Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Sakura Wars So Long My Love [NTSC-U]
#1
[Bug Report] Sakura Wars So Long My Love [NTSC-U]

# PCSX2 version: Official Beta 1888, Official v0.9.6 release
# CPU options: EErec on and off, VUrec0 and VUrec1 on and off, MTGS on and off , microVU0 and microVU1 on and off
# Plugins used: GSdx 890 , 1873 , 2693 (hardware and software dx 9 & 10 on all)
ZeroGS 0.97.1
spu2-x 1.1.0 , 1.2.0 , r2693 1.4.0
ZeroSPU2 r514-dev 0.4.6 , r1455 0.4.6 , r2592-dev 0.4.6
#All speed hacks off
# Description: The error is identical in both versions of the emulator no matter what plugins and settings are used. The only difference is the message the emulator gives for the error. Resuming the game at chapter 7 causes it , you get a black screen and it never loads.

from the logfile:
Code:
[Gnk][File] Device UnAssign [def+]
00180040/00180040/[ADX] E0092911:sceCdSearchFile fail.(dvCiOpen)[ADX] E0092911:sceCdSearchFile fail.(dvCiOpen)

00180040/00180040/[ADX] cvFsOpen #6:open failed[ADX] cvFsOpen #6:open failed

00176e40/00176e40/ROFS assign is failed: DEF.ROFS assign is failed: DEF.

Hope i did this right , i couldnt find an existing thread for this game and provided all the info i could. If any more info would help please let me know and ill try to provide it.
Reply

Sponsored links

#2
Yeah solid bug report good work Smile
Would be best if you could compile the latest SVN revision (something before r2822 since that is bugged) and test the game with that too, although I doubt it will fix it
[Image: newsig.jpg]
Reply
#3
Ty and not a problem. Downloaded SVN r2819 , all tests i ran with it resulted in exactly the same error. If theres anything else i can add that would help let me know.
Reply
#4
At least you got to Chapter 7. I either 1) can't get the game to start (black screen) or 2) game runs great except the text is all messed up.
Reply
#5
Well if you havent yet try playing the game on the beta with the most recent beta plugins. Thats mostly what i played it on , didnt notice any text problems , very few issues at all actually with almost all speed hacks on , the only real problem i encountered was the start of chapter 7.
Reply
#6
Interesting problem. I'd love to figure out these CDVD issues one day, they mess with my plan to fix the long load times and some SIF timing issues Tongue2
I could use your memory card though, to get to that scene fast.

Edit:
Hope you aren't using that undub that's around though.
We've had some cases where the undubber just messed up, and people blame the emulator for it.
Reply
#7
(04-08-2010, 01:36 PM)rama Wrote: Edit:
Hope you aren't using that undub that's around though.
We've had some cases where the undubber just messed up, and people blame the emulator for it.
There shouldn't be an undub for this game, none is needed: you actually get 2 DVDs, one for each audio track (I have both of them here).

Btw, I submitted a GSDX bug report for this game on the issue tracker:
http://code.google.com/p/pcsx2/issues/detail?id=643

Quite unrelated, but maybe you can help: I wanted to try my hand at looking what is happening there myself, but when I try to use "rundll32 GSdx-SSE2-dbg.dll,GSReplay 1 gsdx_20100408191327.gs" I get an error saying that "the specified module could not be found". I checked that the dll exports the GSReplay function though, and of course both files are in the folder and the file names are correct.
Reply
#8
(04-08-2010, 01:36 PM)rama Wrote: Interesting problem. I'd love to figure out these CDVD issues one day, they mess with my plan to fix the long load times and some SIF timing issues Tongue2
I could use your memory card though, to get to that scene fast.

Edit:
Hope you aren't using that undub that's around though.
We've had some cases where the undubber just messed up, and people blame the emulator for it.

Damnit , i knew i forgot something , sorry about that. It is the one with jap voices , but its not some homemade undub or anything. Its the second dvd that it comes with. Anyways heres the memory card , its a bit of a mess but it has the files you need to resume at that part of the game. Packed it with RAR to make it smaller , if thats a problem let me know and ill change it.


Edit: Well i may have reported this too soon actually. After quite a bit more testing using the svn build i was asked to try ive managed to make it past the initial problem. And just in case it will help here is what i was using when it worked.

# PCSX2 version: SVN r2819
# CPU options: EE set to recompiler , IOP set to interpreter , all other options for EE/IOP and VUs set to defaults
# Plugins used: GSdx 2817 (MSVC 15.00, SSSE3) 0.1.16 (Set to DX11 hardware)
spu2-x r2789 1.4.0

Im not really sure what made it work. But ive not tried it after changing these settings. I do know that the last thing i changed the was the IOP setting.


Attached Files
.rar   Mcd001.rar (Size: 384,4 KB / Downloads: 224)
Reply
#9
Yeah, I did try using the beta emulator with beta plugins. That's how I'm getting a black screen, maybe I should try using your configuration but something tells me it's not going to make a difference.
Reply
#10
Well it couldnt hurt to try it. Works for me up until the issue i reported. Here is what i used with the beta:

plugins: gsdx 2693 (MSVC 15.00, SSE3) 0.1.16 (DX10 hardware)
spu-2x r2693 1.4.0 all settings at their defaults
lillypad svn (r1853) 0.10.0
linuz Iso cdvd 0.9.0

cpu options:
everything on

speed hacks:
x1.5 cycle rate
all ee hacks on
all vu hacks on with cycle stealing set to slight speed up

advanced options
all set to defaults

Hope that works for ya.
Reply




Users browsing this thread: 1 Guest(s)