Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Sakura Wars: So Long, My Love [NTSC-U]
#1
# PCSX2 version: Official Beta v0.9.7 beta
# Plugins used: GSdx 3068 0.1.16 (hardware and software, dx10), SPU2-X r3117 1.4.0
# Description: Hi. I just got this game and tried to run it on PSCX2 0.9.7 beta but it crashed. I've searched the forum and most people don't have problem running this game. The following is the log:

PCSX2 0.9.7.r3113 - compiled on May 29 2010
Savestate version: 0x8b430000

x86-32 Init:
CPU vendor name = GenuineIntel
FamilyID = a
x86Family = Intel® Core™2 Duo CPU T9900 @ 3.06GHz
CPU speed = 3.050 ghz
Cores = 2 physical [2 logical]
x86PType = Standard OEM
x86Flags = bfebfbff 0c08e3fd
x86EFlags = 20100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1

Initializing PS2 virtual machine...
Allocating memory for recompilers...

Loading plugins...
Binding GS : C:\Program Files (x86)\PCSX2 0.9.7\Plugins\gsdx-ssse3-r3068.dll
Windows 6.1.7600
NVIDIA GeForce 9600M GT (8.16.11.8861)
Binding PAD : C:\Program Files (x86)\PCSX2 0.9.7\Plugins\lilypad-r2930.dll
Binding SPU2 : C:\Program Files (x86)\PCSX2 0.9.7\Plugins\spu2-x-r3117.dll
Binding CDVD : C:\Program Files (x86)\PCSX2 0.9.7\Plugins\cdvdGigaherz.dll
Binding USB : C:\Program Files (x86)\PCSX2 0.9.7\Plugins\USBnull.dll
Binding FW : C:\Program Files (x86)\PCSX2 0.9.7\Plugins\FWnull.dll
Binding DEV9 : C:\Program Files (x86)\PCSX2 0.9.7\Plugins\DEV9null.dll
Plugins loaded successfully.


Initializing plugins...
Init GS
Windows 6.1.7600
NVIDIA GeForce 9600M GT (8.16.11.8861)
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
* CDVD: Opening drive '\\.\D:'...
* CDVD: IO thread started...
Opening USB
Opening FW
Opening DEV9
* CDVD: Disk Type: No Disc
McdSlot 0: C:\Program Files (x86)\PCSX2 0.9.7\memcards\Mcd001.ps2
McdSlot 1: C:\Program Files (x86)\PCSX2 0.9.7\memcards\Mcd002.ps2
Plugins opened successfully.
Issuing EE/iR5900-32 Recompiler Reset
Bios Version 2.0
Load Bios Warning: rom1 module not found, skipping... (this is not an error)
Load Bios Warning: rom2 module not found, skipping... (this is not an error)
Load Bios Warning: erom module not found, skipping... (this is not an error)
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
# Initialize memory (rev:3.70, ctm:393Mhz, cpuclk:295Mhz detected)
# Total accessable memory size: 32 MB (B:2:8:0) (370:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Feb 6 2003 08:38:48
CPUID=2e20, BoardID=0, ROMGEN=2004-0614, 32M

(IsoFS) Block 0x10: Primary partition info.
(GetElfName) Detected PS2 Disc = cdrom0:\SLUS_219.30;1
(GetElfName) Software version = 1.00
(GetElfName) Disc region type = NTSC
Disc ID = SLUS-21930
(IsoFS) Block 0x10: Primary partition info.
Initializing Elf: 4409432 bytes
ELF (cdrom0:\SLUS_219.30;1) CRC = DD41054D
Entry point = 0x00120008
Game not found in database [SLUS-21930]
(IsoFS) Block 0x10: Primary partition info.
(GetElfName) Detected PS2 Disc = cdrom0:\SLUS_219.30;1
(GetElfName) Software version = 1.00
(GetElfName) Disc region type = NTSC
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
vtlb miss : addr 0x0, mode 0 [read]
vtlb miss : addr 0x0, mode 0 [read]
vtlb miss : addr 0x0, mode 0 [read]
vtlb miss : addr 0x70025F8B, mode 1 [write]
vtlb miss : addr 0x7FF34E40, mode 0 [read]
vtlbDefaultPhyRead32: 0x18054F40

Thanks.
Reply

Sponsored links

#2
Quote:I've searched the forum and most people don't have problem running this game.
Then obviously it's a configuration issue on your end and not an emulator bug. Moved to general discussion.
[Image: newsig.jpg]
Reply
#3
That's what I thought at first. But if you look at the last lines of the log:

vtlb miss : addr 0x0, mode 0 [read]
vtlb miss : addr 0x0, mode 0 [read]
vtlb miss : addr 0x0, mode 0 [read]
vtlb miss : addr 0x70025F8B, mode 1 [write]
vtlb miss : addr 0x7FF34E40, mode 0 [read]
vtlbDefaultPhyRead32: 0x18054F40

To me, those errors look more like a bug compared to configuration issue. Unfortunately I don't have the expertise to comprehend those "misses." And from the log, it can also be seen that all the plugins were able to be successfully loaded. I'm not sure what the problem is. If anyone can tell me their setups, it would be great.

Thanks.
Reply
#4
The game looks like it crashes at boot. I suggest making an ISO image of your game and then using the internal ISO reader to run it. Do NOT mount it to any other external program like daemon tools, that can cause crashes like the one you're getting now.
[Image: newsig.jpg]
Reply
#5
Perfect. I just tried it and it works now. For some reason, it wouldn't boot my PS2 disc. But after converting it to ISO, it works. Thanks for the help.
Reply




Users browsing this thread: 1 Guest(s)