Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug Report] Unable to launch game from ELF (Wild Arms 4 & 5)
#1
So far I've launched about 20 games from the ELF (with widescreen hacks) and none have had issues until I tried it with Wild Arms 5. I later found out WA4 has the same problem. This is the message I get:

Code:
(R5900) Re-executed ELF Entry point (ignored) [addr=0x00100008]

Basically here's what normally happens:

1. Drag ISO into pcsx2, followed by ELF
2. PCSX2 quick boots into game

And here's what happens with WA4 and WA5:

1. Drag ISO into pcsx2, followed by ELF
2. PCSX2 goes into browser
3. I select the disc
4. PCSX2 full boots into game (ignoring external ELF)

I've attached the emulog below, together with an emulog from a successful ELF launch. I should mention WA4 and 5 both can't be booted even from an unmodified external ELF. The only way I'm able to apply the widescreen hack to the ELF is by hex editing the ISO directly. So for some reason the game can launch with a modified ELF, just not an external one.

Edited for more info: This was on pcsx2 5178, but the problem persists as far back as 0.9.7. Game version is NTSC-J. Mounting ISO and selecting ELF manually still results in same problem. If you need more info or logs just ask Smile
Reply

Sponsored links

#2
I think I'll move this on bug reports, so edit to include revisions and such Wink
[Image: newsig.jpg]
Reply
#3
(07-14-2012, 10:47 PM)synce Wrote: I should mention WA4 and 5 both can't be booted even from an unmodified external ELF.

Worked fine here(started it from unmodified external ELF)but what I notest is that the game when booted from external elf,always use the full boot method
Reply
#4
Don't rename the ELF. In the logfile attached i can see you have renamed the file to "SCPS_151.18-WIDESCREEN.elf". There are a lot of games that wont boot or crash in game when the ELF (patched or unpatched) is renamed. Keep the original file name and it should work.
Reply
#5
No luck there... even with unmodified elf it's the same story. I do remember someone saying he was getting crashes when playing from ELF, but I think he fixed it by booting with drag and drop. I'll keep your suggestion in mind though if I ever get a crash, thanks Smile

Also worth noting is that user sergx12 seems to have the same ELF resetting/ignoring problem with Genji and Tsugunai.
Reply




Users browsing this thread: 2 Guest(s)