Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug report] Jak 3 - Extreme slowdown in a specific mission
#1
I've played about halfway through the game without any issues (playability wise) to the point where you have to enter Haven Forest again for a hoverboard mission. Anyway, in this mission, there are flying particles which create "rings" for you to run through. For some reason these simple particle effects cause a massive slowdown when active, dropping the fps from a smooth 45-50 to about 10 or less. As soon as the particle runs through its course and creates the ring, fps becomes normal again, but because it slows down so much, the mission is unplayable.

Some kind of fix would really be appreciated as I'd like to complete the game now that I've gotten so far.

I've tested with and without speedhacks with no difference and tried several svn revisions, the latest official beta, and the latest svn release at point of writing (4054), but they all suffer from the same issue. Using the PAL version of the game.

If needed, I can provide a memorycard file with a save point in the said mission.
Reply

Sponsored links

#2
moved to general discussion until it meets the "Bug report format"

Are you sure it's not a gsdx issue ?
is it the same problem in software mode ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
PCSX2 setitngs? Plugin settings? What do the EE/GS% numbers in the game window say when you get the slowdowns?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
Sorry for not including the settings in the OP, forgot. I'm using Gsdx SSE41 (4031) with internal res set to 1920x1080 and texture filtering enabled, all other settings at defaults. PCSX2 settings are at defaults too (the interpreter stuffs, haven't touched them), and SPU2-X with 2x reverb and 5.1 expansion enabled.

I'll try it again tonight in software mode, didn't think of that, and if it still happens, I'll post the EE/GS numbers.
Reply
#5
Tried it in software mode, and the particle slowdown wasn't there. But my computer's too slow to run it in software mode anyway (medium spec laptop with a core 2 duo t6600 cpu 2.2 ghz, ati mobility 4670 xt), so the whole game ran at around 20-25 fps...

Here's screenies of the EE/GS numbers, using Gsdx, before and after activating the mission (statue thingy):

http://img155.imageshack.us/img155/8302/jak3bug1.jpg

http://img408.imageshack.us/img408/9959/jak3bug2.jpg

Another thing is that sometimes the game is unable to make the checkpoint rings appear at all and the particles just float still for an eternity while the clock counts to zero. This happens in both software and hardware mode. I was able to run through the first rings now on second try though despite the slowdown...odd.

It has to be some kind of bug because the game can render MUCH more complex scenes, like the entire city with lots of npcs fighting each other all over the place, at 40 fps or more.
Reply
#6
Hmmm, there was a recent problem with world of warcraft on ATi cards which was very similar, It isnt an Asus card is it? the overclocking/monitoring tool that runs in the background has been causing problems, make sure any programs like that are closed.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
Looks like a problem with using that high resolution, try enabling/disbaling the "allow 8-bit textures" and reducing the resolution or simply enabling "native" in GSdx, lastly you could try frameskip while playing that part (shift+f4 to toggle it).
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#8
(11-26-2010, 01:08 PM)refraction Wrote: Hmmm, there was a recent problem with world of warcraft on ATi cards which was very similar, It isnt an Asus card is it? the overclocking/monitoring tool that runs in the background has been causing problems, make sure any programs like that are closed.

Nah, it's just a regular Ati Mobility Radeon HD 4670 XT (1 GB). I only have the driver control panel active, but it doesn't have overclocking options afaik.

(11-26-2010, 01:24 PM)Shadow Lady Wrote: Looks like a problem with using that high resolution, try enabling/disbaling the "allow 8-bit textures" and reducing the resolution or simply enabling "native" in GSdx, lastly you could try frameskip while playing that part (shift+f4 to toggle it).

Thanks for the suggestions, I managed to "grind" through it myself just now (took quite a few retries but I managed to do it by looking the other way while waiting for the particle to "run its course" Tongue). If I run into this kind of bug again I'll try those.
Reply




Users browsing this thread: 1 Guest(s)