Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[Bug report] Ratchet and clank 1-4 pal
#1
# Playground version: rev 513 28.12.2008
# Cpu eerec on, vurec0 and vurec1 on, MTGS on
# Plugins used: Gsdx 0.1.12 or zerogs 97.1, spu2ghz 1.9.0 or zerospu 0.46
# Description: Every Ratchet game (made by insomniac 1-4) Has the same problem. They works all great till when you select new game and you can watch the opening intro but then the screen just goes black, it doesn´t hang,
looks like it just stops reading the dvd or image. The last line in ps2 output is always #iop recompiler data reset# or #bgezal#. I tryed skip video patch and save states but they dont help. I have tryed these games in many revisions in official and beta at many different settings but always the same.

TESTED WITH 0.9.6 STILL THE SAME PROBLEMS:/

Sponsored links

#2
This looks like it might have been an "easy" fix (for however few exist in Pcsx2!). Some of the Branch and Link instructions were never finished. I've attached a set of builds for you to test -- one each VM and VTLB. They're dev builds so they might dump a bit more info to the console than you're used to. That's ok. Smile

Let me know if they fix the problem or make it behave differently.


Attached Files
.7z   pcsx2-pp-devtest-ratchet.r527.7z (Size: 868,91 KB / Downloads: 561)
Jake Stine (Air) - Programmer - PCSX2 Dev Team
#3
Sorry but they dont fix the problem. I tryed all the games but just the same thing. Only difference i see is that the last line in the console is now #bltzal#
Maybe they need some kind of hack to work. You can see the place where it stops in those screenshots. 1 shot of every game.

But thanks from trying to fix it, im sure you will find the problem at some pointLaugh


Attached Files Thumbnail(s)
               
#4
(01-01-2009, 03:57 PM)kingis Wrote: Sorry but they dont fix the problem. I tryed all the games but just the same thing. Only difference i see is that the last line in the console is now #bltzal#
Maybe they need some kind of hack to work. You can see the place where it stops in those screenshots. 1 shot of every game.

But thanks from trying to fix it, im sure you will find the problem at some pointLaugh

http://www.youtube.com/watch?v=lvmGAmduJV8
This one works, although I haven't been able to tweak mine to work that well yet....
#5
Yes, but that has been made by different team and is only a bad port from psp.
I,m talking about those 4 first ps2 games made by insomniacSmile
#6
Just wondering if anyone has any more info as to why the game doesn't load. I'm a bit curious.
MotherBoard:nForce750i
Cpu:Intel Core2 Duo E8400 @ 3.6 Ghz
Ram:2.0Gb @ 960 Mhz DDR2
Graphics Card: GeForce 8800 GT
Core Bus @ 733 Mhz
Memory Bus @ 1011 Mhz
#7
None of the newer builds fix the problems Sad

I hope they fix this soon.
#8
i don't understand why is not working,game is older than 4 years,so it should be working. someone must write some new fix so we can play it!
#9
Wrong reasoning, snake44. Totally wrong.
#10
(03-17-2009, 11:30 AM)snake44 Wrote: i don't understand why is not working,game is older than 4 years,so it should be working. someone must write some new fix so we can play it!

The idea of teleportation is about 20 years old

what? you telling me you down have your own teleporter??
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!




Users browsing this thread: 1 Guest(s)