Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Bugged controls, moving on its own?
#1




What causes this? See how my character is twitching to the left? It happens in all games, on menus, everything. If I wait for a minute it will stop, but after a while the problem returns.
This happens when I'm doing absolutely nothing. I put my controller on the desk and it still does it.
I'm using a PS3 controller and I've disabled Sixaxis so that is not the issue. This is a new controller and it was working fine until yesterday, I was messing around with various settings but I have no idea what I've done.

In addition to PCSX2 I'm using Motioninjoy and Joy2Key (so I can take screenshots with my PS button).

Please help.
Reply

Sponsored links

#2
sounds like your analog stick isn't sitting quite centre when it returns to the middle, causing it to continue moving. you could probably increase the deadzone in lilypad to reduce this.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
That would be unfortunate, I've given the deadzone increase a try and I will report back with the results.

The thing is though, it's not a consistent issue. It's a transient problem, it'll do this for a minute and then it'll be okay for a while, then it will come back. Even if I lay the controller flat on my desk it will still do this little twitching. If the analog stick was loose or off-center, wouldn't it just be a smooth movement to the left instead of an occasional twitchy one?
Reply
#4
its depends if its off by much or if the value reported back to the PC is flickering. I can't think of any other reason why it would twitch like that, unless motionjoy/joy2key are having a fit, which wouldn't be suprising, motionjoy is poorly coded.

You could also try this instead of motionjoy http://forums.pcsx2.net/Thread-XInput-Wr...#pid275346
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
I cranked the deadzone as high as it would go and I'm still having the issue.
Reply
#6
Try that xinput thing instead of motionjoy, also don't have joy2key open, just in case.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
(12-31-2012, 01:58 AM)SkeletonBill Wrote: I cranked the deadzone as high as it would go and I'm still having the issue.

Go to the "Devices and Printers", right click the pad's icon and then "Game Controller Settings". Once in "Properties" go to "Settings" and try calibrate it there.

Good Luck.
Imagination is where we are truly real
Reply




Users browsing this thread: 2 Guest(s)