Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Build PCSX2 on Slackware 14.0
#1
Hi everyone,

I just build PCSX2 revision 5475 on BlankOn 7.0 (Ubuntu Natty Indonesian version) successfully and running well; on IGN 8.0 (Fedora 17 Indonesian version) successfully and running well; on Slackware 14.0 successfully and can't run well anyway ! I think it's cause of sound system on Slackware 14.0 and the GPU plugins. PCSX2 revision 5475 myself compiled on Slackware 14.0 only can run well using GSdx SDL 1.3 and SPUnull.

Can anyone help me how to build PCSX2 revision 5475 on Slackware 14.0 ?
Reply

Sponsored links

#2
What are the dependencies you are missing? Are you on 32 or 64 bit? If Slackware supports multiarch it would be easier to install 32 bit version of dependencies. I will admit I do not know much about Slackware. What does you terminal log show when you try to do cmake?
Reply
#3
Missing depedencies i think only nvidia-cg-toolkit, because i must install manually from rpm / deb to my Slackware. I'm using Slackeware 14.0 32 bit. I'm using the newest library for GLEW v 1.9, Portaudio v19 and soundtouch v 1.7. The other like wxGTK, SDL not the newest version.
I will show terminal log from cmake as soon as possible in here.
Thank you for attention.
Reply
#4
Quote:bash-4.2$ cmake -DEGL_API=TRUE -DGLSL_API=TRUE ..
-- The C compiler identification is GNU 4.7.1
-- The CXX compiler identification is GNU 4.7.1
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- BuildType set to Devel by default
-- Disable the stripping by default in Devel build !!!
-- Disable the building of po files by default in Devel build !!!
-- EGL is experimental and not expected to work yet!!!
-- Found Freetype: /usr/lib/libfreetype.so (found version "2.4.10")
-- Found GTK2_GTK: /usr/lib/libgtk-x11-2.0.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Found ALSA: /usr/lib/libasound.so (found version "1.0.26")
-- Found BZip2: /usr/lib/libbz2.so (found version "1.0.6")
-- Looking for BZ2_bzCompressInit in /usr/lib/libbz2.so
-- Looking for BZ2_bzCompressInit in /usr/lib/libbz2.so - found
-- Found Gettext: /usr/bin/msgmerge (found version "0.18.1")
-- Found JPEG: /usr/lib/libjpeg.so
-- Found OpenGL: /usr/lib/libGL.so
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - found
-- Found Threads: TRUE
-- Found SDL: /usr/lib/libSDL.so
-- Found Subversion: /usr/bin/svn (found version "1.7.6")
-- Found wxWidgets: TRUE
-- Found ZLIB: /usr/lib/libz.so (found version "1.2.6")
-- Looking for EGL_KHR_create_context
-- Looking for EGL_KHR_create_context - not found.
-- Found EGL: /usr/lib/libEGL.so
-- Could NOT find Cg (missing: CG_LIBRARIES)
-- Found GLEW: /usr/lib/libGLEW.so
-- Found Libc: /usr/lib/librt.so;/usr/lib/libdl.so;/usr/lib/libm.so
-- Found PortAudio: /usr/lib/libportaudio.so
-- Found SoundTouch: /usr/lib/libSoundTouch.so
-- Found SparseHash: /usr/include
-- Found SparseHash_new: /usr/include
-- Skip build of zerogs: miss some dependencies
-- check these libraries -> glew (>=1.6), opengl, X11, nvidia-cg-toolkit (>=2.1)
CMake Warning at plugins/zzogl-pg/opengl/CMakeLists.txt:61 (message):
Current EGL implementation doesn't support openGL context. Fallback to
standard GLX.


-- Configuring done
CMake Warning at pcsx2/CMakeLists.txt:650 (add_executable):
Cannot generate a safe linker search path for target pcsx2-dev because
files in some directories may conflict with libraries in implicit
directories:

link library [libz.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [librt.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [libdl.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [libm.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib

Some of these libraries may not be found correctly.


CMake Warning at plugins/CDVDiso/src/CMakeLists.txt:70 (add_library):
Cannot generate a safe linker search path for target CDVDiso because files
in some directories may conflict with libraries in implicit directories:

link library [libbz2.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib

Some of these libraries may not be found correctly.


CMake Warning at plugins/GSdx/CMakeLists.txt:179 (add_library):
Cannot generate a safe linker search path for target GSdx-0.1.16 because
files in some directories may conflict with libraries in implicit
directories:

link library [libGLEW.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib

Some of these libraries may not be found correctly.


CMake Warning at plugins/GSdx/CMakeLists.txt:218 (add_executable):
Cannot generate a safe linker search path for target pcsx2_GSReplayLoader
because files in some directories may conflict with libraries in implicit
directories:

link library [libGLEW.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib

Some of these libraries may not be found correctly.


CMake Warning at plugins/spu2-x/src/CMakeLists.txt:105 (add_library):
Cannot generate a safe linker search path for target spu2x-2.0.0 because
files in some directories may conflict with libraries in implicit
directories:

link library [libportaudio.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [librt.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [libdl.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [libm.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib

Some of these libraries may not be found correctly.


CMake Warning at plugins/zzogl-pg/opengl/CMakeLists.txt:250 (add_executable):
Cannot generate a safe linker search path for target pcsx2_ZZReplayLoader
because files in some directories may conflict with libraries in implicit
directories:

link library [libGLEW.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [libjpeg.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [libz.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [librt.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [libdl.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [libm.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib

Some of these libraries may not be found correctly.


CMake Warning at plugins/zzogl-pg/opengl/CMakeLists.txt:157 (add_library):
Cannot generate a safe linker search path for target zzogl-0.4.0 because
files in some directories may conflict with libraries in implicit
directories:

link library [libGLEW.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [libjpeg.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [libz.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [librt.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [libdl.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib
link library [libm.so] in /usr/lib may be hidden by files in:
/usr/X11R6/lib

Some of these libraries may not be found correctly.


-- Generating done
-- Build files have been written to: /home/setiajie/Games/pcsx2-r5475/build
bash-4.2$

Quote:bash-4.2$ uname -a
Linux darkstar 3.2.29-smp #2 SMP Mon Sep 17 13:16:43 CDT 2012 i686 AMD A6-4400M APU with Radeon™ HD Graphics AuthenticAMD GNU/Linux

Quote:[100%] Building CXX object plugins/zerospu2/CMakeFiles/zerospu2.dir/Targets/SoundTargets.cpp.o
Linking CXX shared library libzerospu2.so
[100%] Built target zerospu2
bash-4.2$
Reply
#5
My installed plugin :
   

FREEZE when running !
   
Reply
#6
Your cmake said you are missing the cg-toolkit. Not being familiar exactly with Slackware terminology, I can at least say that either the lib is called nvidia-cg-toolkit or ...libcg and libgl (2 different libs). Here is an excerpt (not all inclusive) of my ldd command for libGSdx-0.1.16.so ...

amd-apu@amd-apu:~$ ldd /home/amd-apu/Desktop/pcsx2-linux-r5464/plugins/libGSdx-0.1.16.so
linux-gate.so.1 => (0xb76e4000)
libX11.so.6 => /usr/lib/i386-linux-gnu/libX11.so.6 (0xb6ec6000)
libGLEW.so.1.8 => /usr/lib/i386-linux-gnu/libGLEW.so.1.8 (0xb6e60000)
libGL.so.1 => /usr/lib/fglrx/libGL.so.1 (0xb6d75000)
libgobject-2.0.so.0 => /usr/lib/i386-linux-gnu/libgobject-2.0.so.0 (0xb6d25000)

Plus plenty more dependencies, all satisfied.

You could try ldd command on your GSdx plugin to find the exact name of missing dependencies it wants on your system. Plus don't forget to use proprietary GPU drivers, not mesa.

In the meantime one of the ZZogl plugins is based on GLX not Nvidia toolkit, so it should work for now. I just can't remember if it is 0.3 or 0.4.
Reply
#7
I think the cause of freeze is GPU and SPU on Slackware 14.0 because i try to play using pcsx2 binary revision 5475 from BlankOn 7.0 build (run very well on BlankOn 7.0), it freeze also.
Reply
#8
It freeze because you play with experimental flags Wink
-DEGL_API=TRUE => Replace GLX by EGL. Need at least Intel GPU and mesa 9.0 but not tested so unlikely to run.
-DGLSL_API=TRUE => Replace Nvidia's CG (Nvidia is the creator of the lib, it doesn't mean that it won't work with any GPU) by GLSL (only impact zzogl 0.4). Because of the poor state of the fglrx driver, it could either crash/freeze/hard lock your computer/run nicely

Edit: maybe try the attached patch for glsl.
Reply
#9
Thanks everyone, after i fix my sound configuration (Slackware 14.0 using ALSA and OSS by default). My PCSX2 release 5475 compiled on Slackware 14.0 run well but the graphic / video is lag. I'm using AMD Catalyst 12.11 beta for my GPU driver on Slackware 14.0.
Reply
#10
(12-14-2012, 11:40 PM)setiajie82 Wrote: Thanks everyone, after i fix my sound configuration (Slackware 14.0 using ALSA and OSS by default). My PCSX2 release 5475 compiled on Slackware 14.0 run well but the graphic / video is lag. I'm using AMD Catalyst 12.11 beta for my GPU driver on Slackware 14.0.

Problem solved : I can run PCSX2 release 5475 on my Slackware 14.0 well after i fix ALSA conflict problem (default sound system) and i change KDE4 desktop effects -> Advanced -> Compositing type = OpenGL


Attached Files Thumbnail(s)
   
Reply




Users browsing this thread: 1 Guest(s)