Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CPU & RAM Usage
#1
I'm not exactly sure if this question was already answered, but when I use the emulator on my computer, the frame rate is really slow when I play any game on it. It doesn't use much of my RAM or CPU, about half of RAM and CPU is only being used (not exactly half is being used just by Pcsx2, maybe only about 150,000-220,000). Is there a way that I can have the emulator access more of my CPU and RAM so that it won't lag? The attached files show computer info and the current Plug-in settings I have applied. If further information is required I will find the information and give it to you.


Attached Files Thumbnail(s)
                                   
Reply

Sponsored links

#2
(08-14-2012, 03:21 AM)Vincey94 Wrote: It doesn't use much of my RAM or CPU, about half of RAM and CPU is only being used

probrably you're in battery mode assuming if your battery level at below 60% then the computer will FORCED to use less cpu/gpu power
and addition to power saver best to set to "Balanced" or "High performance"
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#3
(08-14-2012, 04:12 AM)tallbender Wrote: probrably you're in battery mode assuming if your battery level at below 60% then the computer will FORCED to use less cpu/gpu power
and addition to power saver best to set to "Balanced" or "High performance"

I'm plugged in, I've actually been plugged in all day and have Graphic and CPU settings set to be High Performance and Quality when plugged in regardless of battery percentage.
Reply
#4
how about your temperatures this is also giving CPU/GPU cuts once the temps is 90C~above
download CoreTemp.
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#5
(08-14-2012, 04:37 AM)tallbender Wrote: how about your temperatures this is also giving CPU/GPU cuts once the temps is 90C~above
download CoreTemp.

The current info I received from the application is in the attachment.


Attached Files Thumbnail(s)
   
Reply
#6
you need to run coretemp and pcsx2 simeonteonusly for about an hour to read the pcsx2's peak temperatures.
pls. try again
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#7
(08-14-2012, 05:05 AM)tallbender Wrote: you need to run coretemp and pcsx2 simeonteonusly for about an hour to read the pcsx2's peak temperatures.
pls. try again

Here you go Smile
Plus toward the bottom left, there are bars on a quarter circle. The farthest from the middle is my RAM & the 3rd farthest is my CPU, the first is my 422GB HDD and the second is my 29GB Default system partition for Lenovo system programs. I was running Kingdom Hearts 2 Final Mix+, the core temp application, and Google chrome. Compare the picture before I ran Pcsx2 and when I did, you can see difference in CPU & RAM.


Attached Files Thumbnail(s)
   
Reply
#8
The frame rate is very slow because the your CPU and GPU are very weak.
Reply
#9
Disable Dynamically toggle vsync in Emulation settings->GS window, disable Aggressive CRC in the GSdx hacks dialogue. Also post a screenshot of CPU-Z while running PCSX2 and getting the slowdowns (first screen where it shows CPU clocks) to see if the CPU scales the multiplier properly
[Image: newsig.jpg]
Reply
#10
Applications take as much ram as they need, not more unless they're buggy and have memory leaks(happen with some ps2 games under pcsx2, but that's BAD and unwanted;P), it also doesn't affect pcsx2 speed at all unless you would have soo little ram that your system would need to use hdd swap file and slowdown itself by doing so, in other words be happy that only small portion of ram is used, that's completely correct behaviour and nothing really you should like to change.

Now time for the bad info, Core temp shows that your CPU is getting downclocked to a stupid 800mhz that's probably not enough even to run the lightest of the games at full speed(unless maybe Monster Hunter 2 as that game seems to have no requirements at all lol;P), your max temp also is reaching 85 degrees Celsius, it's quite possible that overheating is your problem. Double the chance couse you're using intel hd not having dedicated gpu in there meaning it's generating loads of additional heat and slow downs while probably not having enough juice to reach full speed from the start.

In other words, if you don't have a dedicated gpu in this laptop and accidently using intel hd(any hidden nvidia in there with optimus drivers?), you'll not be able to play much at it. Even if for some light games intel hd 3000 is enough to reach full speed(which to begin with is rare) using it to render graphics additionally overheats your cpu and it will slow down to cool itself down pretty often. Putting it simple to a brutal truth, we'll not be able to help you much and don't expect much more than you already see.
Reply




Users browsing this thread: 1 Guest(s)