Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CPU usage drops to nearly 0%
#1
For a long time I could play games on pcsx2 without any issues however a few months ago these issues came out of nowhere and I've no idea how to fix them.

At seemingly random points in all games, my fps will go from a solid 60 down to either 40 or sometimes 20. It varies with each game. Cutscenes in some games, in game dialog in others, it seems to be random. Examples include speaking to Issun in okami and the pictures that appear the first time you pick up an item in devil may cry 2, (both of which are not graphically demanding).

Using Msi afterburner I checked my CPU usage, and during these moments all cores drop to nearly 0%. All of my temps check out. I've tried turning on and off turbo mode and hyper-threading in my bios. I've tried messing with my graphics card settings. I've tried using speed hacks, and tried rolling back video drivers, but to no avail.

It feels like something is deliberately stealing my performance, tho I have checked my processes list and there are no additional items during these laggy periods. Strangely tho if i press ctrl, alt, del my fps jumps back up to 60! however when return to the game it drops back down.

The second issue I have is the when the game IS running at 60 fps I get something similar to micro stutter. I say similar because its not like microstuttering I've seen in the past. 50% of the time it runs as it should, the other 50%? not so much. This too only happens in certain places

I hope I'm not missing something painfully obvious. I'm not the smartest guy when it comes to tech!

Does anyone out there think they can help!?
Thanks for reading.

PS. I have a m14x laptop with a geforce 555m gpu, a i7-2720QM CPU, and with 8gb of ram.
Reply

Sponsored links

#2
Is it plugged in and at a maximum performance power plan?

Are you running the games from an ISO image or from a disc?
[Image: newsig.jpg]
Reply
#3
I'm using an iso image, its plugged in and I'm using the high performance power plan.
Reply
#4
Hm maybe some kind of mess up with the graphic card drivers. In GSdx settings, select the dedicated graphics card under adapter. If that doesn't help either, check if the issue still happens if you have PCSX2 windowed (or full screen if you're now using it windowed)
[Image: newsig.jpg]
Reply
#5
(10-15-2014, 12:55 PM)Bositman Wrote: Hm maybe some kind of mess up with the graphic card drivers. In GSdx settings, select the dedicated graphics card under adapter. If that doesn't help either, check if the issue still happens if you have PCSX2 windowed (or full screen if you're now using it windowed)

since,his core speed drops nearly to 0, i rather doubt that's the case.this isnt a problem of graphics driver its related to the cpu. and how about setting pcsx2's priority to high in taskmanager and disabling all speed hacks and using micro recompiler if you are using super vu and turn most of the settings to default. if the problem is still unsolved, then try resetting the bios and changing your cpu configurations in bios (in case if there's any error in the processor).and, to be on the safer side try using your laptop while it is charging since, most users get a performance boost while using their laptop while charging.... Biggrin
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#6
Can you check gpu clock and cpu clock during these lags? You can use CPU-Z & GPU-Z for that purpose.
Reply
#7
It seems to me like his HDD is stopping or going into power saver mode. Stick with me here. Since you can change the settings in those modes check it out. Sometimes power plans in windows conflicts with bloatware that manufacturers install. If temps and all that are fine then it is basically saying I am not being used so go to a power saved mode. My desktop does this with its video card and cpu a lot unless I turn the boost or power saving modes in the bios for cpu and in your video card software. Least with my video card I have to max out all my settings or just tell it to run 100% so my game doesn't get stutters.
MOBO - ASUS Maximus VII Hero
CPU - Intel i7 4790k 4.4GHZ
RAM - 16 Gigs DDR3 2133mhz
HDD - 3 500 Gig SSD 1 3 TB 7200 RPM
GPU - EVGA Nvidia GTX 1070 SC
OS- Windows 10.
Reply
#8
I've reset my bios but unfortunately the problem hasn't gone away. As for turning off power saving modes, I've already tried turning off turbo mode, Intel speedstep and power saving C states.

I've installed CPU-Z and GPU-Z, here is a pic http://postimg.org/image/u32lmdgvx/
Without anything running (just on the desktop) the CPU core clock usually sits around 2990 to 3280 MHz and the multiplier in between x30 and x32. However every minute or so it will drop all the way down to 797 MHz with the multiplier at x8, this only lasts for a few seconds though. During pxsx2 gameplay it seems to jump down to 797 more often and during the the laggy periods. It seems to sit on 797 MHz more offten, though it does still jump back up to around 2990 occasionally.

I also made sure to select my dedicated GPU in the video pluggin settings, and the problem affects fullscreen and windowed modes.
Reply
#9
i'm afraid i am out of ideas, and does this happen only for pcsx2 or for any other app does it slow down.....
most likely its a problem of hardware......
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#10
It only seems to happen during pcsx2. you think it could be a faulty CPU?
Reply




Users browsing this thread: 1 Guest(s)