Thread Rating:
  • 1 Vote(s) - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can GSdx be enabled to change to display's native resolution in fullscreen mode?
#1
Question 
Hi. First of all, thank you for putting your time and work on this project.

My LCD display has 1600x900 of native resolution but I find things get a little tiny for browsing and working on the desktop, so I use an interpolated resolution, 1366x768. I can either set this on Windows's display manager or Nvidia Control Panel.

When it comes to emulators and PC games I always prefer the display's native resolution, because I play using fullscreen and can have a more clear and detailed picture in that mode without affecting my desktop preferences. I'm used to doing that in most emulators out there, such as SNES9x, Fusion, FBA, Dolphin, etc. But I'm not being able to do that with PCSX2. I choose my display's native resolution the first time I configure the GSdx plugin, and when I go fullscreen mode ("Alt + Enter") the video doesn't change and my desktop resolution is preserved, which shows me a more blurry picture.

I made a quick research in this forum and found the issue was commented in this thread: http://forums.pcsx2.net/Thread-Please-ad...on-setting

It seems that changing the video mode is no longer available in updated GSdx plugin releases. Well, I know LCD displays are intended to be used with their native resolutions and that one could change the video mode prior to running PCSX2 if ever desired. But many may find quite hard and visually unconfortable to work on desktop and browse using the display's native resolution specially on bigger screens (32'', 42''...) and high resolutions (1080p), and changing the desktop's resolution with only one program in mind is not really user-friendly when talking about emulators.

So, if really removed, I'd like to know whether this feature could come back on a future and updated GSdx/PCSX2 release, and have the resolution changeable without being forced to reset all the configs.

Thanks so much for the attention.


PS: my PC specs are Windows 7 x64, E8400 @ 3.0GHz, 4GB RAM, Nvidia 8800 GTS 512MB with driver version 275.33.
Reply

Sponsored links

#2
just put the resolution to 1600 / 900 before playing any ps2 games? its not that much of a hassle....
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply
#3
Use the NirCmd tool and make a batch for PCSX2.
With it you can change the resolution, load PCSX2, and revert it on close.
[Image: nbKSK.jpg]
Reply
#4
I thank you guys for the replies. I should give NirCmd a try someday to see how it works. However, this is more like a workaround than a solution for the problem.

Being able to set the resolution used in fullscreen mode is like a standard feature in most emulators out there. That's why I'd like to know whether this option could work again on a future GSdx/PCSX2 update. Adding it won't affect anyone that already has the desktop with the display's native resolution, but rather benefit those who may find it unconfortable for some reasons. Besides, it would make PCSX2 more user-friendly.

Thanks in advance.
Reply
#5
Have you tried a larger DPI instead of a lower res?
Reply
#6
GSdx shows the first time config screen as a bug;P I once made a patch to fix it(removing obsolete not-used parts), but it was completely ignored. Those options do absolutely nothing and are just a leftover from ancient GSdx builds which HAD fullscreen mode(opposite to new one which simply stretches the window).
Probably there are no plans of restoring the fullscreen mode, soo forget about those confusing ghost-options from first time config. Workarounds is all you can do for your problem.
Reply
#7
(08-22-2012, 12:10 PM)miseru99 Wrote: GSdx shows the first time config screen as a bug;P I once made a patch to fix it(removing obsolete not-used parts), but it was completely ignored. Those options do absolutely nothing and are just a leftover from ancient GSdx builds which HAD fullscreen mode(opposite to new one which simply stretches the window).
Probably there are no plans of restoring the fullscreen mode, soo forget about those confusing ghost-options from first time config. Workarounds is all you can do for your problem.

wait a second is this really true?!?!?! The option to set your resolution upon first configuring gdsx is just a phantom option for show, and doesn't really change your display res when starting the game? WTF? So does that mean even though my display is running 1080p, the game is not running in fullscreen 1080p? If so, what resolution *IS* it running in?
Reply
#8
Desktop resolution and Mhz. Its not real fullscreen like in PC games. Emu just stretchеd picture to the whole screen,nothing more.Like maximizing any program window, with just hidden top bar.
Reply
#9
Read the blog about it: [blog] A new kind of fullscreen!
[Image: nbKSK.jpg]
Reply
#10
(08-22-2012, 04:03 PM)KrossX Wrote: Read the blog about it: [blog] A new kind of fullscreen!

Very interesting and thank you very much for the link!
Reply




Users browsing this thread: 1 Guest(s)