Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can I disable that bilinear filtering when using software renderer in full screen?
#1
I mostly play 2D fighting games in PCSX2, and in some of them, I need to use software renderer, but when going fullscreen (my monitor is 1920x1080), it's possible to note some anti-aliasing applied.

It affects all games, in all screens, everytime, as it's probably some global anti-aliasing feature, that's applied when not using hardware renderer with the same internal resolution as the monitor...

I provided an example screenshot (attached to this post) to illustrate the problem.

In all the other emulators (for other consoles) I tried, it's possible to use console's native resolution and going full screen without any anti aliasing by changing some setting in the emulator (setting "bilinear filter" to off, etc....), but I couldn't find such option in PCSX2...
Is there some way to disable it?


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
you could use software mode
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Edit manually GSdx.ini to set this option
Quote:linear_present = 0

Be sure, you didn't enable some processing shader such as Fxaa.

Edit: or do you want to disable all bilinear filtering of a game (as you can do in the HW renderer?)
Reply
#4
(02-13-2017, 01:36 PM)gregory Wrote: Edit manually GSdx.ini to set this option

Be sure, you didn't enable some processing shader such as Fxaa.

Edit: or do you want to disable all bilinear filtering of a game (as you can do in the HW renderer?)
Yes, all bilinear filtering needs to be disabled to get the desired result. Software mode looks very blurry/soft in many 2D fighting games.
Reply
#5
Ok. It would be quite easy to add the capability (same as texture filtering). However I don't know where to put the new GUI option.
Reply
#6
(02-13-2017, 07:48 AM)jesalvein Wrote: you could use software mode

I'm already using this


(02-13-2017, 01:36 PM)gregory Wrote: Edit manually GSdx.ini to set this option

linear_present = 0

Be sure, you didn't enable some processing shader such as Fxaa.

Thanks!
"linear_present = 0" removed the blurry effect for most games.

However, "Street Fighter Alpha: Anthology" remains with some filtering.

It seems like some interlacing....But i'm not sure.... It happens only in SW mode, still.


I attached two pictures to illustrate the difference between HW and SW renderers. (Note the "SFAA Software mode" picture is already with "linear_present = 0" in the ini file)

HW version looks very sharp and clear....

It seems like what I need is some kind of "Texture filtering: nearest", but in software mode...
Is it available in some form?



(02-13-2017, 02:32 PM)gregory Wrote: Ok. It would be quite easy to add the capability (same as texture filtering). However I don't know where to put the new GUI option.

Maybe in the very bottom of "Plugin Settings..." dialog, alongside "Shader Configuration" and "OSD Configuration"?

As they already are global options that affect all rendering modes (so I think), maybe that "linear_present" setting could be there as well?

Thanks for your help so far!


Attached Files Thumbnail(s)
       
Reply
#7
On linux linear present is available (with post-processing shader). However there isn't yet a solution to remove filtering on SW renderer.
Reply
#8
You can control current SW filtering with the HW option. GUI will be udpated soon.
Reply




Users browsing this thread: 1 Guest(s)