Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can someone help me with soul reaver 2
#1
Hi,
I'm trying to get soul reaver 2 to run on pcsx2 0.9.8 and 0.9.9 with d3d9 and d3d11 with no luck. Game plays fine until when you have to first switch to the spectral realm to pass through the gate at the sarafan stronhold. The game freezes wheb the soul reaver tries to manifest itself. I've tried gdsx 3 and 4.1 at 1-6x sampling. I tried native resolution and same thing. Using the latest spu-x. If i run th game in software mode it works, but looks like garbage and the part where it would freeze with gdsx, with software by pressing f9 i get a horrible pitch coming out of the speakers. I tried the iso and the dvd. The game has no scratches since i bought it new when it first came out. I just played metal gear solid 3 and thats a cpu intensive game and it played great all through out with gdsx 4.1 and 3x sampling.
My specs are
windows 7 ultimate 64bit
i7 2600k @ 4.6ghz
8gb kington hyperx
gtx 470
360 wireless controller
Thanks

Sponsored links

#2
Works fine here with default settings.
Make sure frameskip is disabled and that you're not using any hacks in GSdx or PCSX2.
you can always try other plugins like ZeroGS or ZZOgl.

What do you mean exactly when you say it's "freezing"? The music is still there? You can switch to software and it works while it's "freezing" in hardware?


And just my opinion but in this game software looks better cause hardware has those broken textures all around Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
#3
(08-09-2011, 04:45 AM)Shadow Lady Wrote: Works fine here with default settings.
Make sure frameskip is disabled and that you're not using any hacks in GSdx or PCSX2.
you can always try other plugins like ZeroGS or ZZOgl.

What do you mean exactly when you say it's "freezing"? The music is still there? You can switch to software and it works while it's "freezing" in hardware?


And just my opinion but in this game software looks better cause hardware has those broken textures all around Tongue2

Thanks for the reply. With ZZ i get a black screen than the emulator crashes. It freezes at the part when the soul reaver is starting to come out of his hand It's silent loses sound. If i switch to software the freeze is still present. In software it plays fine, but then there's a loud screeching sound that comes out of my speakers. I'm not using any speed hacks or frameskip.
#4
It's a cutscene Freeze, where the game is supposed to have Raziel Talk for a bit regarding the stuff that's going on, If for some reason this doesn't happen, it can't return to gameplay, I think it's sound plugin or Emu Core related, though I would say it's likely the sound plugin cause, I've already tried, plenty of stuff to fix it. Some stuff I have tried, got me to the Light Forge, but I say, I had to go though heck to get there, considering all the Sound related 'Soft Freezes', I think it's a sound Problem that causes the problem although it could still be Emu Core Related.. The Issue simply disrupts gameplay, however the Start Menu is still accessable, but to neutralize this issue even for a little while, a Restart of the ISO is needed. Till they fix it totally, try Fooling with the Clamp and Rounding Modes... Sometimes after doing so, you can go farther then that location... Be warned though, if the issue has triggered already, you have to restart the ISO.. and it only seems to delay the sound glitch that caused the issue, so save frequently when possible.. I guarantee that it will mess up the instant a cutscene occurs without the voices, oh and just before it happens the sound can really go nuts, and then at that point if a cutscene happens, with No Voices Instant Issue upon the normal end of the cutscene. It's like it just won't go forward with the game, but the Start Menu still works, it simply won't resume gameplay. Oh and, during this issue, you can enter and Exit the Start Menu, even mess with Menu items, but gameplay won't go forward. Good Luck, fixing this one, I fear only the DEVs can fix this one 'with a new Release', Good Luck regardless though.
#5
If it's a problem with voices not happening then you should try with SPU-X 2.0 or even ZeroSPU2 where it all should be working.

But again I still got no problem even without those Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
#6
If it helps, my Sound Chipset is 'Realtek HD Audio' Driver Version 5.10.0.6353, and I'm using the latest SVN which is '4873', and I will add, with certain settings, it takes quite awhile for the issue to happen, but when it does, the Sound goes crazy, and I have noticed a simliar high pitched tone, before it glitches, then during a cutscene, no voices where there were before. and then it won't continue gameplay. You can however, quit to the main menu. and reload a save or start a new game, but i think until restarting the iso the problem remains.
#7
I found a fix, first an upgraded Sound Chipset driver, solved some of it, but still after LONG periods of time like 2-5 Hours, it would still have a cutscene Freeze like happening, so I tried the Crappy Alternate Buffer Mode found in Spu2-X, and bingo, Sound/Music= Flawless and best of all NO Cutscene Freeze or Hang... I got much farther this way, from an old save near the beginning to the Fire Forge area. P.S. That's really far.

Anyway, I do wonder why the above mode, fixed it as I have no troubles with other games, as a rule.

In Fact, the only remaining issue I know of for me at least, is Terminator 3 Redemption. And that crashes to the desktop by the Graphics Plugin...
#8
i have the same problem Angry

any one have a solution ?  Laugh
#9
The most recent post in this thread is more than 8 months old. Please create a new thread and refrain from posting in threads older than 8 months in the future. Please also review the forum rules. Thank you.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!




Users browsing this thread: 1 Guest(s)