Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't emulate any games on my PC
#1
As the title states, it seems that I can't play any game that I try to emulate. I've read around the forum and people have constantly been saying that they can run specific games that I've tried at near pefect speed with a set-up lower or more or less the same as mine. I've tried both 0.9.6 and the beta version of the program (and the plug-ins as well) but to no avail, I seem to have a constant 30-45 fps in all of my games. (ICO, SotC, and Dark Cloud 2)

Set-up:

Windows XP
CPU: E8400(C2D) overclocked to 3.6ghz
Ram: 2gb
GPU: XFX 4850 1gb

Like I said, have tried different games and tried different settings and still have no solution to my problem. Anyone care to take a stab at it?

Thanks!
Windows XP
E8400 3.0 Ghz (OCed to 3.6Ghz)
2x1 GB Ram
XFX Ati 4850 1GB
Reply

Sponsored links

#2
What settings and what graphics plugins?

Also note, if you can upgrade to windows 7 (still currently free to download till June 2010) directX10 would give you a very significant speed boost.

One other thing, make sure you have MTGS turned on (dual core support) and use the GSDX plugin. What does it say in the graphics window for CPU% when it's slowing down?
[Image: 2748844.png]
Reply
#3
I've tried both Gsdx and ZeroGS plugins and there's a little boost in FPS on GSDX. I do have MTGS on and here's a ss to show the performance level. Is this the CPU % you're asking for?


[Image: icointromovie.th.jpg]

plugins used in ss:
gsdx 890 sse41
spux2-x 1.2.0

The settings used:
Speed hacks ALL enabled and GSDX Default settings.

[Image: settingsam.th.jpg]

In game:

[Image: ingameq.th.jpg]

Temp usually range in mid 40s (even when playing games such as COD4) but whenever I try to emulate, it immediately goes up to 60+. Is that normal?

If you need any more info, just ask!
Windows XP
E8400 3.0 Ghz (OCed to 3.6Ghz)
2x1 GB Ram
XFX Ati 4850 1GB
Reply
#4
Firstly, I don't think you need speedhacks with your processor and clockrate so turn all of those off for now.
OK well at the top of the window of PCSX2, it says 99% CPU, which is referring to the graphics card so that would be the problem. First thing to do is update your GSdx plugin by getting the latest plugin pack in the link below:
http://forums.pcsx2.net/thread-3716.html
Within GSdx, what are the settings you're using? Can you take a screenshot of the settings in there for us?

You say you tried the latest beta, but since you're using an incredibly old version of GSdx which came with the stable release of PCSX2 I get the feeling you might not be using the latest beta at all. If not, in the link provided above you can also download the latest beta (r1888) so grab that if you haven't.

About the temperature of your CPU, that's normal because PCSX2 is very CPU demanding unlike PC games. Since the CPU is most likely maxed out, the temp is surely to rise.
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB
Reply
#5
Ok, so I tried a fresh install of the beta (downloaded and installed this from your link: The latest Pcsx2 beta installer (RECOMMENDED) can be found here: Pcsx2 beta 1888 installer + plugins) and when I tried opening it, i came across this error.

"This application has failed to start because d3dx11_42.dll was not found. Re-installing this application may fix this problem."

Now i only have access to ZEROGS 0.97.1 plugin. No GPSX plugins available.
Windows XP
E8400 3.0 Ghz (OCed to 3.6Ghz)
2x1 GB Ram
XFX Ati 4850 1GB
Reply
#6
Update to the latest DirectX install (the august redistribution). I'm surprised the emulator didn't automatically force you to. You can download the august redistribution from the microsoft website.

99% CPU usage means you're pushing your GPU too much. Lower the resolution. Also in SotC you may need to use VU cycle steal speed hack (only available in the betas and NOT the stable version)
[Image: 2748844.png]
Reply
#7
Is there something wrong with my set-up/settings that's why the cpu% is 99? What exactly can i do to lower this %? I'm using these settings:

Resolution: 1280x800 60Hz
Direct3d9
Interlacing: None
Aspect Ratio: 16:9
d3d internal res: 1024x1024

CHECKED
allow 8-bit textures
logarithmic z
alpha correction (fba)
windowed

What's the average %? and lastly, is it safe to continue playing at 99%? if not, what's the safe %?

UPDATE:

Played KH2 and it's pretty flawless. No speedhacks and I can still reach a constant 60fps with CPU usage at 70-80+.
Windows XP
E8400 3.0 Ghz (OCed to 3.6Ghz)
2x1 GB Ram
XFX Ati 4850 1GB
Reply
#8
99% CPU usage on the GSdx window means your graphics card is the bottleneck. You can lower the load on your graphics card by reduscing the d3d internal res or by checking the 'native' box (but that will have an impact on video quality). If this usage is above 90% it means you'll get bad FPS since your graphics card is holding you back.
[Image: newsig.jpg]
Reply
#9
So an ATI 4850 isn't enough to play smoothly on some games?
Windows XP
E8400 3.0 Ghz (OCed to 3.6Ghz)
2x1 GB Ram
XFX Ati 4850 1GB
Reply
#10
As I said you can lower the internal resolution to lower the load. Yes for some games it might not be enough, as you see yourself Kingdom Hearts 2 works fine while the others don't. Make sure you use the latest released beta (rev 1888) and the GSdx plugin that comes with it that has some important speed issues with Ati cards fixed.
[Image: newsig.jpg]
Reply




Users browsing this thread: 1 Guest(s)