Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Can't get KH2 to work (booting from ISO)
#1
I made an ISO of Kingdom Hearts 2, because it wouldn't load from the disc. The disc is in great condition and plays on a PS2 system. Here's what I get when I try to run from either disc or ISO:

EE/iR5900-32 Recompiler Reset
Bios Found: USA v02.20(10/02/2006) Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_210.05;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_210.05;1) Game CRC = 0xDA0535FD, EntryPoint = 0x0010001C
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_210.05;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
CDVD READ ERROR, sector = 0x001d038b
CDVD READ ERROR, sector = 0x001d035b
CDVD READ ERROR, sector = 0x001d036b
CDVD READ ERROR, sector = 0x001d037b
CDVD READ ERROR, sector = 0x001d038b

I'm wondering if my settings aren't properly loading the ISO or something like that. I get the same error when I try to boot from the disc, each read error comes up a few seconds after the previous. Anyone have a similar issue or know how to fix this? Am I just not configured to load from an ISO?

Here are my plugins:

GSdx 5334 (MSVC 16.00, SSE2) 0.1.16
Lilypad svn (r5282) 0.11.0
SPU2-X r5324 2.0.0
cdvdGigaherz (r4488) 0.8.0
USBnull Driver 0.7.0
FWnull Driver 0.7.0
DEV9null Driver 0.5.0

I also got these errors while trying to view my plugins a second ago to type them up in this post... don't know if this has anything to do with it.

Path: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\gsdx32-avx-r5350.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Program Files (x86)\PCSX2 1.0.0\Plugins\gsdx32-avx-r5350.dll

WTH is going on? o.O
Reply

Sponsored links

#2
Your cpu most likely doesn't support avx soo ignore the plugin error, it's not the one you're using anyway, you could just delete that avx binary if it bothers you.

And for the iso, remake it with Imgburn, most popular programs fail recreating 100% ps2 backup, soo yeah if you didn't used imgburn, most likely your iso is bad.
Reply
#3
I did use imgburn. The only games I have for PS2 are KH1, KH2, FFX, and Baldurs Gate 1. IK BG1 won't work, considering the fact that nobody else here can seem to get it working... you think I should try FFX or KH1 to see if it's a problem with my PC rather than the emu?

As for booting from the actual CD, I have cdvd set to ISO from the dropdown menu, and here's what I get when I select KH2.img from the CD:

isoFile open ok: F:\KH2.IMG
Image type = Audio CD
Fileparts = 1
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (1609860 sectors)

Closing plugins...
Closing SPU2
File not found.
Path: IsoFileSystem
(pxActionEvent) IsoFS could not find the root directory on the ISO image.(thread:EE Core)
Closing PAD
Closing GS
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.

Is there something I'm doing wrong? I believe when I switch to plugin from the cdvd dropdown menu, the discs will load. At least it did with BG1, it just wouldn't play at a proper speed. It just kept freezing at the main game menu. Should I have the cdvd menu set to plugin and try again?

I apologize for being a total noob at this... -_-

EDIT: My bad, I just reinstalled to see if that would work and forgot to setup my bios, will post back after a few tries using different config options.
Reply
#4
To boot from disc you have to select plugin(under CDVD) and set your dvd drive letter in CDVD plugin config.(Edit: oh yeah I'm tired, just noticed you said it does load ~ speed of pc dvd drives is actually much faster than ps2 one and totally not affect game fps, they just spin down very quickly and that result in short pauses when they have to spin up again, soo yeah it's bad, but if the game is slow from DVD, it'll not really be faster off hdd)

If your iso was done with imgburn it's possible your DVD drive is not able to read all the data properly, not all drives are good enough for ps2 discs I guess, if you have any other pc/dvd drive you should probably check it.
Reply
#5
Oh thanks a ton man, I set the drive under the plugins menu, and switched to plugin instead of ISO and now it loads. Thanks for the help! Smile
Reply




Users browsing this thread: 1 Guest(s)