Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
-Can't play Metal Gear Solid 2-
#1
Ugh, this has been bugging me for a few days now..! And yet, combing through multiple Dolphin and PCSX2 threads and forums lead to no answers, but it doesn't make sense.

I think I have a fairly decent CPU, at least enough to handle a PS2 emulator, yet I can't run MGS2 without having the cutscenes drop from 60FPS, to 2FPS, then rising again. Slow down, is also a issue. If I can play the Dolphin emulator 60FPS no problem, for almost every single game
(Exceptions dropping down to 57-59, Resident Evil)

Additional Info:
- Using PCSX2 (r5878)

-Hostmachine unit or system specs are..

Operating System = Microsoft Windows 7 Ultimate Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 8127 MB
CPU name = Intel® Core™ i7 CPU 860 @ 2.80GHz
Vendor/Model = GenuineIntel (stepping 05)
CPU speed = 2.792 ghz (8 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 0098e3fd
x86EFlags = 28100000


-EE Cyclerate and VU Cycle Stealing are both set to max
-Fast CDVD enable, along with MTVU speed hack and mVU flag hack
-Adapter is NVIDA GeForce 310 Renderer is Direct3D 10 (Hardware)
-FXAA is enabled
Reply

Sponsored links

#2
It's a decent CPU, but MGS2 is really demanding, especially all the 1st part in the tanker.
And unfortunately, your GPU is quite weak.

a few things you should remember, though :
Quote:EE Cyclerate and VU Cycle Stealing are both set to max
this is a bad idea and will probalby bring more slowdowns than having a positive effect. increase both sliders 1 by 1 and try to find a balance that suites your specs.
Quote:If I can play the Dolphin emulator 60FPS no problem, for almost every single game
Comparing 2 different emulated systems is a complete nonsense. GC/WII is a lot easier to emulate than PS2.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Hmm.. okay, I'll give it a shot. Truth be told, I haven't started the game yet, because the opening has issues. Furthest I have gotten is to the conversation with Otacon.

Also, comparing two different emulated systems isn't total nonsense. It helps give perspective to the situation. Regardless if It's a lot easier to emulate.
Reply
#4
(03-06-2014, 11:18 PM)TheSolidSnake Wrote: -Adapter is NVIDA GeForce 310 Renderer is Direct3D 10 (Hardware)
-FXAA is enabled

MGS2 is very GPU intensive and your GPU is just way to slow.

Try this settings:
Native resolution
FXAA /FX Shader: OFF
Allow 8-bit Textures: ON

According to Nvidia this GPU only has a 64Bit DDR2 RAM so even with this settings you will probably get much better fps with software mode as your CPU uses faster DDR3 RAM.

Change renderer to Direct3D 10/11 (Software) and extra rendering threads to 3. This should give a much better performance.
Reply
#5
Woah..! Grove4L, that really did the trick.. I get sudden FPS drops from 55-60 all the way to 48, which is a MAJOR performance boost from last time(1FPS).. I'll post more the further it progresses.
Reply




Users browsing this thread: 1 Guest(s)