Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Champions of Norrath visual bug help?
#1
So I've been checking around the forums trying to find out how to optimize this game. It's playable, the framerate is mostly stable, the only issue I'm having is the individual cells the levels are composed of sometimes load extremely slowly, so I end up just walking on empty black space with no textures loaded. It loads certain assets that might be in those cells like chests, but the textures for the floors/walls don't load sometimes or take an extremely long time to load.

I haven't seen any mention of an issue like this on the forums.

I'm using pcsx 1.2.1
GS: GSdx 0 (MSVC 18.00, SSE2) 0.1.16 [gsdx32-sse2-r5875)
EE Cyclerate: 3
VU Cycle Stealing: 3
MTVU is on
EE/VU: Chop/Normal
Direct3D11(Software)
GPU: nVidia GTX 970
PS2 BIOS: 2.20 USA
CPU: i7

using an ISO

In GS, I read somewhere to set frame draw to 3 and frame skip to 1 so I did that, I don't really notice any difference between 3:1 and 2:2 so I don't know if that has anything to do with it


For extra rendering threads, I have it set to 6. I have an i7, I'm not really computer savvy but I read my cpu has 8 cores and software mode uses 2 threads by default, and the optimal number of threads is the number of cores. I have no idea if this is true or accurate though.

I think that's all the relevant info? Any help on why the cells/textures are taking so long to load and how I might fix this would be appreciated.
Reply

Sponsored links

#2
Probably you should set your extra rendering threads somewhat lower since your cpu has probably no real 8 cores but 4 cores that allow hyperthreading. Unfortunately hyperthreading is not really usable for pcsx2. I think a settings like 3 or 4 extra rendering threads should be closer to the optimum.
Still it is hardly believable that this solves your problem.

I would suggest to disable frameskipping completely in gs settings. I think it is a more or less reasonless feature implemented for extremely weak gpu's. Not sure if that really helps you or harms you.

The next is settings VU cycle stealing creates problems and I would not use it. Probably it doesn't help at all for this specific game but only fakes better fps than you actually have. If EE cyclerate really helps you have to check.




You should consider running this game in HW mode using the latest development build and using OpenGL backend. The halfscreen issue was recently fixed in HW mode.

If the suggestions didn't help you so far please post all settings by making screenshots including all pages of emulation settings and gsdx plugin settings.
And please post the emulog after you observed the problem.
Reply
#3
Try one of the newer builds. These games run much better now.
Reply
#4
I'm pretty sure I did something wrong. I don't know how to install a newer build. I have 1.2.1, I downloaded the latest build off the buildbotwebsite, I installed and ran the .exe that was in the pcsx2 that I just installed, redid some of the settings using what willkuer recommended, but nothing really worked. I don't know what was meant by running opengl backend, I thought it was in the graphic plugins where before I had direct3d11(software) but when I tried both direct3d11 hardware, and opengl hardware, I got the half screen bug. Also, when I tried running it back in software mode with a new build, my log just got spammed with something about running out of memory.

So I think I definitely did something wrong when trying to do a new build. Can someone explain how I'm supposed to install new builds? I read elsewhere on the forum that all I had to do was just run the .exe in the new build folder I installed but if that's true then idk why everything went haywire.
Reply
#5
Newer builds mean the latest GIT builds, which can be downloaded here: http://pcsx2.net/download/development/git.html
[Insert Witty Sig Here.]
Reply
#6
Note: you mustn't use custom resolution. Don't forget to enable 8 bits texture to reduce memory bandwidth requirement.
Reply




Users browsing this thread: 1 Guest(s)