Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Compiling question
#1
How do I tell cmake to use i386 as target architecture? Sorry if this was already answered elsewhere.
Reply

Sponsored links

#2
It should be done automatically.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#3
Well that's the problem since when done automatically cmake uses x86_64 as target architecture which I don't want.

Haven't been compiling pcsx2 in a while, but haven't had problem with it before.
Reply
#4
I did quick fix, editing TargetArch.cmake, but now I got message "-- Compiling a i386 build on a x86_64 host" which is again something I don't want, since I want to use i386 libraries for compiling.
Reply
#5
which distro do you use?
Reply
#6
CentOS 6.6
Reply
#7
(02-21-2015, 08:52 PM)ww3 Wrote: Compiling a i386 build on a x86_64 host
So this is true?

It is quite hard to compile pcsx2 on x64.
Reply
#8
If you build.sh it will be done automatically. If you use cmake directly you need to use -DCMAKE_TOOLCHAIN_FILE=cmake/linux-compiler-i386-multilib.cmake

If it still not working, post cmake output.
Reply
#9
I tried -DCMAKE_TOOLCHAIN_FILE thing but problem still remains, see when i start cmake it looks for x86_64 libraries which are in /usr/lib64 folder and not i386 ones in /usr/lib...

previous builds did this correctly, I don't know at what point cmake changed this way...

to illustrate what I'm talking about this is small excerpt of cmake output when started with that last googlecode build and things were correct

Quote:-- Enable the building of po files by default in Release build !!!
-- Found GTK2_GTK: /usr/lib/libgtk-x11-2.0.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Found X11: /usr/lib/libX11.so
-- Found ALSA: /usr/lib/libasound.so (found version "1.0.22")
-- Found BZip2: /usr/lib/libbz2.so (found version "1.0.5")
-- Looking for BZ2_bzCompressInit in /usr/lib/libbz2.so
-- Looking for BZ2_bzCompressInit in /usr/lib/libbz2.so - found
-- Found Gettext: /usr/bin/msgmerge (found version "0.17")
-- Found JPEG: /usr/lib/libjpeg.so
-- Found OpenGL: /usr/lib/libGL.so

and this with latest from the github

Quote:-- Compiling a i386 build on a x86_64 host.
-- Enable the building of po files by default in Release build !!!
-- Found ALSA: /usr/lib64/libasound.so (found version "1.0.22")
-- Found BZip2: /usr/lib64/libbz2.so (found version "1.0.5")
-- Looking for BZ2_bzCompressInit in /usr/lib64/libbz2.so
-- Looking for BZ2_bzCompressInit in /usr/lib64/libbz2.so - found
-- Found Gettext: /usr/bin/msgmerge (found version "0.17")
-- Found Git: /opt/rh/devtoolset-2/root/usr/bin/git (found version "1.8.4")
-- Found JPEG: /usr/lib64/libjpeg.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Found OpenGL: /usr/lib64/libGL.so

That's why asked about how do I make cmake look for i386 libraries, since I want to built 32bit binary and not 64bit one.
Reply
#10
Thank. I need to double check code (tomorrow Smile )
Reply




Users browsing this thread: 1 Guest(s)