Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Configuration questions
#1
Hey everyone. Some things about playing pcsx2 have been annoying me lately and I was curious if there were ways to fix these annoyances.

1. While playing a game, my fps hovers around 50-70 which is pretty good, but I get these slowdowns and the fps remains over 50. Fine, boggy, fine, boggy. Like a pattern the whole time playing. Maybe it's because my fps various constantly, I don't really know. Is there anything I can do about this? Maybe a way to clamp my fps at 40 or 30? Would this take some strain of my cpu or is something like that only for graphic cards?

2. With the SPU2-X plugin, my sound goes out of sync all the time. Kind of like a badly dubbed movie. Characters talking but the action was over seconds ago. Or, they talk and I hear the effects but the move is only half way finished, so the rest is just silent. ZeroSPU2 doesn't seem to go out of sync ever but it sounds horrible by comparison. Do I just deal with it for now or is there something I can do so SPU2-X stays in sync?

3. I can't play fullscreen with Direct3D 10 with Vista and a decent graphics card. Only works in window mode. Wouldn't be so bad if the window wasn't so small. If I make it larger it distorts the image and runs slower. This is a bit weird since I play other games in fullscreen with DirectX10. Is there not way to run pcsx2 fullscreen with Direct3D 10?

Thanks for any help/advice. It's quite impressive for a ps2 emulator to even exist let alone work so well.
Reply

Sponsored links

#2
When a game runs slow i.e., below 60fps then the sound will always be out of sync. Try peops plugin for that. or try time stretching options.

To go full screen you have to select the full screen resolution in GSdx say 1024x768 @85Hz. Its the first option in GSdx config.

Also post your system config.
Reply
#3
(04-05-2009, 11:14 AM)redlof Wrote: To go full screen you have to select the full screen resolution in GSdx say 1024x768 @85Hz. Its the first option in GSdx config.
and do Alt+Enter Smile

also there is a way to limit the fps to make it stay below a setting (but not above) by going config->cpu and setting the limit option Smile
Windows 7 64bit
Intel Pentium Dual-Core E5200 OC to 3.6GHz, Intel GMA x4500, 1GB DDR2

NinjaMight just work on next guideNinja
Reply
#4
Specs:
AMD 64X 4400+ (not great for pcsx2)
GeForce 9800 GT
2 GB ram
Vista sp 1

I forgot about alt+enter.

Thanks for the response. Smile

---edit-
I capped my fps at 55 and used the first two options on Zero's sound plugin. Plays nearly perfectly now. Some things in Zero's sound are too loud and others too quiet. I tried PEOPs but it sounded horrible/painful.
Reply
#5
1) You should set your limit to 60fps (config, CPU, right options, set to "limit"), this way it won't go above 60fps and you'll stick with 40-60 (depending on the game). If you want it to be 40, then, again, config, CPU, and on the right it says something like "custom limits", put in 40 and the game won't go above 40. So if you are getting 40-60, now you will get only 40fps. But i'd stick with the first option because if the game can run on 60, then let it run on 60. When it goes down, it is your machine, as of now.

2)
Quote:When a game runs slow i.e., below 60fps then the sound will always be out of sync. Try peops plugin for that. or try time stretching options.

Well this isn't true... if a game runs slower than 60fps, the sound will run slower too. Most probable thing is you activated a speedhack (x2 or x3 cycle), this tends to break audio in most FMV. Try disabling these speedhacks or turn 1.5x cycle and see if this helps. Also, try changing your output settings (config, audio) and use recommended ones or direct sound. Be sure to uncheck all boxes below (specially the one that sais "disable time stretching").
SAGER NP8690 | i7-620M 2.66Ghz | 6GB RAM | ATI 5870M 1GB GDDR5 | FullHD 1080p 15.6'' | 500GB HDD 7200RPM | WINDOWS 7
Reply
#6
It was the speed hacks desyncing the sound. I've switched back to SPU2-X. I also changed my limit to 60 per your suggestion and all is well.

There is one thing I forgot to ask and it's a real PITA problem.

My keyboard stops registering input (just for pcsx2). I've been using Lilypad. It's extremely annoying especially when I'm playing a fighter game. All I can do is stand there. Eventually it gives control back. It's not a game mechanic, I can't even pause. Any advice on how to fix this?

Games also seem less stable in full screen but I can live with it.

Thanks to everyone for your advice. Smile
Reply
#7
Glad we can help pal =]

About the controller thing, it happens to me too. But only when you switch from full screen to windowed mode, it seems that pcsx2 "losts trail" of the input, even if you click many times on the window of your game so windows takes it as the main window. It shouldn't happen however if you're playng fine. Don't know what could be the cause of this... maybe someone else can help?
SAGER NP8690 | i7-620M 2.66Ghz | 6GB RAM | ATI 5870M 1GB GDDR5 | FullHD 1080p 15.6'' | 500GB HDD 7200RPM | WINDOWS 7
Reply
#8
well that's perfectly normal then, you just need to click the desktop then the pcsx2 window Smile (for it not to happen it would have to be programmed in lilypad that the device should be re-attached (speaking programatically Tongue))
Windows 7 64bit
Intel Pentium Dual-Core E5200 OC to 3.6GHz, Intel GMA x4500, 1GB DDR2

NinjaMight just work on next guideNinja
Reply
#9
Thanks to everyone. I have everything working I think as good as they can be on my system now.

Um, about the input thing, kind of embarrassing.... weak batteries Laugh ...heh heh...

I've never changed them in over 3-4 years so... didn't really occur to me. They should install lasers in them like the mouse so they die in about the same amount of time. Glare

Ahem.... well anyway.....
Reply
#10
well what do ya know Laugh
Windows 7 64bit
Intel Pentium Dual-Core E5200 OC to 3.6GHz, Intel GMA x4500, 1GB DDR2

NinjaMight just work on next guideNinja
Reply




Users browsing this thread: 1 Guest(s)