Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Constant slowdown at interval
#1
Greetings,

I have been using PCSX2 on my laptop with below specs:

Acer Aspire 4752G
-Intel Core i5-2430M 2.4GHz
-nVidia Geforce GT520M 1GB
-Sound Blaster Go!
-6GB RAM
-500GB HDD

I am experiencing fps dropdown down to half every 10-20 seconds or so. Previously I tweaked and used DX9, DX11 and somehow it went away(game tested that time was Mana Khemia 1 NTSC-J). Currently this behaviour affects all games I try, so I'm wondering if any of you have any clues? I have tried every type of GS plugins with every kind of settings but still get this slowdown, could it be due to other plugins? or are just my PC not hot enough to run PCSX2 ?

Thanks in advance.
Reply

Sponsored links

#2
Have you tried software mode?
Reply
#3
(05-03-2013, 05:59 PM)Luminax Wrote: or are just my PC not hot enough to run PCSX2 ?

Thanks in advance.

Probably quite the opposite ;p download CoreTemp and keep an eye on your temperatures whilst playing on PCSX2, if they start going over 80-85c, your computer will probably start throttling.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#4
Try official version 1.0.0 r5350 from here http://pcsx2.net
u'll not get slowdowns Smile
Reply
#5
(05-03-2013, 07:32 PM)Preet Wrote: Try official version 1.0.0 r5350 from here http://pcsx2.net
u'll not get slowdowns Smile

isn't that what is he using already i suppose he didn't mention any outdated or unofficial versions !

and how do you guarantee the "NO SLOWDOWNS"

(05-03-2013, 06:25 PM)refraction Wrote: Probably quite the opposite ;p download CoreTemp and keep an eye on your temperatures whilst playing on PCSX2, if they start going over 80-85c, your computer will probably start throttling.

yeah still wondering when will MS implent a similar feature on their OSes ....
Reply
#6
Use default setting and recomanded speedhack
Reply
#7
Preet : I am using the official latest version, still the slowdown
billyash: I've tried almost every possible combination possible (one combination caused the gamescreen to shake heavily I still have jitters in my eyes)
Refraction: Thanks, will try monitoring CoreTemp.

Speaking of temperature, maybe if I clean up my laptop so that my GPU/CPU won't get too hot I'd get a better performance ? hmmm

Will try and inform
Thanks and regards guys
Reply
#8
Maybe some problem in windows or u'r system.
Update all drivers of windows & u'r system also e.g.Graphic card,sound card etc.
Reply
#9
(05-03-2013, 07:32 PM)Preet Wrote: Try official version 1.0.0 r5350 from here http://pcsx2.net
u'll not get slowdowns Smile

I'd agree with the posts mentioning this, Preet. If everybody sticks with a version the emulation development stalls.

Is possible that the emulation becoming a bit slower in one or so games because the goal is achieving greater compatibility with most games. What means some former unplayable or incorrectly emulated games are enhanced in newer versions.

So, remember this when suggesting using older versions in a general fashion. Probably you got better response in some games you play but there are other factors than just speed in emulation.
Imagination is where we are truly real
Reply
#10
nVidia GeForce GT 520M, a quite powerful chip for a laptop...
unfortunately it heats up quite powerfully, as well.

I just cleaned up my laptop, and went back to the old 'desk fan to the face' method and now I checked CoreTemp, CPU went over 82 but game is as stable as a rock! (well... some very very minor slowdown here and there but it's a granted given that it's an emulation)

Problem solved, keep your graphic card cool!
Reply




Users browsing this thread: 1 Guest(s)