Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Core [Bug Report] Disgaea [PAL]
#1
PCSX2 version: 0.9.6. I would use the beta, but I don't want to make an ISO of my disc.

CPU options: default, never changed

Plugins Used: Tested both GSdx 890 (MSVC 15.00, SSSE3) 0.1.14 in DirectX 10 hardware/software mode and ZeroGS.

1920x1080@60hz (for some reason the program falls back to 1280x960 Windowed)
4:3
Internal Resolution: 2048x2048
NLOOP: Gray tick
Texture Filtering: On
Vsync: On

P.E.Op.S CDDVD (CDDA mod) 1.3.0 (default plugin never started the game, some error is logged in the console window). The rest of the settings are left at their default values.

Steps To Reproduce:
- Go to the Dimensional Gate Keeper, Vyers Castle and then Magnificent Gate.
- Press L1 after the level starts to rotate the display once.
- Destroy the yellow prism.

Description of problem:
The cliffs tend to flicker during the chain reaction, very minor with the Software Renderer, Minor with the Hardware Renderer.

Memory Card: I attached it, kinda stupid having no list of supported file types on the forum UI for uploading files. Wasted my time uploading it compressed with NTFS compression :/


EDIT: My system specs are below.

Core2 DUO e6750 @ 2.66GHZ
ASUS P5KC Mother Board
2 gig DDR2 800 RAM
500g SATA2 HDD
X-FI Extreme Music
Nvidia Geforce 8800gt 512MB PCI-E
Windows 7 RTM x64
Thermaltake 750watt Toughpower Power Supply
Thermaltake Armor+ MX case.


Attached Files
.zip   Mcd001.zip (Size: 42,11 KB / Downloads: 127)
Computer specifications:
Windows 10 x64 | Intel Core i7 @ 2.66GHZ | ASUS P6T | Gigabyte Windforce x3 Geforce  760 4GB | 8GB DDR3 1600MHZ RAM | Integrated Audio
Reply

Sponsored links

#2
Turn off Speed Hacks.

Try again.

Clarification: Almost all geo effects flicker in disgaea games are the result of some speedhack enabled. So make really sure you do in fact have them all turned off.

Also: 0.9.6 bets work fine with PeOPS plugin. Just copy the plugin into the /plugins folder and have fun.

Finally: SSSE3 is not a typo. Intel released two versions of SSE3, but they felt like being clever and evil at the time so they named the second one SSSE3.

The extra "S" stands for "Supplimentary"
Jake Stine (Air) - Programmer - PCSX2 Dev Team
Reply
#3
I don't use any hacks of any sort, the game runs fine performance wise without anything like that needed.

Quote:Also: 0.9.6 bets work fine with PeOPS plugin. Just copy the plugin into the /plugins folder and have fun.
Elaborate, The PeOPS pCD plugin included with the emulator works. the default one "Gigaherz's"? does not. With Gigaherz's I get the following error in the command prompt window.
Code:
EE NisPackedIrx.c( 149) : error
Computer specifications:
Windows 10 x64 | Intel Core i7 @ 2.66GHZ | ASUS P6T | Gigabyte Windforce x3 Geforce  760 4GB | 8GB DDR3 1600MHZ RAM | Integrated Audio
Reply
#4
Ok this is interesting. This is actually something I've noticed myself but hadn't actually placed a finger on it as being the cause -- specifically that the PAL versions of Nippon Ichi games run a lot worse in general than the NTSC versions. The PAL versions actually behave like the NTSC versions on speedhacks. Ie, if you play Disgaea/NTSC and set yourself up with VU Cycle Stealing and/or EEx2 cycle rates, the exact same thing happens.

That indicates that the game isn't finishing rendering the scene before the vsync (speedhacks skip emulated cpu time, so a common side effect is that games can't finish drawing the entire scene at 60fps anymore). Why PAL games behave like they're speedhacked is very curious. It could even have something to do with our very low compat rates with PAL titles (many don't even boot, or can't make it past the intro splashes).
Jake Stine (Air) - Programmer - PCSX2 Dev Team
Reply
#5
Quote:It could even have something to do with our very low compat rates with PAL titles (many don't even boot, or can't make it past the intro splashes).
I didn't know this but it doesn't surprise me as it is the same with almost every other emulator. American games get the best support Tongue Anyways the glitchy graphics isn't show stopping or anything serious so unless the game freezes at some point or something serious I'm happy with it as is.
Computer specifications:
Windows 10 x64 | Intel Core i7 @ 2.66GHZ | ASUS P6T | Gigabyte Windforce x3 Geforce  760 4GB | 8GB DDR3 1600MHZ RAM | Integrated Audio
Reply
#6
I should point out that when I had a CRT TV and used component A/V with the TV, no artifacts were present in Disgaea. (tested/played on a fat ps2)

No artifacts are present on my LCD TV when using composite either (component produces just a black screen on the LCD) but there is severe colour bleed/blur.
Computer specifications:
Windows 10 x64 | Intel Core i7 @ 2.66GHZ | ASUS P6T | Gigabyte Windforce x3 Geforce  760 4GB | 8GB DDR3 1600MHZ RAM | Integrated Audio
Reply
#7
If you were seeing artifacts when testing the game on your actual ps2 then that would have been a bad sign for your ps2.
Old habits die hard - System Shock
Reply
#8
Oh I was just pointing out that the artefacts are indeed caused by subpar PAL emulation (I assume there is no graphical corruption in the NTSC version with no speed hacks etc.)

Also, I upgraded to the latest beta but reverted the GSdx plugins to the ones included with 0.9.6 because the newer ones have a broken underline artifact under most lines of text in the game.
Computer specifications:
Windows 10 x64 | Intel Core i7 @ 2.66GHZ | ASUS P6T | Gigabyte Windforce x3 Geforce  760 4GB | 8GB DDR3 1600MHZ RAM | Integrated Audio
Reply
#9
(11-03-2009, 05:46 PM)Franpa Wrote: Also, I upgraded to the latest beta but reverted the GSdx plugins to the ones included with 0.9.6 because the newer ones have a broken underline artifact under most lines of text in the game.

That part should be fixable by tweaking the GSdx internal resolution settings, or using the new x2 scaling option. (I haven't tested that new stuff myself tho).
Jake Stine (Air) - Programmer - PCSX2 Dev Team
Reply
#10
Quote:or using the new x2 scaling option.
I assume this is a setting for the other video plugin included? Adjusting the internal Resolution setting from 2048 to 1536 then to 1024 yields no difference with the Direct X 10 Hardware mode. I would use Direct X 9 but I like Windowed mode ._.

edit: setting internal res to Native fixes it, though it is pretty blurry, this is probably just a placebo effect though. I'm gonna play for a bit.

edit 2: Yes it is too blurry, I prefer the following settings (which exhibit the artifacting in the latest plugin)

Resolution: 1920x1080 or 1280x960
Renderer: Direct X 10 Hardware
Shader: Pixel Shader 2.0 (grayed out)
Aspect Ratio: 4:3
Internal Resolution: 2048x2048
NLOOP hack: gray tick
Texture Filtering: ticked
Wait VSYNC: ticked
Computer specifications:
Windows 10 x64 | Intel Core i7 @ 2.66GHZ | ASUS P6T | Gigabyte Windforce x3 Geforce  760 4GB | 8GB DDR3 1600MHZ RAM | Integrated Audio
Reply




Users browsing this thread: 1 Guest(s)