Thread Rating:
  • 3 Vote(s) - 4 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Core i7 notebooks and pcsx2: SLOW
#1
Got access to a Core i7 notebook (Clarksfield) today, a Dell XPS Studio 16 with Win7. It's one of the first notebooks available on the open market to feature a core i7. This thing has quad 1.7ghz processors that run at 2.8ghz in dual-core mode, and 3.0ghz in single-core mode, through "Turbo Boost". It's got 1mb of L2 cache and 8mb of L3 cache. 4gb ram.

I benchmarked this thing using pcsx2 (build 2184 w/new GUI) against a different Studio XPS 16 with the same configuration except the older rig has Vista and a 2.66 c2d processor. Same drivers, video card, DirectX, the works. The result?

The new core i7 is MUCH slower than my old c2d notebook, in pretty much ALL games (Tekken 4, GTA3, Lego SW, etc. etc. you name it -I've tried many). In most cases it's a difference of 10-20fps slower. I'm getting similar slowness with Dolphin. On my c2d notebook most games play just fine at 50-60fps.

What's even more weird is this new rig totally smokes the c2d when it comes to benchmarks like Cinebench, which test single CPU and multi-CPU performance. I've run these benchmarks myself. Even Demul (another emulator) is faster with the Core i7.

I spent most of the day on the phone wrestling with Dell techs that barely knew what I was talking about and I finally gave up. I've disabled Speedstep in the BIOS - no difference. And there's no other BIOS options for things like HyperThreading. CPU-Z shows that the CPU frequency is all over the map, even when only running pcsx2 with nothing else - it jumps from 1.7ghz to 2.2ghz to 3ghz and down to 1.5 ghz.

I'm totally baffled. Unless anyone (Jake?) has any other ideas I'm just going to send this thing back as a piece of junk. The lesson should be that core i7 is great as long as you don't use emulators. Otherwise stay as far away as possible, and hold on to your c2d for as long as you can.

If anyone else has a notebook core i7, it would be interesting to hear your experiences as well.
Reply

Sponsored links

#2
I think the real lesson is dell notebooks are not best for emulation Tongue2

I'd try changing the power profile in windows's control panel to high performance to begin with and disable all kind of power saving features not sure how turbo mode works in notebooks but seems your problem is there somehow, I dont have much experience with notebooks tho Tongue
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
and the graphics cards of those notebooks are pretty bad indeed.
[Image: 2ymccqu.jpg]
[Image: 17715.png]
Reply
#4
(11-15-2009, 02:25 AM)Shadow Lady Wrote: I think the real lesson is dell notebooks are not best for emulation Tongue2

I'd agree, except my other c2d notebook runs pcsx2 and dolphin just fine. That's thanks mostly to the CPU, though my video card is also pretty nice (ATI 4670).

(11-15-2009, 02:25 AM)Shadow Lady Wrote: I'd try changing the power profile in windows's control panel to high performance to begin with and disable all kind of power saving features not sure how turbo mode works in notebooks but seems your problem is there somehow, I dont have much experience with notebooks tho Tongue

I've done that. I should have mentioned. Didn't make a difference.
(11-15-2009, 02:27 AM)diegochiha Wrote: and the graphics cards of those notebooks are pretty bad indeed.

These both have an ATI 4670 - discrete. Most notebooks graphics cards are bad, but not this one.
Reply
#5
Try to disable 2 cores in the bios. Hopefully you can do that. If you are able to that then turbo should kick in. Also you need to keep speed step enabled, otherwise turbo mode is disabled. With turbo mode, many things can interupt it so the smallest thing like windows tracking time can stop it because the task will be executed on a different core. Disabling two cores will ensure that you will always get the turbo boosted speed.
Reply
#6
an ati 4670 its not that great either,it has even less power that his pc counterpart
[Image: 2ymccqu.jpg]
[Image: 17715.png]
Reply
#7
(11-15-2009, 02:55 AM)diegochiha Wrote: an ati 4670 its not that great either,it has even less power that his pc counterpart

That depends on your frame of reference. The 4670 is one of the best graphics cards available for notebooks. Besides, that's totally immaterial. What's important is that on two systems with the SAME graphics card (and other specs) pcsx2 is much slower on the core i7 platform.
Reply
#8
(11-15-2009, 02:48 AM)bkwegoharder Wrote: Try to disable 2 cores in the bios. Hopefully you can do that. If you are able to that then turbo should kick in. Also you need to keep speed step enabled, otherwise turbo mode is disabled. With turbo mode, many things can interupt it so the smallest thing like windows tracking time can stop it because the task will be executed on a different core. Disabling two cores will ensure that you will always get the turbo boosted speed.

As I said in my original post, there's no other options in the BIOS. That includes disabling cores. Thanks anyway though.
Reply
#9
I think turbo mode might not be kicking in due to some background application utilizing the remaining two cores. Try using CPU-Z to check the clock on that CPU during PCSX2.
Nappa: Vegeta! What does the scouter say about his power level?
Vegeta: It's...one thousand and six.
Nappa: Wh-...really?
Vegeta: Yeah! Beat him up Nappa!
Nappa: Yay!
Reply
#10
Damn. Maybe you can open task manager and restrict pcsx2 to 2 of your cores? That way load balancing doesn't get in the way of turbo mode.
Reply




Users browsing this thread: 1 Guest(s)