Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Crackly sound
#1
So I'm running arch and pulse audio. Usually(not always though) when I have the sound in PCSX2 to run via alsa it sounds all crackly and there's nothing I can do about it, but if I switch it from alsa to oss it tends to work perfectly. If I leave it on oss, though, then when I restart the program, or start it at all the sound won't come out when it's running oss, so what I have to do is switch from OSS to alsa and then back to oss, and then it tends to work just fine, unless I pause/close a game and start a new one. If i do that I have to go through that entire cycle again.

Is there a way I can just get it to work with alsa (or oss I don't really care which one) and keep using pulse audio, without having to jump through hoops each time I start the program?




And another problem I'm having unrelated to sound is I use a lot of savestates and I use the turbo button a lot and when I first start the game they work just fine, but whenever I pause the emulator and restart it or alt tab out or do anything that makes the screen lose focus the only way I can make those hotkeys to work again is to restart the entire emulator. If I recall correctly I had this problem on Windows too, but I could be wrong. Why is it doing this and is there anything I can do to just have the hotkeys always work?
Reply

Sponsored links

#2
Regarding the crackling sound, that's the workaround I have always done, so I don't see a better way.

I'm not sure about the hotkey issue though. For some reason I can't get savestate hotkeys to work in Linux version but F9 and F4 work fine.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#3
i never used to have that problem. i think it's related to pulseaudio. also when computer sounds happen or skype loads up it seems to break the sound in game and the only way to fix it is to restart the program. i probably have pulse set up wrong or something. i don't remember struggling this badly before, and I always seemed to be able to fix it eventually.

edit: so it appears that it won't work properly at all when skype is running. i think it's strictly a problem with pulseaudio interacting with alsa/oss/jack now, becuase when skype isn't running i can make it work with the switch trick, but it won't work when skype is running. i'll have pavucontrol running (the pulse volume controller) and the audio will show up and disappear from pavucontrol synchronusly with the crackles and skips that the audio is doing. so it's like the audio can't fully initialize with pulse when other processes are using my sound.
Reply
#4
Pulseaudio historically has never been too cooperative so I'm glad you figured that out. Tongue
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#5
Yes it is an issue with pulseaudio. Search in the forum, someone post somewhere a config to avoid this kind of issue.
Reply
#6
searched for about 45 minutes and havent found a config file. you meant for pulseaudio right?


i saw one in a thread that had no responses but that config didn't work.

gregory do you use pulse?
Reply
#7
not a config file. Just an option on a file.

No I don't use pulse (well I don't think so, I got only libpulseaudio).
Reply
#8
was it an option in pulse or in pcsx2?
Reply
#9
It was an option of pulse/oss/alsa (don't remember) not pcsx2. I don't remember well.
Reply




Users browsing this thread: 1 Guest(s)