Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
DQ 8 screen flicker problem
#1
Hello,

I'm afraid I'm a total nOOb at working with the emulator, so this might be a stupid issue, but I can't figure it out and I'm hoping someone here can. I am currently running PCSX2 0.9.7.3113, and I'm trying to run Dragon Quest VIII. The game itself runs pretty great - there are some significant slowdowns, but I've read threads here that give suggestions as how to fix them.

My big problem is that roughly every 6-8 seconds, the screen will flicker, and despite my best efforts I have been totally unable to fix it. It gets really annoying, and I'd love if anyone has any ideas as to what to do. Thanks!
Reply

Sponsored links

#2
Have you tried the interlacing options at the GSDX plugin?
One way to verify that on fly is pressing F5 and noticing if some will fix the issue. Most probably the "blend bbf" is your best bet.
Imagination is where we are truly real
Reply
#3
Unfortunately none of the interlacing options work, and I have now noticed that it happens the moment the emulator starts working - the flicker can be seen at the Sony startup screen. Also, F5 does nothing, even though the Plugin settings suggest it should do something.

I have tried every plugin that came with the software, and the ONLY one where the flicker doesn't occur is with ZeroGS 0.97.1. However, the game becomes totally unplayable 1/4 of the way through the first cutscene.

I'd be happy to post my specs and/or settings if someone thinks it would help. I'm sure there must be someway to fix this, but I have absolutely no idea what it could be.
Reply
#4
Quote:I'd be happy to post my specs and/or settings if someone thinks it would help. I'm sure there must be someway to fix this, but I have absolutely no idea what it could be.

Please do, DQ8 should not flicker like that.
Reply
#5
(07-16-2010, 12:06 AM)Ænigmatik Wrote:
Quote:I'd be happy to post my specs and/or settings if someone thinks it would help. I'm sure there must be someway to fix this, but I have absolutely no idea what it could be.

Please do, DQ8 should not flicker like that.

Here are (I think) my relevant specs:

COMPUTER
Intel Core i7 860 @ 2.80 GHz
4 GB of RAM
ATI Radeon HD 5870
Windows XP

PCSX2 0.9.7(r3113) SETTINGS:
GS: GSdx 3068 (MSVC 15.00, SSE2) 0.1.16
PAD: LilyPad svn (r2930) 0.10.0
SPU2: SPU2-X r3117 1.4.0
CDVD: cdvdGigahertz (r3006) 0.8.0

GSdx9 SETTINGS:
Direct3D9 (Hardware)
Interlacing: None
D3D internal res: 1024 x 1024

All other settings are at default - I don't really know what anything else does, so I've left them alone. As mentioned above, I've now noticed the flicker as soon as I boot the CDVD, not just when playing DQ VIII. The flciker can be either the entire screen or a large chunk of it, and happened every 6-8 seconds. I tried turning on Interlacing as mentioned above, but no effect. Additionally, pressing F5 does nothing - no changes, no window, nothing. The only plug in that did not have the flicker was ZeroGS 0.97.1, but again the game was unplayable shorty after the opening cut scene began.

If you need more info, just let me know!
Reply
#6
try pressing F5 until you find the best result or change the interlacing inside gsdx (i hope this helps)
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply
#7
try the SSE4.1 plugin; try dx10 version, your CPU allows it; the interlacing should be "blend bbf" (you can try the others too).
Imagination is where we are truly real
Reply
#8
(07-16-2010, 12:51 AM)nosisab Ken Keleh Wrote: try the SSE4.1 plugin; try dx10 version, your CPU allows it; the interlacing should be "blend bbf" (you can try the others too).

The SSE4.1 plugin has the same problem. Also, this may seem dumb, but where can I enable the dx 10 version? I can't find it as an available option anywhere
Reply
#9
he has win xp so he cant use it.... try interlacing as i said above....
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply
#10
(07-16-2010, 01:07 AM)iakoboss7 Wrote: he has win xp so he cant use it.... try interlacing as i said above....

None of the interlacing with any of the plugins has any effect on the flickering - I just tested all of them with the three main plugins. I don't know why the ZeroGS plugin eliminates the flicker but then makes the game unplayable.

From what I'm reading I should be able to handle this game with no problems - arrrrgh!
Reply




Users browsing this thread: 1 Guest(s)