Thread Rating:
  • 9 Vote(s) - 4.56 Average
  • 1
  • 2
  • 3
  • 4
  • 5
DS4Windows - J2K
Hi Jay,

Long time user and very grateful fan of DS4Windows!
I've found something quite interesting, I don't know if you've also noticed. Sony started releasing their new DS4 controllers, I picked one up. New controller is exactly identical except for the fact that it now includes a narrow lighbar line on the touchpad. Apparently, the new controller is now able to be used by directly plugging into the PS4, to reduce latency.
However I'm only using it for PC so big whoop haha.
HOWEVER, unlike my old DS4 controller, when I plug in this new one, something pops up in my windows sound devices options!
It's classified as a headset audio device and I can use the controller's audio jack for sound! Prayers answered? Not quite..
Unfortunately, when I run DS4W, the headset audio device is still present but fails to play any audio. I've tried enabling "use dinput only" but that doesn't work.
I know you don't much like how many times people have asked you about "sound through the controller" and how many times you've had to explain the reverse engineering is impossible. But does this new model changes things? Or are we at the same impasse? I don't know if there's any way you could change the driver to not interfere with the audio device.

Also a question to anyone out there,
When I'm using the Lillypad plugin and select dinput, I am able to set controls to Pad1. The dinput device shows up as "DX wireless controller" Unfortunately, once in game, despite the controller test still showing readings from input, and all the controls being set, there is no input in game. Of course, it works with DS4Windows and the Xinput device. But is there anyway to make this DS4 controller work without xinput? Because if possible I'd like to use the audio jack, and as I explained, xinput is disabling the audio (probably cause there's no headphone jack on an xbox controller?)

Once again thanks so much for your awesome software and thanks in advance for the reply! Smile
Reply

Sponsored links

I know this might be a dumb question (because this is called ds4 windows) but I always use this program for my ds4 controller but my friend has a ds3 controller, so I have to use other (less user-friendly) programs to emulate the controllers.
Is there maybe a possibility that there will come ds3 support because this is by far the best ds software for windows.
Reply
Hello, DS4Windows is awesome and works almost always perfectly however recently I encountered some problems with Mass Effect 1 while trying to get it working on my PC with controller. I know the game doesn't support controllers, but I found out that there are mods, which enables it and it should work. I got the mode, but the game for some reason doesn't recognize any input from my controller. I even tried to run it in with DS4 hidden so the controller only appears as Xbox 360, however didn't help either. Does anyone have some experience with ME, or other Origin games and DS4Windows? Apparently the game works fine with Xbox360 controller and I saw at least one person claiming that the game runs with his DS4Windows emulation as well, but I wasn't able to run it myself.
Reply
Hi, when finish using ds4 with pc via bluetooth, how to reconnect with ps4 again?
Reply
So anybody know what this is about? When i tried to uninstall the program it kept saying i don't have the right permissions ( even running thru godmode settings) and won't let me do a thing with the folder even under total admin access


Attached Files Thumbnail(s)
   
Reply
I NEED HELP!
MY CONTROLLER ISNT WORKING ON PS4 AFTER USING DS4WINDOWS! ANY HELP GUYS?
Reply
(02-17-2017, 01:26 PM)drizzydero Wrote: I NEED HELP!
MY CONTROLLER ISNT WORKING ON PS4 AFTER USING DS4WINDOWS! ANY HELP GUYS?


1) Unpair the controller from Windows and re-pair to your PS4.  If that doesn't work...

2) Get a toothpick or small paperclip etc and push the little button on the back of your controller.
Reply
Hi I am hoping I can get some help here.

I have used the app for a while, but the last couple of days i have had some problems. The main thing is that my internet stops working when i connect my controller (PS4 controller) with Bluetooth.

Everything in windows says i am connected to the internet, ipconfig in cmd is normal, and wifi status is receiving and sending bytes as normal. But nothing has internet. I can't even connect to my router in the browser.

It starts almost immediately after i connect my controller with Bluetooth and running DS4Windows (running DS4Windows with usb cable doesn't do this). I have tried to reinstall drivers, and disabled and enabled in the device manager, resetting the controller, but nothing helps.

Anyone know what to do? I am fairly lost.
Reply
I've been a long time user of DS4Windows because it just works so well for me. I hate having to use other input wrappers because DS4 is so good! But that's actually why I'm here because I finally ran into a problem that I cannot find any kind of answer for. I have a Hori Real Arcade Pro 4 Kai Fightstick... the first model, because I was an early adopter. The first model supports PS3, PS4, and Dinput for PC only, second model fixes that by adding Xinput. But so anyway, I plug in this stick for my computer because I was under the impression DS4Windows would pick it up no problem. I was apparently misinformed because DS4Windows does not detect it unfortunately. So I really just swung by to ask if anybody has had this problem, if they've fixed it or not. I'm also really curious to know why this controller can't be seen as a regular PS4 controller. Whether I use a USB 2.0 or 3.1 port and making sure the stick is set to PS4 mode (and for good measure, tried it in PS3 mode), DS4Windows just doesn't like it apparently.
Reply
Just installed it, why can't I use the analogue sticks as a mouse? I did create a profile for it but for some reason it doesn't work. I hope I'm just missing something here, help please.
Reply




Users browsing this thread: 5 Guest(s)