Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dark Cloud 2 [USA] Slowdown
#1
I tried running DC2 on the current build of PCSX2, and it ran, on average, around 40-60%. I thought it was my processor, but it only ran at 60% during the game's playing. Is anyone else getting this?

Specs:
Nvidia9800 GT
2.12Ghz dual-core processor
1GB RAM
Windows Vista
Reply

Sponsored links

#2
Well, I don't know the game. But if it's 3D (or even 2D..) your cpu is kinda weak. OC would probably solve your problem.

I can suggest to use speedhacks for a lil bit more speed...
| i7 860 2.8@4ghz | Scythe Mugen 2 Rev.B | Asus Maximus Formula III | G.Skill Ripjaws 4 Gigabyte | 570 GTX AMP! | Enermax 720w PSU | X-Fi Titan | OCZ Vertex 120 GB |
Reply
#3
(03-29-2009, 07:54 PM)yunsabit Wrote: Well, I don't know the game. But if it's 3D (or even 2D..) your cpu is kinda weak. OC would probably solve your problem.

I can suggest to use speedhacks for a lil bit more speed...

I tried the speedhacks, I didn't notice any major changes in gamespeed.

I'm more curious as to why my processor only ran at 50-60% while running the game. Is there anyway to dedicate more processing power to PCSX2?
Reply
#4
Don't worry, pcsx2 runs as fast as it can. The various readouts are not an actual representation of how much your cpu is used.
And yeah, don't expect a 3d game to run full speed on a "2ghz processor" (you didn't say which cpu, there's a lot of differences Tongue2 ).
Reply
#5
(03-29-2009, 08:03 PM)rama Wrote: Don't worry, pcsx2 runs as fast as it can. The various readouts are not an actual representation of how much your cpu is used.
And yeah, don't expect a 3d game to run full speed on a "2ghz processor" (you didn't say which cpu, there's a lot of differences Tongue2 ).

It's an AMD Athlon, sorry. Heh, I can never remember the manufacturer.
Reply
#6
Actually dark cloud 2 runs horrible on my e8400 as well (3.1ghz). It seems to be glitch free..just very very slow. Same with Rogue Galaxy which I think uses the same engine. Speed hacks dont really help. Very strange that Shadow of the Colossus runs fine however on my cpu.


Wolfdale e8400
3 gigs ram
ati 3850
Reply




Users browsing this thread: 1 Guest(s)