Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dark Cloud 2 freezing problem
#1
Ok, Im a recently new member and PCSX2 user so I barely know what Im doing.

I havent done alot of searching around, just a couple random posts.
but they didnt have what I was looking.

the specific details of how this game is freezing is that right after a scene where I have no controls it's just theatrical it will go to a loading screen. At first everything will be fine but then FPS will drop from around 60 to around 20ish and music will stop and then pick up for half a second and then stop again repeatedly. then FPS drops to 5 and then 1... and it just sorta gets stuck on this loading page...

this happens very early on in the game, right after the 2nd floor in the water channels where the main character talks about not remembering his mom's face anymore (lol...).

Ive only turned on 2 speedhacks (the top two ticks on the left side) and GSDX native to see if this would counteract what I see is going on, I dont actually know the cause or how to fix it. Otherwise everything else is still on default.

processer: intel core 2 quad 2.66 Ghz
graphics: NVIDIA GeForce GTS 250

This is probably one of my favorite games of all time and with this I cant play the game anymore.... please can you help me fix my game from freezing?

Sponsored links

#2
Are you using 0.9.7? Cuz it should be playable
I'm inactive on this, dedicating most of my time to osu!
#3
I downloaded the beta of 0.9.7 because it was... recommended above the current version? or whatever like it said on the download page.

also, I forgot to say there is one other thing that I changed and that was some of the audio settings. (because the music is one of the things I loved about the game)

module- 2 direct sound
Synchronizing mode - Async mix

I have tried changing the synchronizing mode back to the default as well but it didnt fix the problem so I switched it back... i still dont know if that could be a cause but I want to include everything that might be the cause.

also, on the loading page that it freezes on...
UI tends to be around 20-25%
EE tends to be around 71-79%
and GS is 0 because it's a loading page
#4
Does this happen to be the white loading screen?

If so, it is a problem with the game that can't be fixed (it even occurs on the original ps2 when it came out). Try combinations of clearing dungeons beforehand and skipping (not skipping) the cutscene. In my experience, it all depends on the ps2 but you should still get through eventually. Just a warning, there is another white loading screen in Chapter 3 so save frequently.
#5
(07-19-2010, 07:45 PM)Zanoab Wrote: Does this happen to be the white loading screen?

yea... >_<
thats depressing. hopefully it all works out eventually. thanks for helping me out, it's too bad there isnt some sort of emulator fix...? maybe?

I figure though that because of what you said that it is the BIOS and not the emu, so I guess Im just going to have to deal with it.

thanks again for help.
#6
Zanoab, doing those two things you said got it to work.

lol, now theres only one problem left... my fps is too high so I cant enjoy the music at some points of the game XD... at the end of the dungeon I previously couldnt get to, after all the creatures were dead, my fps hit almost 100... So the music sped up to almost double its original speed lol... now it's sort of cruising at 80... I like high fps in all of my games but I love the music too much.

how do I keep it at a steady 60 without speeding up?
#7
This second issue is easy to solve, just make sure the "Disable frame limiter" is NOT marked in the GS tab under "config" menu -> "Emulation Settings" Smile I know, it's strange dealing with negatives...
Imagination is where we are truly real
#8
thanks guys!
now I can enjoy my favorite game again. It's been soooooooo long XD
#9
hi guys, I'm having the same problem white the white screen,....and something came up in my mind..... I just have to remove my memcards with the new save game after chapter 1,... and I really need those save game because I don't find any of those @ google
would you please help me..??
#10
(02-27-2012, 04:59 AM)skidalther Wrote: hi guys, I'm having the same problem white the white screen,....and something came up in my mind..... I just have to remove my memcards with the new save game after chapter 1,... and I really need those save game because I don't find any of those @ google
would you please help me..??

create your own thread you revive a 2 yr. old thread
you love hi-jacking because you scared to death to creating your thread due to hi-chances of owned-thread closing
better close this now!
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM




Users browsing this thread: 1 Guest(s)