Thread Rating:
  • 4 Vote(s) - 3.75 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Devil May Cry 3 slowdowns problem in some locations
#1
Hi.

First, My PC Specs:

CPU - Intel Core i5-2500K @4Ghz
RAM - Corsair Dominator 1600Mhz CL9 8GB (2x4GB)
GPU - Gainward HD4850 512MB @675/2100
Windows Seven Ultimate 64bit

I'm playing Devil May Cry 3 Special Edition (US) and the game is running pretty well on GSDX DX10 (Hardware) AVX at 3x Scaling, Blend BFF, alpha Hack.
PCSX2 0.9.9.r4868, GSdx32-AVX-r4863.
This SVN is running better than the official release (tested just now on DMC3).
I'm not using any speedhacks (the game is running noticeably better without any of them).

But there are some problems in some places, like the place right before Cerberus (where the Golden Statue is/ after the Club Fight) and some other places in other missions. The framerate drops from stable 60FPS to something like 30-32FPS (and it looks like it's even lower though it shows 30FPS).
On lower scaling it runs better, but could my GPU be the problem? Or may it be something else?

Please don't suggest changing to Native Resolution, anything below 3x scaling looks like crap on Full HD Display, so it's a no go.
Reply

Sponsored links

#2
(08-14-2011, 02:24 AM)KatanaPL Wrote: Please don't suggest changing to Native Resolution, anything below 3x scaling looks like crap on Full HD Display, so it's a no go.

At least try it and see if it helps you before dismissing it?
If resolution is the problem then there's probably not much else you can do about it but reducing resolution (doesn't have to be native), but if it's not the problem then at least you know and you can move past it.

Would help if you post your PCSX2 and plugin settings and the EE/GS% values in the game window when you get slowdowns.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
I can only view at it from the pc version of the game (I will never play it on the emulator - this' a no go Laugh).

but maybe the view distance is too much to compute all the data in a reasonable matter of time. also dunno about the amount of dynamic texture uploads - there's alot of different textures smashing the 4MB barrier - in that scene. that might cause another possible slowdown reaction. it might even be a fault of the mtvu hack that bypasses a lot of syncronity while uploading that dynamic textures.

this all a lil technical. but I love to point on that things.

major is the fact that it works faster if you lower the internal resolution. so...

jump over your shadow and play it in native if you have to. Wink
Reply
#4
(08-14-2011, 02:50 AM)Shadow Lady Wrote: At least try it and see if it helps you before dismissing it?
If resolution is the problem then there's probably not much else you can do about it but reducing resolution (doesn't have to be native), but if it's not the problem then at least you know and you can move past it.

Would help if you post your PCSX2 and plugin settings and the EE/GS% values in the game window when you get slowdowns.

Tried the native resolution, works pretty well, but looks like crap Laugh
But I mean what is the reason, do other people have the same problem in the same locations or is it just me? Maybe my GPU is too weak?

(08-14-2011, 03:54 AM)xstyla Wrote: I can only view at it from the pc version of the game (I will never play it on the emulator - this' a no go Laugh).

but maybe the view distance is too much to compute all the data in a reasonable matter of time. also dunno about the amount of dynamic texture uploads - there's alot of different textures smashing the 4MB barrier - in that scene. that might cause another possible slowdown reaction. it might even be a fault of the mtvu hack that bypasses a lot of syncronity while uploading that dynamic textures.

this all a lil technical. but I love to point on that things.

major is the fact that it works faster if you lower the internal resolution. so...

jump over your shadow and play it in native if you have to. Wink

Tried playing the PC Version, it's sooo hard to set the gamepad in it :/ I have a PS3 Sixaxis connected to the PC and with every setting there are some problems, either the analog stick isn't working or shoulder buttons aren't working - problems everywhere Laugh
I tried playing DMC3 on PS3 - everything is smooth but looks like crap Laugh

I like me some technical explanations, computer science is my profession, I like to learn new things about it Smile
Reply
#5
If lowering internal res helps you to get more speed, then yeah your GPU is too weak for it.

But in the pc version as long as all buttons are working correctly in the windows, you could use some program like GlovePIE to press a keyboard key while you press pad key and play the game with pad on keyboard settings. Heh, but that counts only if the pad works in the windows already.
Reply
#6
(08-14-2011, 10:17 AM)miseru99 Wrote: If lowering internal res helps you to get more speed, then yeah your GPU is too weak for it.

But in the pc version as long as all buttons are working correctly in the windows, you could use some program like GlovePIE to press a keyboard key while you press pad key and play the game with pad on keyboard settings. Heh, but that counts only if the pad works in the windows already.

Gamepad is working OK on any game, The configuration in DMC3 is what makes the problems Smile
Even tried to emulate it as XBOX 360 gamepad and the analog sticks were switched.



Attached Files Thumbnail(s)
   
Reply
#7
as stated before, if lowering the resolution increased the speed then the problem is your GPU is too weak.

since you also say it looks like crap as native on a HD display, i play on a full 1080p HD tv via HDMI through my laptop and native resolution looks fine. I generally play at 2x native, so your just too visual based for your games it seems... makes me wonder what youd say if you were to play games like FF7/8 and the like today...
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#8
(08-14-2011, 10:02 AM)KatanaPL Wrote: Tried the native resolution, works pretty well, but looks like crap Laugh
But I mean what is the reason, do other people have the same problem in the same locations or is it just me? Maybe my GPU is too weak?

You can try using a custom resolution, something like 1536x1024 would be like 3x width and 2x height which could be better for you, you can also try enabling/disabling the "allow 8-bit textures" setting and see if it makes a difference or switching to D3D9(hardware) renderer could help too.

Having a strong GPU pretty much lets you raise the internal resolution higher, yours just doesn't let you use 3x at the moment Tongue2
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#9
I'm alil ashamed to push pcsx2 away from this game, but it's got a fully working PC port.

and for that I used "JoyToKey" (google yourself - I don't have any reliable source for it atm) to map all the buttons to a crappy saitek controller. Laugh worked like a charm (even both analoque sticks) and was fast and I finished the game with that. I think there was even a official tool to help setting up controllers for it. quite a hassle tho. but it's working if you smart enough.

well. it's up to you
Reply
#10
For fixing a problem with the controller setup in PC version - along with already mentioned JoyToKey, you could try this - GlovePIE. It allows for more advanced scripts, but doing a simple emulation is very easy.

Just go to the GUI tab, press detect output and press a key on keyboard, then detect input and press the key in your pad, click apply and continue with rest of the keys. Then go to the first tab("untitled" by default), you'll see a simple GlovePie script that changes one key press to other(from pad to keyboard in this example), save it and run this script to control your game with a pad on default keyboard settings^_^.
Reply




Users browsing this thread: 1 Guest(s)