Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Digital Devil Saga 1 and 2: need more fps
#1
Question 
Edit: I gonna try the beta of the emulator to see if there is any improvement on my issue. Will edit this with my impressions later.

Edit 2: Holy, the microVU0 and microVU1 features improved greatly the slowdown and framerate for the cinematics. Still there is this non-aligned-top glitch I mentioned in this post, and when passing to the normal game, the shadows are rendered properly but the framerate decapitates itself below 50% and even reaching 40% quotas, slowing down everything (I think I still need a way to increase the fps output when there are many 3D models rendering at the same time on scene). Overall, now it makes the games a little more "playable", except when there are many models around and the controls reacts with a huge delay due to the low fps. It also keeps making these odd "clippings" (instead of being behind the table, they appear as if they were standing over the object)
[Image: loltable.jpg]

Salutations. I have finally managed to get them both to work with an ISO made from the original games of my brother. The games works fine but with some small graphical glitches (like an inch from the top of the cinematics not being aligned with the rest of the cinematic below, or not being able to render the shadows as casted shadows upon the ground but as plain polygonal planes with 100% of opacity which skewers the 3D models of the characters in a very painsome manner).

I'm new to this emulator, and followed throughly all the guide to configure it from scratch. Since I'm new, I don't know how or "when" a game is properly emulated. I readed in these forums that the game should be always running at 60fps, but mine gets half of it (50~53% as 30~33fps rate). Also readed that the sounds and music usually adapts themselves to the actual FPS rate of the game, and supposedly that's the explanation to why they slow-down in my case (they sometimes plays smoothly at certain points of the game when the frame-rate is higher of course).

So I came to a conclussion that in order to emulate the game decently, I should increase the FPS of it in some way. I think my graphic card and my processor are decent enough to make them to "give more fuel" for the emulator (I'm worried about its ghz since they are only 2.40ghz and I dunno if that will hinder the processor to pull more power for my needs).
And now the questions:

-How I increase the fps rate of the emulator?
-What are exactly those "speed hacks" everyone talks about?
-Will I need to "overclock" my computer for this? (I don't know what is to OC a computer at all, but I readed in a thread that some people got better results with OC'd computers, and that made me to wonder...)

Hope someone can help me with this. As for other data (related to how I configured everything), I barely tweaked the defaults, just changed to SS3 since my processor allows it, pixel shader of 2.0, Weave BFF (saw-tooth), aspect ratio of 16:3 since I can pull widescreen, D3D and Native made no difference at all in my case so I left D3D with the default. For the sound left the SPU2-X with the defaults, and the CDDVDROM Gigaherz's CDDVD 0.7.0 plugin, linking to the emulated compressed ISO in a virtual CDDVD drive made with Daemon Tools.

I think I have not forgot to tell everything about my config. Left my full computer specs in my signature Ninja I just want to get at least more than 50fps to make the sound and everything else to work smoothly. I thought about trying to use frameskips, but I hadn't the luck to find out how to tweak that with this emulator (or if that will increase the performance at all - couldn't tested it orz )
Reply

Sponsored links

#2
Speedhacks are located in the "config > speedhacks" menu, you may have to try playing with those "x2 cycle rate" and "vu cycle stealing" set to slight/moderate usually increase the speed of the games a bit without making them glitchy.

The problem with the picture is because of GSdx, GSdx r1406 is the last working without that problem but the ones after actually show the shadows correctly, last I remember DX10 is some of a bit of speed gain on this game at least if I recall correctly but you cant use it due to XP unfortunatelly.

http://pcsx2.dyndns.org/index.php?n=GSdx
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
Your fps are indeed too low for this kind of pc.
Try using ZeroGS as GS plugin, or put GSdx in software rendering mode.
(I'm thinking your vga card might be a problem for GSdx, not sure though.)
Reply
#4
ZeroGS has the same Z-depth problem as modern gsdx do. I fix this in ZZogl (and it's became quicker a bit), but I do not sure, that it would be quick enough.
Reply
#5
Sorry for bumping an old thread if this kinda thing is looked down on... but I'm having similar problems as the OP so I figured it wouldn't hurt. Unsure

I'm using GSDx 1.16 and all of the glitches (like standing on the table) seem to be fixed, but I'm still having FPS issues. I've tried other graphics plugins (GSDx 1.15, ZeroGS, ZZogl) but they don't improve the FPS at all and/or the glitches show up.

I've tried software mode which helps with the glitches but not FPS, and tried using internal res which didn't change anything.

I've tried different combinations of speed hacks but I still drop to 30fps in some areas... with some speed hacks it says it's running at 60fps but clearly isn't.

So is there anything I can try? Or is Digital Devil Saga just a PITA?
Vista 64bit
Intel Core 2 Quad @ 2.50GHz
GeForce 9800 GTX+
Reply
#6
(03-15-2010, 09:56 PM)Taxt Wrote: Sorry for bumping an old thread if this kinda thing is looked down on... but I'm having similar problems as the OP so I figured it wouldn't hurt. Unsure

I'm using GSDx 1.16 and all of the glitches (like standing on the table) seem to be fixed, but I'm still having FPS issues. I've tried other graphics plugins (GSDx 1.15, ZeroGS, ZZogl) but they don't improve the FPS at all and/or the glitches show up.

I've tried software mode which helps with the glitches but not FPS, and tried using internal res which didn't change anything.

I've tried different combinations of speed hacks but I still drop to 30fps in some areas... with some speed hacks it says it's running at 60fps but clearly isn't.

So is there anything I can try? Or is Digital Devil Saga just a PITA?

Uh, u shouldn't use the internal res, try to enable native option. And yup, speedhacks give false FPS reading, so it's usual if u experience that. Did u use directx10 or directx9 ?And what's your version of pcsx2 ?
SPECS:
i7-2630QM
NVIDIA GT540M
500GB SATA
4GB DDR3
Windows 7 Home Premium 64-bit
Windows 7 Professional 64-bit
Windows 8 Pro 64-bit


Acer Aspire 4750G
Reply
#7
Also make sure that vsync is disabled (You're only mentioning exactly 30 or 60fps, hence I suspect you have it enabled Tongue2 ).
Reply
#8
I meant to say native res not internal res. It didn't make a FPS difference.

I have vsync disabled, I was just rounding my fps up or down. The worst it gets (so far) is the low 30s.

I tried DX9 and DX10, pcsx2 9.6 and the beta 1888.
Vista 64bit
Intel Core 2 Quad @ 2.50GHz
GeForce 9800 GTX+
Reply
#9
(03-16-2010, 06:25 PM)Taxt Wrote: I meant to say native res not internal res. It didn't make a FPS difference.

I have vsync disabled, I was just rounding my fps up or down. The worst it gets (so far) is the low 30s.

I tried DX9 and DX10, pcsx2 9.6 and the beta 1888.

What are the best setting to run digital devil saga 1?
Reply




Users browsing this thread: 1 Guest(s)