Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Digital Devil Saga (U) on PCSX2 1.2.1
#1
I've been trying to get this game to work and, while it is fully playable, it stops just shy of being fluid. The game lags a little in some walkaround areas but usually it's okay, but during battle it lags badly enough that the sound slows and stutters.

I've tried setting the sound to desync and async mix, but neither seems to help, and i've tried turning it down to absolute minimal settings but there is absolutely no change. Whether i'm running it at 6x sampling or native, the issue stays the same.

I AM playing on a laptop, but I doubt my hardware is the issue. Still:

NVidia GT 780M
16GB of RAM
Intel Core i7-4700MQ CPU @ 2.40 GHz 2.40 GHz
Windows 8 64bit

As for my settings, the best performance I've gotten is generally:

DirectX11 Hardware Mode
6x Native Sampling
Texture Filtering

Enable Shade Boost/FXAA/FX Shader

It's noteworthy that this laptop also has an Intel HD card and that I had to manually set the plugin to use the Nvidia card as the adapter, but I have no way to check whether it's actually using the Nvidia card that I know of.

Thank you for your help
Reply

Sponsored links

#2
On a laptop with the resolution cramped up to x6? You have a deathwish right there, put it back on x2 and work your way from there. Also make sure you've set your power plan to high performance to avoid some of the throttling, but do keep an eye on your battery and temperatures.
Reply
#3
You did see that the OP has a 780m right?
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#4
Like I said I've used every single setting from native to 6x and there's no change.

I monitor my temperatures constantly and I always have it set to High performance and plugged in, I've also set the processor to 100% output in the advanced power settings.

My temperatures never exceed 50C as my laptop is a high-end Sager with dual fans and it's honestly pretty great at ventilation. Also, if it was throttling then PCSX2 should work perfectly to begin with and then lose performance once the heat ramps up, but I have saves placed right before fights to test this and fights ALWAYS lag the sound and animation, no matter what my temperatures are.

It's worth noting by the way that the audio slows down while the menu is visible and I can pick skills during fights, but when the actual fight animations play out, for example casting Agi or Bufu or simply attacking, the game ramps up to full speed and the audio plays perfectly!

In fact, setting the fighting to Auto results in perfect performance, even at 6x sampling. So it really doesn't seem to be that! It's more like some particular setting I have on a software level makes it really hard for the game to manage something in the battle screen--maybe the AMOUNT of objects that need to be rendered, with all the menu items and different player character and enemy models on screen at once

I'm not entirely sure what settings would govern things like that, though, so if there's something I missed I have no way to know. Regardless, given that I CAN get perfect performance, it seems doubtful that my hardware is the issue here.
Reply
#5
Are you using any speed hacks
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#6
Yeah, right now I have:

EE Cyclerate at 2

VU Cycle Stealing at 2

INTC Spin detection enabled

Wait loop detection enabled

Fast CDVD enabled

mVU Flag Hack enabled

MTVU Multi-threading enabled

so basically, everything is enabled. I did it in an attempt to improve performance, and it mostly does...but it always stops just shy of perfect, primarily in the battle scenes as I said. Could one of these things be the ones CAUSING the issue though? Maybe I fixed the speed but then created an issue with the speedhacks that seems like lag?
Reply
#7
(04-21-2014, 06:42 AM)Tazzypillar Wrote: Yeah, right now I have:

EE Cyclerate at 2

VU Cycle Stealing at 2
..
Fast CDVD enabled
...

Fast CDVD only needed when you play from dvd disk.

EE & VU Cycle turn it off.
Reply
#8
Thank you! Turning off EE & VU Cycles fixed the issue. I also turned off CDVD but I did that after the issue was fixed.

The audio still has slowdowns very, very occasionally, but I don't suppose anything can be done for that and it isnt too much of an issue anyway
Reply
#9
You can put try to increase EE again... But slowly.
You can also put the spux-2 output mode to timestretch instead of async-mix. Then you would not hear lags anymore even if they are present. This can crash some games but I have seldom heard of it the last weeks.
Reply
#10
The VU cycle stealing was probably the biggest problem as that tends to cause far more issues than the EE cycle rate hack.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply




Users browsing this thread: 1 Guest(s)