Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Direct3D11 not working if second monitor connected
#1
Hello,

If I want to use my TV to play PCSX2 games with Direct3D11 Hardware (connected with a HDMI cable) I get a black screen in PCSX2 (even the full boot is a black screen).
If I remove the HDMI cable of my TV, I'm not getting a black screen.

With Direct3D9, this problem is existant. Two monitors are working fine with it.

Because Direct3D11 is much better and my GPU is supporting it, I'd prefer Direct3D11 and use it instead with my TV.

My hardware:
CPU: i7-2760QM with Intel HD3000
GPU: nvidia GT555M (this one is used in PCSX2).

Could someone help me?
Reply

Sponsored links

#2
It will work if the TV is configured as the primary display, but obviously then the other screen will be black.

and since the intel device didn't have these problems iirc its an nvidia driver issue with d3d11 (some AAA d3d11 games have this issue as well)
Reply
#3
I think you misunderstood something.

It's not the whole screen which is turning black, it's only the PCSX2 window. And that in both screens, doesn't matter which one is the primary screen.
Reply
#4
are you setting the tv to dual view or clone?
Reply
#5
With "clone" I don't get a black screen, but PCSX2 is really slow (because it's shown on 2 monitors).
With dual view I just get the black screen. Sad

I really would want to use it with dual view.
Reply
#6
in the latest svn, select the Geforce device in the list rather than leaving it set to default graphics device

this is seemingly an optimus specific issue with external displays
Reply
#7
no problems here and he has probably the same laptop/set-up as mine, if you are connected to the tv, rightclick on the desktop and select screen resolution, and select the tv as main monitor. the screen should be black now on the laptop and you should have the desktop on your screen now.


if you start pcsx2 and play a game dont go into fullscreen just yet, see if it plays accordingly, if it does, alt and enter to go fullscreen. (or double click if you have that in the settings enabled
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply
#8
That's really working, thanks warWeeny!!! Smile

Just sad that the whole desktop and everything is shown in the TV then, that way I have to toggle the main monitor all the time. Isn't there an alternative?
Reply
#9
like i said, this seems specific to optimus enabled laptops

multiple displays work fine on desktop d3d11 parts

some wowtards have noticed it to occur as well
Reply
#10
I was able to pull the taskbar to the second monitor. That way, the TV is the main monitor if I use it, even if my taskbar is on my laptop.

PCSX2 is working perfectly fine now and I'm happy to play my beloved Persona4! Smile

Thanks a lot Squall and warWeeny!!!!
Reply




Users browsing this thread: 1 Guest(s)