Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
DirectX Slow?
#1
When I have the graphics on D3D Hardware mode, it's ~40 FPS and the sound's choppy. When I have OpenGL Hardware mode on, it's 60 FPS. Why does this happen?


Desktop Specifications:

Motherboard: ASRock Z87 Extreme4
CPU: Intel i7 4770K
RAM: 16GB DDR3
GPU: AMD Radeon HD 7800 Series
OS: Windows 7 Pro 64-bit
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(11-17-2014, 07:53 PM)jesalvein Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.

I'm trying to play Call of Duty - Finest Hour from an iso file.
I only changed the graphics settings and controller settings.

I'm playing on PCSX2 1.2.1
I've attached a picture of the graphics settings window.


Attached Files Thumbnail(s)
   
Reply
#4
What if you disable antialiasing ?
What do the ee% and gs% say when it's slow ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
(11-17-2014, 10:21 PM)jesalvein Wrote: What if you disable antialiasing ?
What do the ee% and gs% say when it's slow ?

Disabling AA and other enhancements doesn't affect the FPS at all.

EE: 99-100%

GS: 40-50%

At the beginning when there's lots of fog, it's at ~40 FPS. When the fog's gone it goes to ~55 FPS.
Reply
#6
You cpu is being maxed out
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#7
(11-17-2014, 10:49 PM)Nobbs66 Wrote: You cpu is being maxed out

It's only using 30% of my CPU.
Reply
#8
Give software mode + 3 extra rendering threads a try
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#9
Try skipdraw 4 to under hwhacks.
Reply
#10
(11-17-2014, 10:53 PM)masterCameron101 Wrote: It's only using 30% of my CPU.

You can utilize another core if you turn on MTVU(3 instead of 2 normally), but pcsx2 can't just automatically split up the work it does on extra cores. Even if you have MTVU on, and you're not using software rendering, PCSX2's performance can easily be limited by your cpu, even though it's only using 2-3 cores.
Reply




Users browsing this thread: 1 Guest(s)