Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Does the sound plugins for pcsx2....
#1
Rely more on your CPU or your Sound Card? just wondering because I'm getting slowdown in games and its tied to the sound.
Reply

Sponsored links

#2
All sound plugins use your processor's power to emulate the SPU2. So no,your sound card is not used at all. What do you mean slowdowns tied to the sound? If the game is below full FPS,sound will slow down too to match the video speed.
[Image: newsig.jpg]
Reply
#3
I see this same kind of issue in my machine. I'm not sure why that is but if I were to use the null driver for sound, performance is much better depending on the game. I'm not sure if that's because my CPU speed just isn't up to snuff (which I don't think is the case) or there is some other configuration causing the problem.

I'm seeing this in FFX presently with using SPU2-X with everything disabled and using Direct sound. I'm using GSDX DX9 (10 runs slower for me) 1920x1200 internal res, everything else is checked. Speed hacks are 2x cylce, everything but waitcycles sync is checked, with VU stealing on moderate and with all that it runs very well (55-60 frames) but occasionally the sound will get choppy and get out of sync and the games slows down a little. However using the null sound driver I haven't seen any slow downs. Perhaps I should try overclocking and see if it goes away. I saw in another post that PCSX2 is highly dependant on clock speed more than anything else.
--------------------------------
OS's: Windows 7 RC 1 x86 \ Kubuntu 9.04 x86
CPU: AMD Phenom II x4 940 BE
GPU: Nvidia Geforce 260 GTX
--------------------------------
Reply
#4
The increased job of emulating sound can cause slowdowns in pcsx2, after all, having to emulate audio can be taxing as well. Overclocking your cpu is probably the best thing to try as pcsx2 is very reliant on clockspeed.
Reply
#5
(07-23-2009, 10:38 PM)nasageek Wrote: The increased job of emulating sound can cause slowdowns in pcsx2, after all, having to emulate audio can be taxing as well. Overclocking your cpu is probably the best thing to try as pcsx2 is very reliant on clockspeed.

I just found it odd that if I weren't moving or doing anything the sound would randomly just get messed up and out of sync and after about 5 seconds or so it'll resync and be fine. Perhaps it is just the clock speed. I'll give it a whirl I guess, hope my cooler is up to the task.
--------------------------------
OS's: Windows 7 RC 1 x86 \ Kubuntu 9.04 x86
CPU: AMD Phenom II x4 940 BE
GPU: Nvidia Geforce 260 GTX
--------------------------------
Reply
#6
Care to share your audio configuration? There is a possibility it's unrelated to your cpu if it happens when idle.
Reply
#7
Here are all my settings using the latest versions of the plugins to my knowledge.


Attached Files Thumbnail(s)
   
--------------------------------
OS's: Windows 7 RC 1 x86 \ Kubuntu 9.04 x86
CPU: AMD Phenom II x4 940 BE
GPU: Nvidia Geforce 260 GTX
--------------------------------
Reply
#8
(07-24-2009, 05:54 AM)bobkornog Wrote: Here are all my settings using the latest versions of the plugins to my knowledge.

Try disabling "wait vsync" and "Disable time-stretching"
Reply
#9
Everything seems in order to my relatively untrained eye. Maybe you could give the other audio plugin a try?
Reply
#10
(07-23-2009, 10:53 PM)bobkornog Wrote: I just found it odd that if I weren't moving or doing anything the sound would randomly just get messed up and out of sync and after about 5 seconds or so it'll resync and be fine. Perhaps it is just the clock speed. I'll give it a whirl I guess, hope my cooler is up to the task.

It happens sometimes specially if you have speedhacks on. Just take in count PCSX2 isnt perfect Tongue
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)