Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dragon Quest V and GSdx10
#1
I'm trying to play my copy of Dragon Quest V (patched in English) but for some reason, the menus are overlapping. I found out that the issue arises with the use of GSdx9 (which is odd) I have to use GSdx10. Downloaded the Plugin but I get an error saying:

The selected GS plugin failed to load.
Reason: The plugin reports that your hardware or software/drivers are not supported.
C:\PCSX2 1.2.1\Plugins\GSdx10.dll

I already uninstalled and am now using the binary version of PCSX2. Re-downloaded the Plugin just in case the first download got corrupted to no avail.

Operating System: Windows 7 Pro 32-bit(7601.win7sp1_gdr.130828-1532)
Language: English (Regional Setting: English)
System Manufacturer: IBM
System Model: 8144NUY
BIOS: Phoenix FirstBios™ Desktop Pro Version 2.0 for ThinkCentre.
Processor: Intel® Pentium® 4 CPU 3.20GHz (2 CPUs), ~3.2GHz
Memory: 1024MB RAM
Available OS Memory: 1022MB RAM
Page File: 1688MB used, 358MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled

It's an old computer, I know. But Dragon Quest V is pretty much playable except for the annoying, headache-inducing menus that I have to go through whenever I need to check their equipment, stats, etc. Oddly enough, I already tried playing this on a Windows XP computer 2 years ago (obviously it wasn't running GSdx10) but I never had this issue then.

Thanks in advance!
Reply

Sponsored links

#2
tried :
- software mode (F9)
- without patching your iso with the English patch
- d3d9 renderer
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
What exactly do you mean with overlapping?

Using pcsx2 1.0 or 1.1 stable, the game (v1.2 translation) should run fine in hardware mode, only the last dungeon has heavy camera issues which were not present in older youtube Let's plays:

http://forums.pcsx2.net/Thread-Dragon-Qu...al-Dungeon
Reply
#4
Thumbs Down 
(03-09-2014, 08:24 PM)jesalvein Wrote: tried :
- software mode (F9)
- without patching your iso with the English patch
- d3d9 renderer

Software Mode fixed it! Thanks!!! But one question, I've Googled the difference between Hardware and Software Rendering and found out that Software Rendering is very demanding for the CPU, does that mean I shouldn't spend hours playing the game to avoid breaking the computer?

(03-09-2014, 08:40 PM)etking Wrote: What exactly do you mean with overlapping?

Using pcsx2 1.0 or 1.1 stable, the game (v1.2 translation) should run fine in hardware mode, only the last dungeon has heavy camera issues which were not present in older youtube Let's plays:

http://forums.pcsx2.net/Thread-Dragon-Qu...al-Dungeon

Whenever I try to open menus like Status, Items, etc., the new window/menu pops up behind the other windows. The transparency doesn't help since all the words are on top of each other instead of hiding previous windows from view.

Example Image (not mine) http://forums.pcsx2.net/attachment.php?aid=22855

PS: I read your post about the issue you're having. I hope I won't encounter that on mine. You could try posting this issue in the Dragon's Den forums (woodus.com) and see if there's someone there who could help.
Reply
#5
More demanding does mean it might run slower but it will not break your computer. Software mode means pcsx2 will only use the CPU and not the GPU which is specialized in graphics processing and therefore much faster. You can speed up software mode by setting extra rendering threads to 2 in gsdx settings and by enabling mtvu speedhack.

Hardware mode is usually faster and allows to play the game in higher display resolutions.

To fix hardware mode you can try to enable alpha and half pixel offset hacks in gsdx and enable everything under hardware mode settings in gsdx. Also try to disable the two cycle stealing speedhacks (if enabled), they will cause crashes in this game anyway.

Another fix could be to try a custom gsdx internal resolution, x2 or maybe 640x480 or 800x600 should be OK with your hardware.

What kind of GPU (graphics card), GPU drivers and GPU driver settings do you use, the issue may also be located there. I checked the game with pcsx2 1.2.1 gsdx v5875 DX9 and DX11 and I do not have that window rendering issue in hardware mode.

You do not need to download different gsdx plugins as the DX version can be set in gsdx plugin settings. You also should use the SSE3 version of gsdx which is the fastest version for your Pentium 4 CPU.
Reply
#6
I've had my import copy of the PS2 version of Dragon Quest V sitting on the shelf unwrapped for years. This thread reminded me that I still own it LOL. I want to play it someday but not sure I can tolerate jrpgs anymore. They're just so tedious these days. I bought this game at a time when I was feeling nostalgic and "in the mood" for a good jrpg. I should give it a go and finally play this version(played the original snes one and loved it many years ago).
Reply
#7
@etking: I was thinking that running games in Software Mode is kinda like overclocking the computer, which I heard can break it. I don't want to have the pc just one day die on me and smell burnt electronics because of playing with it for extended periods just like I would with a PS 2. I'm too noob and a little paranoid for this kind of stuff. >_<

Your instructions are clear enough for me to be able to tweak the suggested settings but it the issue still persists in Hardware Mode (which I noticed, actually runs the game a bit slower in my case - even without the tweaks you suggested. I never paid attention to the FPS difference between the two modes - Software's better for me). By the way, it won't let me use any SSE3 version of GSdx because of incompatibility. My GPU's quite old:

Card name: ATI Radeon X300/X550/X1050 Series
Manufacturer: ATI Technologies Inc.
Chip type: ATI Radeon Graphics Processor (0x5B60)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_5B60&SUBSYS_038114CD&REV_00
Display Memory: 318 MB
Dedicated Memory: 63 MB
Shared Memory: 255 MB
Current Mode: 1360 x 768 (32 bit) (60Hz)

PS: English isn't my native language but I hope you understand what I'm trying to say.


@Isamu: Go for it! The nostalgia you'd get with this game is much better compared to playing the DS remake (that's how it was for me, at least). It's the same game and experience yet a new one because of the differences if you know what I mean. I just wish that the Android/iOS port would use this instead of the DS version.
Reply
#8
(03-10-2014, 07:38 AM)Lightpost Wrote: @etking: I was thinking that running games in Software Mode is kinda like overclocking the computer, which I heard can break it. I don't want to have the pc just one day die on me and smell burnt electronics because of playing with it for extended periods just like I would with a PS 2. I'm too noob and a little paranoid for this kind of stuff. >_<

Your instructions are clear enough for me to be able to tweak the suggested settings but it the issue still persists in Hardware Mode (which I noticed, actually runs the game a bit slower in my case - even without the tweaks you suggested. I never paid attention to the FPS difference between the two modes - Software's better for me). By the way, it won't let me use any SSE3 version of GSdx because of incompatibility. My GPU's quite old:

Card name: ATI Radeon X300/X550/X1050 Series
Manufacturer: ATI Technologies Inc.
Chip type: ATI Radeon Graphics Processor (0x5B60)
DAC type: Internal DAC(400MHz)
Device Key: Enum\PCI\VEN_1002&DEV_5B60&SUBSYS_038114CD&REV_00
Display Memory: 318 MB
Dedicated Memory: 63 MB
Shared Memory: 255 MB
Current Mode: 1360 x 768 (32 bit) (60Hz)

PS: English isn't my native language but I hope you understand what I'm trying to say.


@Isamu: Go for it! The nostalgia you'd get with this game is much better compared to playing the DS remake (that's how it was for me, at least). It's the same game and experience yet a new one because of the differences if you know what I mean. I just wish that the Android/iOS port would use this instead of the DS version.
Your cpu doesn't support ssse3
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#9
I've no overlapping problems using either DX11 or DX9:
http://i.imgur.com/av4exXQ.jpg
Make sure you're using the latest PCSX2 release, which is 1.2.

Isamu: This isn't your typical JRPG that needs to be tolerated. This game is awesome! Smile
Reply
#10
@Nobbs66: Just as I thought. I guess I just have to stick with Software Mode.

@Rama: I'm using 1.2.1. Already tried uninstalling it and used the binary version instead. I even tried the latest SVN. The issue only appears when Rendering is set to Hardware Mode. In Hardware Mode, CPU usage doesn't reach 50% but it seems like my graphics card is really bad, it can't display those menus properly. I guess I should stick with Software Mode because not only it displays the menus correctly, it's a lot faster. The only downside is I have to get used to the computer's loud fan noise and hot air blowing out of it.


@Isamu: Unwrap the game and play it! This remake is much more immersive because of how you can view places in 360. And the "Ooh! I remember this/that!" adds a bit more fun to it. I'm sure it's worth your time since you loved the original. Just like what Rama said, it's awesome!
Reply




Users browsing this thread: 1 Guest(s)