Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dragon Quest VIII Invisible Enemy
#1
Question 
Hi,

Just wondering if anyone here also encountered this. I fought a "Firespirit" near Farebury and it was invisible. Toggling "Software" mode  shows them but it's slow to play.

Here's a screen shot of the monster in the bestiary.

Does anyone know how to fix this? I tried fiddling the Gsdx configs with no luck. I also saw a similar post but didn't find any fix there.

[Image: 2elqqeo.png]
Reply

Sponsored links

#2
Only software mode will work properly. Try setting Extra SW rendering threads to something bigger than 0, like 2 or 3 (depending on the cores your CPU has)
[Image: newsig.jpg]
Reply
#3
It's been so long ago the last time I played this game and I can't find that monster(I didn't even remember where Farebury is until I use google)but in the monsters list,that monster(and any other that I have in that family)is completely visible no matter what I try.
DX9\11\OGL SW\HW

Edit:Even with HD4600
Reply
#4
(08-10-2015, 11:02 AM)Bositman Wrote: Only software mode will work properly. Try setting Extra SW rendering threads to something bigger than 0, like 2 or 3 (depending on the cores your CPU has)

This will work while in SW mode? or also while in HW mode? In SW mode I can view the monster properly.
Reply
#5
(08-11-2015, 02:35 AM)akfgkort Wrote: This will work while in SW mode? or also while in HW mode? In SW mode I can view the monster properly.

In DirectX HW Mode, go to GSDX Plugin Settings. If 'Enable HW Hacks' is checked, Settings, select 'Configure...' next to 'Enable HW Hacks'; under the new submenu, ensure the 'Alpha' box is NOT checked - if the box is checked, it will cause the issue of the Firespirit to not render correctly. 

Also, you might need to set 'Skipdraw' to '1' under DirectX mode to enable partial character shadows.
Reply
#6
Current git
OpenGL HW 3x
CRC=None

that shows fine.

DX11 much of the same other then the whole Nvidia DX11 driver bug that currently has Texture bug cause textures to flash black. The shadows are also fix with HW Depth addition in both Opengl/DX11

Im thinking that is old build maybe intel gpu?
Reply
#7
(08-16-2015, 02:14 AM)tsunami2311 Wrote: Current git
The shadows are also fix  with HW Depth addition in both Opengl/DX11

Im thinking that is old build maybe intel gpu?

Also current git, no ability to enable HW Depth under Direct3D11 - only OpenGL (which runs quite slowly on my Radeon 280x, so have to stick with DirectX11)

D3D11 HW
4x Native
Skipdraw 1 for Gameplay, 0 for Cutscenes
CRC None
Half-Check Sprite Hack
Half-Check Round Sprite Hack
Texture Filtering Full
16x Anisotropic
Reply
#8
You dont need skipdraw shadows work fine in dx11/opengl,
dont need spritehack or round sprite either

you dont need any hw hacks for dq8 for it to run and look correct

DX11
3x
TF=full

Opengl
3x
TF=full
Hw depth

crc=non

Image is fine and show proper so does shadows
Reply
#9
(08-16-2015, 03:19 AM)tsunami2311 Wrote: You dont need skipdraw shadows work fine in dx11/opengl,
dont need  spritehack  or round sprite either

you dont need any hw hacks for dq8 for it to run and look correct
Wish I could repeat this on my machine with D3D11 HW (latest Git 1.31-20150815200634, same behaviour in previous git snapshots), clean plugin folder with latest GSDX plugin (2015081500634 MSVC 18.00, AVX 1.0.0) - screenshots attached. Radeon 280x, Win 8.1, Catalyst 15.7.1, Intel 2700k @ 4.0Ghz.

Shadows do not work properly in D3D11HW; also using Sprite and Round Sprite Hacks to clean up 2D menus when upscaling.

*EDIT*: EE Cyclerate is at default cyclerate, and VU Cycle Stealing is disabled.


Attached Files Thumbnail(s)
                   
Reply
#10
"using Sprite and Round Sprite Hacks to clean up 2D menus when upscaling."
Also make menu jaggy and ugly, I rather have the marks still there, then have TF be disabled cause it is disable with either of those 2 hacks used, to each his own i guess

DX11 should have shadows with out skip draw as it was working both opengl/dx11 when it was first introduced a month or so ago, must be some regression.

Either way DX11 and Opengl both show firesprite,The black in DX11 pic is due to another driver bug nvidia introduce in DX11 that effect gsdx when scaling is used.

And why are you not using opengl is has better compatibility then dx11 at this point

Using GSdx32-SSE4 here
Reply




Users browsing this thread: 1 Guest(s)