Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dragon Quest VIII resolution
#1
Hello everybody. 

I seem to be having a problem playing DQ8 on anything higher than native resolution. Whenever I put it even a little bit higher than native, I drop down to 10fps or less. I've never really had this problem with any other game before and I'm not sure what to do. I haven't done a ton to change my settings so most are set at default I believe. 

I'm playing on an Asus G73SW -  specs: http://www.pcworld.com/product/815395/as...ebook.html

Also I have access to the game disc if that could help at all. I'm not too knowledgeable on this kind of stuff so if anybody has any ideas on how I might be able to fix this by changing settings or something, it would be greatly appreciated.
Reply

Sponsored links

#2
DQ8 is basically GPU taxing.
since your GPu is a bit on the low side, it's not surprising.
I guess you won't be able to push higher than 2x native if you want to avoid slowdowns
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Possibly removing some effects with skipdraw (values from 1-10) and increasing resolution you get a better experience. Often effects like fire or sparkling are hard to emulate. If you remove them you can achieve higher resolutions - at the same time loose effects that might be necessary for the experience.
Reply
#4
Use DX9 and disable Alpha Correction (FBA)...I got nice speed boost doing that(not that I need it Tongue))

There isn't much difference between 2x and above but man,the difference between native and 2x on 1920x1080 screen is just amazing.
Edit:Btw at native,the texture filtering makes the game really blurry.
Reply
#5
(08-10-2015, 05:44 PM)jesalvein Wrote: DQ8 is basically GPU taxing.
since your GPu is a bit on the low side, it's not surprising.
I guess you won't be able to push higher than 2x native if you want to avoid slowdowns

I was a bit afraid of that, but oh well. My laptop is a few years old now so there's no getting around it. I'd be fine with 2x but even that's a bit choppy right now, especially the sound.

(08-10-2015, 06:17 PM)willkuer Wrote: Possibly removing some effects with skipdraw (values from 1-10) and increasing resolution you get a better experience. Often effects like fire or sparkling are hard to emulate. If you remove them you can achieve higher resolutions - at the same time loose effects that might be necessary for the experience.

This does seem to help a little bit, thanks.

(08-10-2015, 06:58 PM)vsub Wrote: Use DX9 and disable Alpha Correction (FBA)...I got nice speed boost doing that(not that I need it Tongue))

There isn't much difference between 2x and above but man,the difference between native and 2x on 1920x1080 screen is just amazing.
Edit:Btw at native,the texture filtering makes the game really blurry.

Disabling Alpha Correction seemed to help out quite a fair bit. I'm a bit embarrassed to say I'm not sure what DX9 is though. I looked around various options but never saw anything for that. 

That blurring on native res is really what's killing it for me right now, and why I at least want to get 2x to run smooth enough.
Reply
#6
You can't disable it in any other mode so you are already using DX9(Direct3D9 (Hardware) if you need the full name)
Reply
#7
Ah ok, yeah I recognize the full name now.

Thanks for the help, I'm going to continue to mess with it and hopefully I can get it to 2x. These things have helped a great deal so I'm pretty close now.

EDIT: Alright, I think I'm good to go now. I forgot my NVIDIA setting was to max quality, but when I switched it to balanced everything started going much faster without really sacrificing too much. Now I'm able to run 2x really smooth audio and video wise.
Reply
#8
Smooth audio is possible even below full speed using async mix as synchronization mode in spu2-x plugin settings.
Reply
#9
Even when running full speed the audio on timestretch may sound funky because of the slightly fps fluctuations that happens even when the game is running full speed so I just leave it set to async myself because of that.
Reply




Users browsing this thread: 1 Guest(s)