Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Dragon Quest VIII shadows
#1
So I read that you need to enable skipdraw to 1 to enable character shadows, but it's causing the screen to constantly flicker. Is there another way to get shadows working in this game?
CPU: Intel Core i5-3470 Quad Core @ 3.6GHz
RAM: 8GB
GPU: Nvidia GeForce GTX 660 Ti
OS: Windows 7 Ultimate x64
Reply

Sponsored links

#2
Try press F9.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
Software mode completely destroys the visuals. I'd rather have no shadows than making the game looking like absolute crap.
CPU: Intel Core i5-3470 Quad Core @ 3.6GHz
RAM: 8GB
GPU: Nvidia GeForce GTX 660 Ti
OS: Windows 7 Ultimate x64
Reply
#4
You realize "absolute crap" is the way the game looks on the real machine?

Anyway, you asked for another way, and I gave you one. No shadows, or "absolute crap" those are your choices.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#5
(07-01-2014, 08:04 AM)Blyss Sarania Wrote: You realize "absolute crap" is the way the game looks on the real machine?

Anyway, you asked for another way, and I gave you one. No shadows, or "absolute crap" those are your choices.

PS2 emulation at native resolution looks worse than playing on a real PS2. It's like you haven't seen how games look on CRT TVs.
CPU: Intel Core i5-3470 Quad Core @ 3.6GHz
RAM: 8GB
GPU: Nvidia GeForce GTX 660 Ti
OS: Windows 7 Ultimate x64
Reply
#6
(07-01-2014, 07:52 AM)PyroBunta Wrote: Software mode completely destroys the visuals. I'd rather have no shadows than making the game looking like absolute crap.

I agree graphics look terrible at native resolution especially on modern screens easiest solution to all of these hardware mode bugs would be option to increase resolution in software mode. I prefer better graphics over speed.
Reply
#7
"PS2 emulation at native resolution looks worse than playing on a real PS2"

Incorrect. Hook up your PC to a CRT TV and it will look exactly the same as a PS2 would. Hook your PS2 up to an LCD and it will look like PCSX2 does.

Regardless, if you are that dissatisfied, you should be playing on your PS2 anyway.

@Monochrome100 - Software mode doesn't have bugs because it focuses on accuracy. Allowing upscaling would not be focusing on accuracy, and would introduce many of the same bugs. And probably new ones.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#8
(07-01-2014, 04:53 PM)Blyss Sarania Wrote: "PS2 emulation at native resolution looks worse than playing on a real PS2"

Incorrect. Hook up your PC to a CRT TV and it will look exactly the same as a PS2 would. Hook your PS2 up to an LCD and it will look like PCSX2 does.

Regardless, if you are that dissatisfied, you should be playing on your PS2 anyway.

@Monochrome100 - Software mode doesn't have bugs because it focuses on accuracy. Allowing upscaling would not be focusing on accuracy, and would introduce many of the same bugs. And probably new ones.

I'd expect everyone that hears "emulation" to know that it's almost always done on a computer's LCD screen. Let me fix that line then: "PS2 graphics at native resolution on an LCD screen looks worse than on CRT TVs".

All I asked was IF there was another option/way instead of just going software mode. Apparently the answer is no. So I'll deal with playing the game without shadows.
CPU: Intel Core i5-3470 Quad Core @ 3.6GHz
RAM: 8GB
GPU: Nvidia GeForce GTX 660 Ti
OS: Windows 7 Ultimate x64
Reply
#9
(07-01-2014, 04:53 PM)Blyss Sarania Wrote: "PS2 emulation at native resolution looks worse than playing on a real PS2"

Incorrect. Hook up your PC to a CRT TV and it will look exactly the same as a PS2 would. Hook your PS2 up to an LCD and it will look like PCSX2 does.

Regardless, if you are that dissatisfied, you should be playing on your PS2 anyway.

@Monochrome100 - Software mode doesn't have bugs because it focuses wit accuracy. Allowing upscaling would not be focusing on accuracy, and would introduce many of the same bugs. And probably new ones.

According to Dolphin devs resolution has no relation with accuracy and how do you explain Desmume X432R is working fine at higher resolutions with softrasterizer ?
https://forums.dolphin-emu.org/Thread-wi...ity?page=5
Besides why cant hardware mode become more accurate as well ? Dolphin hardware mode is far more accurate than the one in pcsx2. If thats to hard adding option to increase resolution in software mode would be still be far easier and quicker solution.
Reply
#10
You can't compare dolphin to pcsx2 like that, the graphics units of the consoles they are emulating are COMPLETELY different. Hardware mode relies on compatibilities, with the PS2 there was so much custom/off spec stuff it makes it extremely difficult to emulate things correctly without a massive speed hit (or at all).

As for a higher resolution Software mode, it's probably possible, it has been discussed, but due to the complexity of the design and how horrible it is to follow gabests code, nobody would even want to try tackling it, and again, a speed hit to an already slow system, Desmume can afford it because the DS has a relatively simple graphics chip which doesn't require much power.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)