Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Drops to 30 fps, don't know how to disable vsync
#1
Hey guys, have a problem.
I've downloaded PCSX2 pretty recently, wanting to experience some of my old favorites again (Ratchet and Clank, Jack and Daxter, Crash Bandicoot, etc.) and I've gotten everything up and running fine, but I'm getting fps drops to about 30-40 fps (usually 60). I've tried disabling the frame cap but, obviously it is way to fast, giving me something like 400 fps. (I can run Battlefield 4 at 80 fps, hardware isn't an issue) I've looked it up and it seems that I need to disable vsync, but I don't know how. I've tried multiple games. I've gotten into the nvidia control panel and disabled it there, but that hasn't changed anything. Just so it's out there, I am playing games from an ISO. Any help would be greatly appreciated Smile Thanks.
Reply

Sponsored links

#2
Quote:I can run Battlefield 4 at 80 fps, hardware isn't an issue
nope. that's not how it works.
pcsx2 can be 10 times more demanding than battlefield 4, especially when it comes to those games you listed.

In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(10-16-2014, 09:06 AM)jesalvein Wrote: nope. that's not how it works.
pcsx2 can be 10 times more demanding than battlefield 4, especially when it comes to those games you listed.

In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.


Using gtx 770, 16 gb ram, i7 processor 5690k, windows 8.1 64 bit
Running PCSX2 1.2.1
Custom settings are: custom ratio and window size (1920x1080), full screen, currently using directX 11 to see if it would change anything (was direct 3d before and still getting FPS drops)
Tried Ratchet and Clank, Ratchet and Clank 2 and Ratchet and Clank Size Matters, all of them had the same problem (number 2 a bit less than number 1), also all of them are .iso files.
Thanks for replying, hopefully this helps Smile
Reply
#4
which i7 processor is it a desktop or a laptop and also I would say try one of the SVN Version you can find at: http://buildbot.orphis.net/pcsx2/
Reply
#5
(10-16-2014, 09:48 AM)StriFe79 Wrote: which i7 processor is it a desktop or a laptop and also I would say try one of the SVN Version you can find at: http://buildbot.orphis.net/pcsx2/

It's a desktop PC, i7 5690k or something like that.
Reply
#6
Ise software mode and set extra rendering threads to 3 or 4.
Enable mtvu speedhack + ee cycle rate to 1.
That should help.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
(10-16-2014, 11:29 AM)jesalvein Wrote: Ise software mode and set extra rendering threads to 3 or 4.
Enable mtvu speedhack + ee cycle rate to 1.
That should help.

Thank you so much! That fixed it, game is running almost perfectly now. Textures are bugging, but I'm not sure if that's a hardware issue or the rom's issue. Anyway, I have the main issue dealt with. Again, thanks for all your help!
Reply
#8
(10-16-2014, 10:50 PM)Corvus2199 Wrote: Thank you so much! That fixed it, game is running almost perfectly now. Textures are bugging, but I'm not sure if that's a hardware issue or the rom's issue. Anyway, I have the main issue dealt with. Again, thanks for all your help!

Yeah, you made me nearly mess my pants with those specs. DAMN!
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply




Users browsing this thread: 1 Guest(s)