Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
EE at 100%
#1
Hello, been awhile since I posted here. I recently got a laptop with pretty good specs that I've been using to play DQ8 on. The basic spec is as follows:
I7 2670QM 2.20 ghz(3 ghz with turbo boost)
AMD 6990m 2gb
8 gb of ram
PCSX2 0.9.8

So I tried playing Persona 4 tonight for the first time. I initially had fps limit uncapped so the opening FMV past by at blazing speed. I turned the limiter on then started a new game. Now, for some reason, the FMV that followed after starting the game played played noticeably slower; it was choppy and almost in slow motion, running at about 30 fps.

As the thread title says, I noticed that the EE percentage was abnormally high. First thing I did in an attempt to troubleshoot was to turn off all speedhacks but that did nothing. I turned on Intel Turbo Boost monitor to check if it wasn't running at a lower clock speed and that wasn't it, either. If anything, the CPU usage is only ~15% with pcsx2, even with affinity set to use only two cores.

The oddest thing was that this behavior became the norm for all of my games. Games that I played fine like FFXII, DQ8, Persona 3, and Tales of the Abyss all run with EE at 100%.
Windows 7 Professional x64
C2D E8500 @4.0ghz
Gigabyte EP45-UD3P
EVGA GTX 460 768mb
OCZ DDR2 4 gb 1066 ram
Antec Earthwatts 500w PSU
Reply

Sponsored links

#2
Apparently your CPU single-threaded performance is not powerful enough to emulate the EE thread. You should download the latest subversion and use the MTVU hack to offload the work of EE thread to another CPU core.

You can find the subversions at PCSX2 homepage -> Download -> SVN.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#3
Sounds like you need to set your Wondows' Power Plan to "High Performance".

Nice laptop. Smile
Reply
#4
(06-14-2012, 12:59 PM)Livy Wrote: Apparently your CPU single-threaded performance is not powerful enough to emulate the EE thread. You should download the latest subversion and use the MTVU hack to offload the work of EE thread to another CPU core.

You can find the subversions at PCSX2 homepage -> Download -> SVN.

Isn't it odd that it was working fine for months until now, though? I'll try the latest SVN, though I'm just being cautious just in case this problem creeps up again randomly like it did.

(06-14-2012, 08:00 PM)Rezard Wrote: Sounds like you need to set your Wondows' Power Plan to "High Performance".

Nice laptop. Smile

It's set to High Performance.
Windows 7 Professional x64
C2D E8500 @4.0ghz
Gigabyte EP45-UD3P
EVGA GTX 460 768mb
OCZ DDR2 4 gb 1066 ram
Antec Earthwatts 500w PSU
Reply
#5
Have you tried turning the limiter off again to see if they blaze by like before?
Reply
#6
lol, its probably the radeon not increasing its clocks
Reply
#7
Tried the latest SVN with MTVU hack on. No changes, unfortunately.

(06-15-2012, 09:03 AM)Mr.Bonkers Wrote: Have you tried turning the limiter off again to see if they blaze by like before?
Yes, I did try it. It still crawls during FMVs and I can barely get 60 fps in game.

(06-15-2012, 09:27 AM)Squall Leonhart Wrote: lol, its probably the radeon not increasing its clocks
lol, no. GPU-Z and AMD Overdrive both reports that the core is running at 715 MHz and memory clock is at 900 MHz, both of which are running according to specs. And I thought GS is tied to GPU while EEs were tied to CPU?
Windows 7 Professional x64
C2D E8500 @4.0ghz
Gigabyte EP45-UD3P
EVGA GTX 460 768mb
OCZ DDR2 4 gb 1066 ram
Antec Earthwatts 500w PSU
Reply
#8
what is your CPU temperature while the emulator is running? to me it sounds like your cpu is slowing itself down.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
maybe the CPU are too hot?
Reply
#10
My CPU is known to run a little hot for unknown reasons, but with PCSX2 it never goes above 60c. I've monitored the CPU speed using Intel Turbo Boost monitor and it doesn't go below 2.2 ghz, which is how it's always been in the past with other games, too. Just to reiterate, the CPU usage is around ~15%.

I played DQ8 with pretty high settings only a few weeks ago at 60 fps with the same setup. This problem started occurring with Persona 4's first FMV, but intro FMV played fine the first time, which is the most puzzling aspect to me. Why would it suddenly slowdown?
Windows 7 Professional x64
C2D E8500 @4.0ghz
Gigabyte EP45-UD3P
EVGA GTX 460 768mb
OCZ DDR2 4 gb 1066 ram
Antec Earthwatts 500w PSU
Reply




Users browsing this thread: 1 Guest(s)