Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Emu crash
#1
Hi everyone
I'm having a major problem getting the emu to run at all. As far as I can tell I can't get into the game yet, it crashes after the bios part, where it shows the Playstation 2 in white, at that moment the screen kinda gets stretched vertically and it crashes. The error I'm getting is Microsoft C++ Visual Runtime error stating : This application has requested the Runtime to terminate it in an unusual way.


I am running Windows 7 64bit, have the runtime installed, tried both the x86 and the 64x version. My specs:
Intel i7 920
6GB RAM
ATI HD5800

Sponsored links

#2
I didn't know that PCSX2 has a separate x86 and x64 version.

Are you using a really old beta?
[Image: 813647.png]
+ geforce GT 440 @ Win7 64bit
#3
What game, pcsx2 version and settings?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
#4
Any game basically. I've tried the 0.9.6 beta as well as the Wx version. As for settings pretty much every possible combination for graphics, sound pad and CD plugins.
#5
(10-12-2009, 02:08 AM)ellachen0417 Wrote: I didn't know that PCSX2 has a separate x86 and x64 version.

Are you using a really old beta?

He's talking about the VC runtimes. There are both x86 and x64 versions.

Also, I seem to remember having this problem, as well. I believe I fixed it by reinstalling my graphics card drivers and updating DirectX.
http://www.twitch.tv/krazytrumpeter05
Want to stream your games? Let me know and I can help you get set up with Open Broadcaster Software.
#6
Not sure what could be the problem, I have the newest driver installed, the newest version of DirectX as well but same thing.

Here's the log btw if it helps:

Thread Log: Executing destructor for Redirect_Stdout
STDOUT Redirection Init failed: GetStdHandle returned NULL.


Thread Log: Executing destructor for Redirect_Stdout
STDOUT Redirection Init failed: GetStdHandle returned NULL.




PCSX2 0.9.7.r1982 (modded) - compiled on Oct 8 2009
Savestate version: 8b410003
x86Init:
CPU vendor name = GenuineIntel
FamilyID = 5
x86Family = Intel® Core™ i7 CPU 920 @ 2.67GHz
CPU speed = 3.201 ghz
Cores = 8 physical [8 logical]
x86PType = Standard OEM
x86Flags = bfebfbff 0098e3bd
x86EFlags = 28000000

Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2

Initializing PS2 virtual machine...
Allocating memory for recompilers...
Loading plugins...
Binding GS : C:\Program Files (x86)\pcsx2\plugins\GSdx-SSE4.dll
Binding PAD : C:\Program Files (x86)\pcsx2\plugins\LilyPad.dll
Binding SPU2 : C:\Program Files (x86)\pcsx2\plugins\SPU2-X.dll
Binding CDVD : C:\Program Files (x86)\pcsx2\plugins\CDVDiso.dll
Binding USB : C:\Program Files (x86)\pcsx2\plugins\USBnull.dll
Binding FW : C:\Program Files (x86)\pcsx2\plugins\FWnull.dll
Binding DEV9 : C:\Program Files (x86)\pcsx2\plugins\DEV9null.dll
Plugins loaded successfully.

Thread Log: Executing destructor for PersistentThread
Initializing plugins...
Init GS
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Opening CDVD
detected blocksize = 2048
isoOpen: D:\Games\star ocean.iso ok
offset = 0
blockofs = 24
blocksize = 2048
blocks = 2274624
type = 2
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 1) (2274624 sectors)
Opening USB
Opening FW
Opening DEV9
Plugins opened successfully.
Bios Version 1.0
Load Bios Warning: rom1 not found (this is not an error!)
Load Bios Warning: rom2 not found (this is not an error!)
Load Bios Warning: erom not found (this is not an error!)
Framelimiter rate updated (UpdateVSyncRate): 59.94 fps
Issuing EE/iR5900-32 Recompiler Reset [mem/structure cleanup]
# Initialize memory (rev:3.17, ctm:393Mhz, cpuclk:295Mhz )
# Total accessable memory size: 32 MB (B:2:8:0)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Dec 10 1999 17:48:37
CPUID=2e20, BoardID=0, ROMGEN=2000-0117, 32M

# Loader 'rom0OhmySDSYS'Tongue2c=00200008
microVU1: Cached MicroPrograms = [001] [001]
ExecutePs2GameDisk
CDVD.KEY = 94,69,95,39,45,04,05
loadElfCRC: cdrom0:\SLUS_204.88;1
loadElfFile: cdrom0:\SLUS_204.88;1; CRC = 23A97857
Program name = cdrom0:\SLUS_204.88;1
# Restart.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Restart Done.
# LoadExec 'rom0TongueS2LOGO'Tongue2c=00200008
init rpc
OSDSND
CD Init
CD Disk Ready
DecSet Write: 53
DecSet Write: 00
# Restart.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Restart Done.
# LoadExec 'cdrom0:\SLUS_204.88;1'Tongue2c=00100008
microVU0: Cached MicroPrograms = [001] [001]
#7
Enable the Tri-Ace gamefix, I'd suggest you use the latest public beta as the version you have can be buggy and currently not supported.

http://forums.pcsx2.net/thread-3716.html
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64




Users browsing this thread: 1 Guest(s)