Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Emulator runs slow no matter what (Thread contains images)
#1
Tongue 
For the life of me I cannot get PCSX2 to run any game at reasonable speed, have read numerous posts around these forums and others and no matter what I try game has terribly low FPS.

Main PC specs:

Windows 8 Pro x64 (tested also on Windows 7 x64)
ASUS M5A97 Pro
AMD FX-8120 Black Edition@ 3.9Ghz (8 cores 8 threads)
8Gb DDR3 1600Mhz Patriot Viper
128Gb Samsung 830 SSD
2GB ATI Sapphire HD 6950 (870/1300)

I get 60fps in menus and videos but in game drops down usually anywhere to 12-17fps. Obviously there is not a lot of intense rendering going on in the menus but surely my system can handle PS2 emulation.

I thought maybe because I was running off the game discs it might be slow so I backed a few up to ISO and ran of the SSD and it made barely no difference. The games run fine on my PS2 so safe to say that the discs are not in too bad condition.

Games tried:

Fifa 2008
Need for Speed Most Wanted
Simpsons Hit and run
Tekken 5
Tom Clancy's Splinter Cell - Chaos Theory
WWE Smackdown vs. Raw

I have more but am not going to dig them out if I cannot play them on my PC.

PCSX2 settings I am using:

[Image: 14894718.png]

[Image: 87877778.png]

[Image: 51375391.png]

[Image: 89470667.png]

[Image: 86963551.png]

[Image: 57287031.png]

[Image: 48049581.png]

[Image: 93974032.png]

[Image: 45891630.png]

[Image: 62643581.png]

[Image: 84141002.png]


Whilst I was writing this post I continued to change some settings and now I get about 30-40fps but it still feel like 10fps, it runs slow and laggy and the sound is crackly.

Am I am expecting too much from this emulator or is it actually possible to have 60fps running smooth? What can I change to make this happen?

Please dont link to the guides I have been other numerous different ones and still no luck.

Thanks in advance Smile
Reply

Sponsored links

#2
your CPU is the culprit (see that EE% at the top of the window ?).
unfortunately, the games you're trying are quite demanding, and your CPU has been proved to perform badly under pcsx2 (and gaming in general).
not much you can do appart from experimenting with speedhacks, sry .... Sad
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(12-23-2012, 08:46 PM)jesalvein Wrote: your CPU is the culprit (see that EE% at the top of the window ?).
unfortunately, the games you're trying are quite demanding, and your CPU has been proved to perform badly under pcsx2 (and gaming in general).
not much you can do appart from experimenting with speedhacks, sry .... Sad

It can handle all modern games with ease such as Far Cry 3.

But I had a feeling it was going to come down to the processor either because of it been ATI or not as effective as some of the others, 8 cores stands for nothing in terms of gaming, only good for video encoding.

Why cannot my GPU take the load of the CPU, is this down to the way the emulation works?

And thanks for the fast reply Wink
Reply
#4
(12-23-2012, 08:51 PM)Blobby Wrote: It can handle all modern games with ease such as Far Cry 3.

Far Cry 3 is a piece of cake compared to PS2 emulation...
Quote:Why cannot my GPU take the load of the CPU, is this down to the way the emulation works?

This isn't how PS2 emulation works, unfortunately.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
Anyway there is a strange thing...you have a DX11 capable GPU on a DX11 capable OS, anyway the GS plugin show Direct3D10 instead of Direct3D11.

There are cases where DX11 plugin improves the performances of CPU-limited games (as GT4) in respect to DX9 (and so maybe also in respect to DX10). Are you using an old GS plugin? Try with the newer ones. Moreover you have an AVX capable CPU, so you should use the AVX capable GS plugin (even if it's more important when you're using software mode).

Oh, and last but not least, be sure that you are using cores of different modules to have the highest performances (check task manager: core 0 and 1 are a module, 2 and 3 are another module and so one).
FX-6300@4.4GHz | Noctua NH-U9B SE2| Asrock 990FX Extreme3| Sapphire HD7850 2GB| 2*4GB AMD Performance Memory 1600MHz Cas8| Intel X-18M 80GB G1| Seagate Barracuda 7200.12 500GB| WD Caviar Green 2TB| Samsung S24B300 (LG Flatron L1720P)| Antec Three Hundred| Gigabyte GT-E8000| OCZ StealthXStream 2 600W| Gigabyte GM-M6800
Reply
#6
I have a similar problem, infact Blobby gave me link to this thread but mine is slightly different and confuses me. I did a screen recording of what happens. http://forums.pcsx2.net/Thread-Big-FPS-Drop-with-video
Reply
#7
WoW... SHOCKS me Mellow to See pcsx2 crawling with such a cpu !!
an FX-8xxx cpu series @almost 4.0 ghz no less GlareBlinkHuh !!

Not to mention your GPU card !!

Hey, poor fella blob... i noticed you use an old pcsx2 build !!!

Why not give pcsx2 1.1.0 r5483 an try = latest SVN build ?

Iam sure you'll gain some speed by using an SVN build ..

Have experienced it myself while i wos troubleshooting an issue in a certain game...

I used one of the oldest builds to reproduce an error and i noticed the speed dropped quite a bit compared to the latest beta svn revision ...

i realy reccommend you test and try several builds / plugins ...


cherriepoppers,
HOBO ASUS M3A32-MVP Deluxe
CPU AMD PII x4 965BE@4.1GHZ stable
COOLER Antec HO2 920 (Water/air)
RAM 4x2 giggles Corsair Vengeance DDR2 800mhz
GPU VTX HD6870 / 1 Gigabyte GDDR5
OS Windows 7 x64 (Ultimate) / SP1
Reply
#8
(12-23-2012, 09:40 PM)||dav1de|| Wrote: Anyway there is a strange thing...you have a DX11 capable GPU on a DX11 capable OS, anyway the GS plugin show Direct3D10 instead of Direct3D11.

.....

I did have one plugin on D3D11 at somepoint but made no difference. Just gonna have keep trying different plugins I think and will look for the AVX one.

(12-23-2012, 09:42 PM)frasmacon Wrote: I have a similar problem, infact Blobby gave me link to this thread but mine is slightly different and confuses me. I did a screen recording of what happens. http://forums.pcsx2.net/Thread-Big-FPS-Drop-with-video

Hi again Tongue

Let me know if you make any progress with your speed issues and I will do the same if I find anything.

(12-23-2012, 09:52 PM)Metagondria Wrote: WoW... SHOCKS me Mellow to See pcsx2 crawling with such a cpu !!
an FX-8xxx cpu series @almost 4.0 ghz no less GlareBlinkHuh !!

Not to mention your GPU card !!

Hey, poor fella blob... i noticed you use an old pcsx2 build !!!

Why not give pcsx2 1.1.0 r5483 an try = latest SVN build ?

Iam sure you'll gain some speed by using an SVN build ..

Have experienced it myself while i wos troubleshooting an issue in a certain game...

I used one of the oldest builds to reproduce an error and i noticed the speed dropped quite a bit compared to the latest beta svn revision ...

i realy reccommend you test and try several builds / plugins ...


cherriepoppers,

This emulator is feeling like a blob haha Wacko

I am using the latest PCSX2 as found on the homepage, but I think I am going to delete the folder and clean it all and try some from the SVN like you say. Maybe I can strike gold with a different build or something *fingers crossed*


Thanks for the replies everyone Smile
Reply
#9
NFS MW works well on my FX-6100@3.3Ghz (no turbo) with the latest SVN EE Cyclerate and Vu Cycle Stealing to 2 (other speedhacks active), so it should work also on your system. I don't have the other games so I can't try...
FX-6300@4.4GHz | Noctua NH-U9B SE2| Asrock 990FX Extreme3| Sapphire HD7850 2GB| 2*4GB AMD Performance Memory 1600MHz Cas8| Intel X-18M 80GB G1| Seagate Barracuda 7200.12 500GB| WD Caviar Green 2TB| Samsung S24B300 (LG Flatron L1720P)| Antec Three Hundred| Gigabyte GT-E8000| OCZ StealthXStream 2 600W| Gigabyte GM-M6800
Reply
#10
(12-23-2012, 11:04 PM)||dav1de|| Wrote: NFS MW works well on my FX-6100@3.3Ghz (no turbo) with the latest SVN EE Cyclerate and Vu Cycle Stealing to 2 (other speedhacks active), so it should work also on your system. I don't have the other games so I can't try...

NFS MW for pc runs even better on my phenomII N830 @800 Mhz (energy safe mode) without any hack. sorry. Cool

that bulldozer is driving slow. ;P that tip with task manager is the most valid tho. Wink
Reply




Users browsing this thread: 2 Guest(s)