Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Epic slow fps
#1
I really don't know why I'm getting such low framerates. I see youtube videos of people getting much higher speed on games with much worse computers than I.

I'm running:
AMD Phenom II x4 quad core at 4ghz
ATI Radeon HD 6970 at 900mhz
4gb ram

I've tried 3 games. God of War, Samurai Warriors, and Starwars Battlefront 2.
God of War I keep retrying the intro and when the enemies come on screen I get down to 45fps all through fighting them.
Samurai Warriors actually runs reliably at full speed the whole game.
Battlefront 2 I got a surprising THREE fps while playing it.

I've tried changing lots of settings. Tried looking through forums and videos. I don't get it. Is it cause it's an ATI card and not Nvidia? Is it cause my card is too new and not supported well? I can play through Crysis just fine on maximum graphics yet I get 3fps when playing Battlefront 2.
I will keep testing but I just want input as to why I'm having slowdowns.
Reply

Sponsored links

#2
No one cares if you can play Crysis. It means nothing when it comes to PCSX2. Now, post your detailed PCSX2 and plugin settings.
Reply
#3
I've tried just about every combination from Direct3D9 hardware/software to Direct3D11 hardware/software. Tried all the speedhacks. Tried frameskipping. Tried native resolution.

Basically I'll try about anything for more speed.
And when I'm playing God of War my cpu is at 40% load and my GPU is at 10% load. How can I make it take advantage of my hardware?
Reply
#4
That is odd. You system seems to be doing no better than my laptop. Maybe you should do a little system maintenance (i.e. drivers, directX). Other than that, try this:

God of War: Enable the [Recommended] Speedhacks, then try increasing the EE Cyclerate slider little by little to increase the speed.

Star Wars Battlefront 2: You will need to use the GSdx software renderer for any kind of real FPS. Using Speedhacks, I get a very playable framerate on a Core 2 Duo at 2.8Ghz.

BTW - If you want PCSX2 to take full 100% use of your hardware with every game (a.k.a be perfect), you'll have to download the source code and find a way to fix all of the emulators imperfections yourself. Wink
Reply
#5
(01-30-2011, 05:20 AM)Rezard Wrote: That is odd. You system seems to be doing no better than my laptop. Maybe you should do a little system maintenance (i.e. drivers, directX). Other than that, try this:

God of War: Enable the [Recommended] Speedhacks, then try increasing the EE Cyclerate slider little by little to increase the speed.

Star Wars Battlefront 2: You will need to use the GSdx software renderer for any kind of real FPS. Using Speedhacks, I get a very playable framerate on a Core 2 Duo at 2.8Ghz.

BTW - If you want PCSX2 to take full 100% use of your hardware with every game (a.k.a be perfect), you'll have to download the source code and find a way to fix all of the emulators imperfections yourself. Wink

It's a fresh install of Windows 7. Nothing to be improved upon in terms of cleaning up. Tried recommended hacks.

I'm starting to blame the ATI driver for my card. I'm using the GSDX plugin or whatever but it uses 0% gpu most of the time. I'll do some testing.
Reply
#6
Update DX9 and graphic driver yet? No one can help you if you don't' post the configuration settings.
Reply
#7
(01-30-2011, 07:33 AM)tuanming Wrote: Update DX9 and graphic driver yet? No one can help you if you don't' post the configuration settings.
I just have all the emulation settings to Default except enabling the RECOMMENDED speedhacks. And my graphics plugin is dx9hardware cause it runs faster than dx11. It's the gsdx plugin. Only other nondefault thing is I set the resolution to Native to see if it would go faster.

Yes I updated DirectX and my graphics driver.

Reply




Users browsing this thread: 1 Guest(s)