Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Erratic frame-drop intervals
#1
Hello, everyone. Did a lot of extensive searching and I couldn't find a solution. I finally decided to make an account and ask you folks here.

PCSX2 1.4.0-20160105132032 (Also tried 1.5-dev with the 2013 VS, but not as extensive)

Win 7 64-bit
16gb Ram
i7-6700K CPU @ 4.00GHz (39c on load)
Nvidia GTX 1060 (52c)

The settings I found this to happen lest likely in is with the SSE2 GPU plugin instead of all the others (SS(S)E3/4, AVX(2))
D3D11 HW <=> OpenGL
Interlacing Auto

3x native
=====
SPU2-X WinXP-VS2013
=====
All speed-hacks enabled except Enable fast CDVD
EE 1
VU 0

My problem with PCSX2, at least with Final Fantasy XII (SLUS-20963), is that the game will slowdown (just for a little bit) during load times or a cut-scene. This only happens in hardware mode. I've tried a number of things including changing GPU and SPU plugins and combinations and to no avail (this includes speedhacks and the widescreen hack/cheat).

I'm sure this little stutter is normal and the game is very much playable, but I'm trying to get this to run as smooth as possible. I think my problem is that I am using a skylake CPU as I've run across some threads where Skylake and PCSX2 have some problems or lack of mTVU support (or something similar). Most of the problem (as indicated by sound distortion by that of frameskipping) happens when loading a new area, within a cut-scene, and ocassionally in combat (very beinning of the game and 3/4ths in).

Any input would be appreciated. Also worth noting that the IZJS version ran a bit smoother (very small decrease in less stutter), but had more notable graphical issues with the floor and shadows.
Reply

Sponsored links

#2
Just did some testing on Windows 10 and to no avail. The problem is about the same.
Reply
#3
are you playing from DVD or ISO?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#4
(09-30-2016, 05:46 PM)refraction Wrote: are you playing from DVD or ISO?

ISO.
Reply
#5
DO this




GS= sse4

Video settings windows:
  custom 800 x 600
  16:9 aspect ratio

video settings plugin:
  Adapter= your graphics card
  render= DX11
  interlacing= none

  resolution = 2x native
  texture filter bilinear ps2
  anisotropic filter 4x
  crc hack partial open gl recomended
  enable HW hacks = UNCHECK BOX!

 video settings plugin shader configuration:

TV shaders = none
FXAA = enable


don't know if it helps but i changed the audio to config to linear as well.



i quick saved right next to the first save crystal you can run up the stairs and trigger the cutscene it should run fine now.
Reply
#6
(09-30-2016, 10:06 PM)binarymushroom Wrote: DO this




GS= sse4

Video settings windows:
  custom 800 x 600
  16:9 aspect ratio

video settings plugin:
  Adapter= your graphics card
  render= DX11
  interlacing= none

  resolution = 2x native
  texture filter bilinear ps2
  anisotropic filter 4x
  crc hack partial open gl recomended
  enable HW hacks = UNCHECK BOX!

 video settings plugin shader configuration:

TV shaders = none
FXAA = enable


don't know if it helps but i changed the audio to config to linear as well.



i quick saved right next to the first save crystal you can run up the stairs and trigger the cutscene it should run fine now.

Thanks for the input. Aside lowering the resolution that low, I've tried this set-up before. The audio was pretty bad (especially when hitting the coyote-like enmies in Giza Plains).
Reply
#7
Quick update.
I decided to grab an ISO copy online since my disc may have been scratched from ye old original PS2 as well as stored it in my 7200rpm HDD.
I also changed the sound Xaudio2 to DirectSound (still at option 3).
Lastly, I changed back to d3D11 and left interlacing on none.

At first I noticed less hiccups, but sure enough more started to appear. It's less apparent though, so i do believe I'm on the right track. I did change a lot of things in the environment, but my thoughts go to my and the new ISO copy.
Reply
#8
Well you can start by deleting that ISO you downloaded, that is illegal and we do not tolerate it here.

Make an ISO of your disc with ImgBurn and that will tell you if your game is alright.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
Alright. I already made my own ISO a few weeks ago with my copy. But I used Alcohol 120%. Now with the ImgBurn copy I still retain the same problem.
Does PCSX2 run better by disabling Aero or running it in compatibility mode for XP or Vista?
Reply
#10
Not really no. The only reason your computer should stutter badly when loading is if your power options on windows stop your harddisk too often, or you have a Western Digital Green drive or you have antivirus or something slowing the system down, or your harddisk is just super heavily fragmented Tongue
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)