Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
"Error Writing Config File in LILIPAD svn 0.10.0 r2930 "
#1
Need some help guys.

I am having a problem with LILIPAD svn 0.10.0 r2930 every time i configured the buttons on my pad.

It's about Error Writing Config File.

I already run it as administrator, coz thats what the error message told me to do. But still nothing's happening.

**ONE MORE THING**

When im using the 0.9.9 version, i couldnt change the default buttons setup on there. Coz everytime i used that, there's already a set of buttons configured for my joystick, but on that config, analog directions were not included.

I appreciate the help guys.
Reply

Sponsored links

#2
If it's installed in C:\Program Files or Documents folder you have the causes.

About the last, it's OK to have config files and others in the Documents folder, just do NOT install anything there or run application from inside it.
Imagination is where we are truly real
Reply
#3
(08-20-2010, 07:11 AM)nosisab Ken Keleh Wrote: If it's installed in C:\Program Files or Documents folder you have the causes.

About the last, it's OK to have config files and others in the Documents folder, just do NOT install anything there or run application from inside it.

Just to check if i understand it correctly.

Yes it's installed in C:\program files. So what i did is cut it from there to my desktop, then change the path as i start the emulator.

Still the same. Then i tried and uncheck the read-only options but still the same.

   

Now all of them are in my desktop. Still the same thing happens. Should i move all of them again to another folder, or just put all of those in one?

"C:\Users\Administrator\Desktop\PCSX2 0.9.7\Plugins" path for my plugins
"C:\Users\Administrator\Desktop\PCSX2 0.9.7\BIOS Files" for my bios...

after moving it from c:\program...

For my 2nd concern.. i provided a picture so you could see whats happening. It doesnt allow me to change the setting on it.

   

Really appreciate the help
Reply
#4
Make some non proprietary directory, lets say C:\Games and be used to install games there, it will spare you from many headaches...

Notice all folders you tried are "Special folders" for windows? The point is "the application running from those folders isn't the user" that's the reason the OS denying them from performing certain tasks not directly related to the user. It's not enough the application inherits the user privileges (do you remember how you need to explicitly allow/negate access for applications on the Firewall? it's done in the application level, not at the user level, the principle is similar).

In time, if you move the PCSX2 folder around you need to make sure all the ini files are deleted to avoid paths problems or previous access rights issues.

Repeating: Avoid All and Any specially protected or proprietary directory and you should be fine. Doing so you'll not need to run as The Administrator anymore and Should Never need to do it for playing games.

PS: I can't imagine worst thing than running Windows directly logged as The Administrator... for anything that not a complete system maintenance...
Imagination is where we are truly real
Reply
#5
I dont know what happen, but it seems to be working now.

First i restarted my system.

Then try and configure all my buttons again for my plugins.

Then, just to find out, the analog button is not working this time. ( It's working before the restart )

I reinstall driver again ( did'nt do restart ) then tried it with the plugins, nothing happens.

Restart it again, check the diagnostics, and all is working on the joystick side.

I did'nt change anything anymore. After everything, it just works out for me. And i dont know what fixed the problem.

Maybe restarting, or re-installing. But maybe somewhere there.

Anyways, thanks for the help.
Reply




Users browsing this thread: 1 Guest(s)