Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Experiencing issues with slow gameplay
#1
I recently started PS2 emulation with the PCSX2 (v1.2.1) emulator. So far I have tried Ratchet and Clank: Going Commando and Kingdom Hearts. Both games run quite slowly despite a (probably false) reading of ~60 FPS. What kinds of alterations should I make to the emulator settings to improve performance? Stability doesn't seem to be an issue (games have not crashed) and I believe my system is capable of handling the emulator.
I was able to improve textures by running Direct3D11 software for the graphics card plugin renderer. While this improved the appearance of the games, they still seem to run slowly. What configuration(s) may help improve framerate or speed of gameplay?

My computer stats:
OS: Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 8098 MB (8 GB) DDR3
CPU name = Intel® Core™ i7-2670QM CPU @ 2.20GHz (@ 2.60 GHz Turbo boost)
CPU speed = 2.194 ghz (8 logical threads)
GPU Info = NVIDIA GeForce GT 525M (1 GB dedicate DDR5 RAM)
Screen Resolution = 1366 x768 (alternatively have a 1080 26 in monitor)

If more information is needed please let me know. Any assistance is greatly appreciated!
Reply

Sponsored links

#2
It would be good to see your emulation settings as well as gsdx plugin settings.

Probably you have maxed all speedhacks and this is causing this issue.

If you don't use speedhacks, how are gs% and EE% readings in the titlebar in windowed mode during slowdowns?
Reply
#3
(08-03-2014, 09:12 PM)willkuer Wrote: It would be good to see your emulation settings as well as gsdx plugin settings.

Probably you have maxed all speedhacks and this is causing this issue.

If you don't use speedhacks, how are gs% and EE% readings in the titlebar in windowed mode during slowdowns?

Emulator Settings:
-EE/IOP = EmotionEngine: Recompiler, IOP: Recompiler, EE/FPU Advanced Recompiler Options: Chop/Zero, and Clamping Mode: Normal
-VUs = VU0: microVU Recompiler, VU1: microVU Recompiler, VU0/VU1 Advanced Recompiler Options: Chop/Zero, Clamping Mode: Normal
-GS = Base Framerate Adjust: 100%, Slow Motion Adjust: 50%, Turbo Adjust 200%. Frame Skipping: Disabled
-GS Window = Aspect Ratio: Standard (4:3) closest to native resolution of game, window size: 640x480, zoom 100
-Speedhacks = Enabled, EE Cyclerate: 2, VU Cycle Stealing: 1 Other hacks that are enabled: INTC Spin Detection, Wait Loop Detection, mVU Flag Hack, and MTVU (Multi-Trheaded microVU1).
-Game Fixes = None enabled

Graphics Settings (currently arranged to achieve best performance and correct texturing/stability):
-Adapter = Intel HD Graphics 3000
-Renderer = Direct3D10 (Software)
-Interlacing = Auto
-Enabled FXAA
-Enabled FX Shader
-Endabled Edge Anti-Aliasing (AA1)

If certain settings have been omitted from this list assume they are disabled or not currently enabled.
Reply
#4
Also EE runs around 50-60% almost constantly and GS runs around 88-100%. Forgot to add those to my first reply.
Reply




Users browsing this thread: 1 Guest(s)