Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FF X & X-2
#1
So I've been Lurking on this forum for the past 48 hours reading the forum threads about the Finale Fantasy games.

I didn't really want to create another one of these threads because I'm sure you get a load of them.

However lke the others I am having problems running the FF X series

I am using 1.0.0 PCSX, and I think the latest plug-ins for graphics, lilypad and sound.

my laptop is 2 years old I know, but the game came out in 2001 so It shouldn't be a spec problem.

When I play the game it's very VERY laggy, the sound was partly to blame but i got that sorted by changing the settings, the graphics though are still very sluggish.

If i was hopping, could you chaps give me a hand at sorting out my problems? make sure i'm doing this right? sadly I'm not very tech savy.


[Image: yify.jpg]

[Image: 2rw2.jpg]


[Image: 769j.jpg]

Uploaded with ImageShack.us
[Image: 5kcp.jpg]
Reply

Sponsored links

#2
What are your specs??

Try running DXDIAG, to find out if you don't know.
[Image: xtqkcQD.png]
Reply
#3
please post the emulog.txt.
Quote:my laptop is 2 years old I know, but the game came out in 2001 so It shouldn't be a spec problem.
care to explain us why ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#4
This is from the DXDIAG

[Image: utmt.jpg]

[Image: 03en.jpg]
Reply
#5
(12-18-2013, 09:57 AM)jesalvein Wrote: care to explain us why ?

I think we can let him off, he self-admittedly is not tech savvy Tongue

Ok, your CPU is more than adequate, however could you show us the next tab (Display)? As you may have integrated graphics.
[Image: xtqkcQD.png]
Reply
#6
Sorry, I edited the post above with the information you required.

I Assumed that no matter if it's a PC or a PS2 I thought being made in 2001 a laptop made in 2011 would be fine. sorry lads.
Reply
#7
Alright well your specs are more than enough.

So first I would disable the sprite and WildArms HW hacks you have on as they don't do anything for FFX I believe.

Also check that your power options are set to "high performance".

Try setting the EE cyclerate speedhack to the middle of the bar.
[Image: xtqkcQD.png]
Reply
#8
(12-18-2013, 10:06 AM)Fezzer Wrote: Alright well your specs are more than enough.

So first I would disable the sprite and WildArmcs HW hacks you have on as they don't do anything for FFX I believe.

Also check that your power options are set to "high performance".

Try setting the EE cyclerate speedhack to the middle of the bar.


What tab are "high performance" options under? I'll make the other changes now however.
Reply
#9
(12-18-2013, 10:05 AM)jlgx50 Wrote: I Assumed that no matter if it's a PC or a PS2 I thought being made in 2001 a laptop made in 2011 would be fine. sorry lads.

Oh no Pcsx2 is an emulator and so things work differently to a direct system port. Ported PC games natively run off PC hardware however an emulator has to do tons more work to "interpret" ps2 processing to be done on your PC hardware.

(12-18-2013, 10:07 AM)jlgx50 Wrote: What tab are "high performance" options under? I'll make the other hanges now however.

Your laptop should have power options under a battery icon in the bottom-right of your desktop?
[Image: xtqkcQD.png]
Reply
#10
(12-18-2013, 10:08 AM)Fezzer Wrote: Oh no Pcsx2 is an emulator and so things work differently to a direct system port. Ported PC games natively run off PC hardware however an emulator has to do tons more work to "interpret" ps2 processing to be done on your PC hardware.


Your laptop should have power options under a battery icon in the bottom-right of your desktop?

Ok I set the laptop to 'high performance, it was on balanced, though i didn't realise that could have an effect when it's plugged into a power point.

Edit 1 :

Nope, just tried an the game is still laggy, but the sound plays fine, thought if i edit the sound setting it'll go back to choppy sound.
Reply




Users browsing this thread: 1 Guest(s)