Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FF (X&XII) unplayably slow
#1
It seems i can't manage to get things working. I'm trying to play Final Fantasy (tried both X and XII) on 0.9.7 r3113, but i have serious problems in playing.
Sequences play smooth, but slowly, almost like in slow motion. This can be felt more on audio than video.
In gameplay of FFX, game goes really too slow to play, and irregularly speeds up/slows down even setting on the frame limiter.
I tried both the audio plugins given in the default pack: SPU2-X gives the mentioned problem, ZeroSPU2 instead makes the audio do strange noises. I tried many possible configurations that could slow down the emulation, in both plugins.
Because it could also not be an audio problem, i also tried setting the video plugin GSdx 3068 (SSE2) on the minimum, but nothing relevant changes.
Sequences in another game, .Hack//Infection, correctly plays.

These are my specs:
Intel Core 2 Quad Q6600 @2.40Ghz
2GB RAM
Win. XP Pro SP2
nVidia GeForce 9800GTX/GTX+

If you need more infos please ask.
Reply

Sponsored links

#2
Hmmm... I can't tell what's wrong. FFX is like perfect for me with .9.7 r3113. I don't feel I do anything special to make it this way. The default plugins (GSdx10 SSE4.1 hardware, SPU2-X), [Recommended] speedhacks and the obvious gamefix.

Maybe you could post some screenshots of your settings and such.
Reply
#3
Your CPU is clocked a bit low at 2.4Ghz. The game will need speedhacks to get fast enough most of the time.
Try setting the EE cycle rate to 1.5x and the VU cycle steal hack to the first step. Also enable the hack marked
as "recommended".
Reply
#4
(07-17-2010, 12:28 PM)rama Wrote: Your CPU is clocked a bit low at 2.4Ghz. The game will need speedhacks to get fast enough most of the time.
Try setting the EE cycle rate to 1.5x and the VU cycle steal hack to the first step. Also enable the hack marked
as "recommended".
Done all of that with no result.

(07-17-2010, 11:00 AM)Rezard Wrote: Hmmm... I can't tell what's wrong. FFX is like perfect for me with .9.7 r3113. I don't feel I do anything special to make it this way. The default plugins (GSdx10 SSE4.1 hardware, SPU2-X), [Recommended] speedhacks and the obvious gamefix.

Maybe you could post some screenshots of your settings and such.
By default i rember having SSE2 set. Now i switched to SSE3 (i don't support SSE4) with very little improvements, but during gameplay it always stays around 33 FPS, so that's unplayable. I did some screen of the settings, they're in the attachments.

Thanks to both of you for helping anyway. Wink


Attached Files Thumbnail(s)
               
Reply
#5
The CPU is a bit slow but should run those games full speed most of times with little troubles with those speedhacks. But I notice the sound may be your problem. Try returning the sets to xaudio2, interpolation linear (your ears will thanks), actually you can try even the 5.1 7.1 config if you do have the speakers. The problem I can't be sure since I don't use the integrated sound and do have a dedicated and old Audigy, so I don't really know how it impacts the emulator (But I know the integrated sound is faulty to games like Oblivion and Fallout 3 but more because an engine's bug than any other thing).

PS: I read somewhere in the forum the SPUX-2 was broken and Air provided a fix, I didn't gave more attention because didn't have the problem but I advise seeking for information on the issue and it's workaround.

Still some parts are really hard mainly on FF12, Rabanastre is a good example, most parts flows full speed without any hacks and x3 internal resolution with a 3.4ghz 965, but some places get the FPS as low as 40/50, that depends not only on the position as the direction the character is facing too (x2 gets the game full speed all the time), so these parts will be slow on your CPU and a few may demand choosing native resolution, but they aren't that much and may be preferable just let them go as they come. Notice you video card is better than mine (9600GT) but those points are more CPU demanding than GPU, reason the advantage from your videocard is diluted there. Another difference is nowadays I use win7 and dx10 (edit: see the next paragraph).

Another thing, FF12 may enjoy the VU cycle stealing x2, I know I played it to the end this way in my former machine with a much older PCSX2 version. That may lag in a few points but is manageable and not game breaking in these particular games (avoid that high hack if it leads to sounds desync in the cutscenes in your machine).
Imagination is where we are truly real
Reply
#6
here's a shot of my settings (I'm using an SVN rev much higher than the beta, you'll only have the TOP mVU to check off, I have 2)
    for me this produces constant 60FPS in FFX (except Demi (and others that use that animation) and Hellfire)
Reply
#7
(07-17-2010, 02:52 PM)nosisab Ken Keleh Wrote: The CPU is a bit slow but should run those games full speed most of times with little troubles with those speedhacks. But I notice the sound may be your problem. Try returning the sets to xaudio2, interpolation linear (your ears will thanks), actually you can try even the 5.1 7.1 config if you do have the speakers. The problem I can't be sure since I don't use the integrated sound and do have a dedicated and old Audigy, so I don't really know how it impacts the emulator (But I know the integrated sound is faulty to games like Oblivion and Fallout 3 but more because an engine's bug than any other thing).

PS: I read somewhere in the forum the SPUX-2 was broken and Air provided a fix, I didn't gave more attention because didn't have the problem but I advise seeking for information on the issue and it's workaround.

Still some parts are really hard mainly on FF12, Rabanastre is a good example, most parts flows full speed without any hacks and x3 internal resolution with a 3.4ghz 965, but some places get the FPS as low as 40/50, that depends not only on the position as the direction the character is facing too (x2 gets the game full speed all the time), so these parts will be slow on your CPU and a few may demand choosing native resolution, but they aren't that much and may be preferable just let them go as they come. Notice you video card is better than mine (9600GT) but those points are more CPU demanding than GPU, reason the advantage from your videocard is diluted there. Another difference is nowadays I use win7 and dx10 (edit: see the next paragraph).

Another thing, FF12 may enjoy the VU cycle stealing x2, I know I played it to the end this way in my former machine with a much older PCSX2 version. That may lag in a few points but is manageable and not game breaking in these particular games (avoid that high hack if it leads to sounds desync in the cutscenes in your machine).
Unfortunately i get this error (see attachment) when switching to XAudio2 (and i don't really get what to do; i obviously have the latest directX already).

(07-17-2010, 03:38 PM)Saiki Wrote: here's a shot of my settings (I'm using an SVN rev much higher than the beta, you'll only have the TOP mVU to check off, I have 2)
for me this produces constant 60FPS in FFX (except Demi (and others that use that animation) and Hellfire)
That brings quite no improvement i fear.


Attached Files Thumbnail(s)
   
Reply
#8
The message in the attachment may be that issue I told about, sadly I can't give more specific directions but I saw a fix exist. Anyway I don't really think that would solve the actual issue but still it would be a good enhancement.

Hope Air read the thread and comes with the links (or someone else that remember where it is).

For the moment try the VU cycle stealing in the second notch (not recommended for most cases but seems to work with those games without serious problems, specially the FF12).
Imagination is where we are truly real
Reply
#9
check native in GSdx, that'll boost speed a good deal
Reply
#10
(07-17-2010, 06:12 PM)nosisab Ken Keleh Wrote: Hope Air read the thread and comes with the links (or someone else that remember where it is).
I hope so too. In the meantime i'll try to search on my own, but ultil furter notice, any other suggestion or information is of course welcomed.

(07-17-2010, 06:18 PM)Saiki Wrote: check native in GSdx, that'll boost speed a good deal
Did that. I noticed a bit of speed up in the sequences but nothing special, and unfortunately that doesn't fix the main issue.
Reply




Users browsing this thread: 1 Guest(s)