Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FF XII performance
#1
hey there!

i'm running the ntsc version.
as soon as i enter the actual game, my fps drop to ~20. cycling through the interlacing modes i can get about 33fps (with ~35ee, ~20gs), which is, ofc, still dreadful.

my system specs:

intel e8400 @ 3ghz
8gb ddr2 ram
nvidia gt 9600
win 7 x64

PCSX2 0.9.7.r3876

currently i use directx 10 hardware mode (directx 9 was no better), with native resolution ticked. in the emulation settings everything is on the default setting, except for speed hacks where all recommended options are ticked.
i've tried lower and higher process priorities, as well as disabling sound.

any suggestions?
Reply

Sponsored links

#2
Seems like you're doing everything right, but still can't get playable fps then it's probably your GPU is to blame. Can you get full speed on FFX or FFX-2? FFXII and FFX-2 are both somewhat demanding on the GPU. See if overclocking your CPU help. If you do not want to then i suggest you upgrade the graphics card or stick with your ps2.
Reply
#3
your vd card is too weak even for native, with 3ghz dual core you should be getting at least 50 flps
Mobo: EVGA X58 SLI LE
CPU: Intel i7 920 C0 @ 4.2 Ghz 1.36v Cogage Arrow
Ram: 3x2GB OCZ Gold 1690 9-9-8-24 1.65v
GPU: MSI GTX580 Lightning @ 970/2200 1.09v+MSI GTX460 Hawk PhysX
HDD: Corsair Force GT 120, 2x F4 320GB Raid 0,F4 2TB, WD-G 1TB
PSU: Corsair HX850 80 PLUS SILVER Modular
Case: Antec 1200 EVGA Mod
Reply
#4
(04-13-2011, 07:19 PM)tuanming Wrote: Seems like you're doing everything right, but still can't get playable fps then it's probably your GPU is to blame. Can you get full speed on FFX or FFX-2? FFXII and FFX-2 are both somewhat demanding on the GPU. See if overclocking your CPU help. If you do not want to then i suggest you upgrade the graphics card or stick with your ps2.

thank you for the quick reply!
i do have ffx-2 somewhere. i'll rip it and see how it works.
i actually have two gt 9600. could i force the nvidia driver to use both (i know sli is not supported in pcsx2)?
i'll keep you posted. (;

edit: ok, i'm gonna check out the new gpu generations, too.
Reply
#5
You really should be getting better fps. I played FFXII at full speed with the same cpu(@3ghz at the time) and a 8800gt which is just slightly better than your 9600gt, I also played it at high resolution so you should be getting fullspeed on native. Try setting Clamping mode to none under the "EE/IOP" and "VUs" tabs, and change the SuperVU recompiler in the "VUs" tab. These settings speed up my game by about 15 fps. Allow 8-bit textures in gsdx also seems to add a minor speedup.
Specs:
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
Reply
#6
(04-13-2011, 07:28 PM)tarni Wrote: thank you for the quick reply!
i do have ffx-2 somewhere. i'll rip it and see how it works.
i actually have two gt 9600. could i force the nvidia driver to use both (i know sli is not supported in pcsx2)?
i'll keep you posted. (;

edit: ok, i'm gonna check out the new gpu generations, too.

Maybe you should try to use the other 9600 gt, this one might be faulty.
Reply
#7
(04-13-2011, 08:10 PM)tuanming Wrote: Maybe you should try to use the other 9600 gt, this one might be faulty.

Wild guess but based on that, try disabling SLI all together. The driver certainly doesnt have a SLI profile for pcsx2. Maybe it's caused by a conflict somewhere.. XD

(Stuff like that happened with my Crossfire setup all the time -.-)
CPU: Intel i7 2600k @ 4GHz
GPU: ASUS GTX580 @ stock
RAM: 8GB (2x4) DDR3 PC3-10600
MB: ASRock P67 Pro3
OS: Win7 Pro 64bit
Reply
#8
put ee cycle and vu cycle to 1 or 0.
Reply
#9
hey guys,

thanks for all your suggestions. it's working now! runs smoothly @ 3x scaling and most emulation options @ default.

the thing that did it was turning off SLI in the nvidia control panel (i also un- and reinstalled the nvidia drivers, although i did have the newest ones installed before). now i get ~60 fps all the time and i didn't even have to OC anything. yay

thanks again!
Reply
#10
Yeh SLi kills pcsx2 performance, it really doesnt scale well Tongue If you'd mentioned you were running dual graphics cards, we might have resolved it sooner Tongue
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)