Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FFX-2 Flicker problem with gsdx
#1
dunno if this has been answered b4, sorry if it has, but the only thing i found was a topic and it had no reply to it.

anyway, final fantasy x-2 flickers in videos and plays them around half speed (not complaining about the speed, but the flickering, and i've tested without speed hacks with no difference other than that the flickering would disappear if certain modes of interlacing are used (speed would remain the same and the videos would either look like its on some old tv or look dark.)
i've tried different revisions of gsdx :1617,1339, 890,
tried both dx 9 & 10 hardware with same problem.
also zerogs doesn't have the flickering, although it has other problems of its own.

specs:

amd phenom triple core 8450 (2,1 ghz)
ati radeon 4670
3gb of ram
windows 7

also the game itself with battles and walking around seems to work more or less fine with speed hacks, its only the movies that are causing the trouble.
Reply

Sponsored links

#2
Known issue, you need a pretty powerful machine to run the videos at full speed, and the flickering can probably be solved by using software modes and interlacing. You can switch between hardware and software in game by pressing the F9 key in GSdx (well most of the times).
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
that might just be a ATI issue, cause I'm on a 8600GT with 2.2 and not having those issues. (I use dx9 hw)
Reply
#4
software mode is pretty much impossible for me as it would go down to 0.99 fps while causing extreme pc lags before crashing pcsx2, either way if its a known issue, then atleast i know that, anyway thanks for the help, i just wish i could atleast skip the videos.
Reply
#5
If you have the same version I do you can change the patch of the game to this and activate the "misc > enable patches" menu option and the FMVs will be skip if you want:

48FE0C71.pnach (patches folder)
Code:
gametitle=FFX-2 US
comment=
//Skip Videos
//patch=0,EE,003338e0,word,24020001
//skip "decode MPEG2"
patch=0,EE,0017aaa0,word,03e00008
patch=0,EE,0017aaa4,word,00000000
patch=0,EE,0017a9e8,word,03e00008
patch=0,EE,0017a9ec,word,00000000
//ZeroGS Patch - GAME_FFXHACK
zerogs=00000080

It is weird however that software would be so slow, maybe it just went wrong try again? Tongue
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#6
edit:
patch works fine,thanks again
Reply
#7
i had the same problem before when i update to latest version of GDSx.
i am also a user of ATi Graphic card but i solve it by not choosing the frameskip options. i just choose normal...

It is would be better if i try the aboves method? (using pnach file)
Reply
#8
The pnach file would only skip the video, you're better off with software mode (F9) if you can use it.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#9
im currently using hardware mode and i didnt have the flicker problem when i choose normal (no frameskip).

By the way, thanks..
Reply
#10
Take a look at my pic, maybe making your configurations like mine it will help im not sure but everything runs perfect with the configuration i have ;P (sometimes there are lag in some areas but otherwise its good enough.)


Attached Files Thumbnail(s)
   
Reply




Users browsing this thread: 1 Guest(s)