Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FFX-2 Settings? nooby :(
#1
Hi all

First time trying PC PS2 Emulation!

Here are my PC Specs:

Vista Ultimate x64 SP2
AMD Athlon x64 3800+ (dual core)
2GB Ram
Nvidia Geforce 9800 GT

I am trying to run FFX-2 direct from my DVD drive.

When it runs, the opening Square Enix logo up til New Game/Load Game looks fine. When I select New Game and it loads the first FMV, it looks like the attached. Also sound is severly distorted. Havent sat through it to see if its ok after the opening movie but...    

Tried cycling through the Interlacing. Using 0.9.6.

GSDx 890 SSE2 - tried DX9 + 10
16:9 aspect ration (I have wide screen monitors)
D3D Internal Res 1400 x 900 (same as my screen res)

Not sure what to do next??
Reply

Sponsored links

#2
Hmm, changed the D3D Internal Res to Native and it looks "normal" but the pictire is small and dark Sad

Going to mess around some more.
Reply
#3
1 - make an iso using imgburn, for instance

2 - use software mode for fmvs (F9 key)
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#4
Will the game run better using an ISO?

I got past the FMV and gameplay is ok...except for unexpected low FPS (lots of freezing while the DVD rom spins up) and battles are very choppy indeed...running about 30 fps.

Is this normal? I mean, for my spec PC.
Reply
#5
My specs are lower than yours, and I get better results.

Definitely, dump an iso from your DVD.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
Thanks.

Ok, dumped ISO.

Interesting results.

FMV now plays normally using ISO. BUT gameplay is still crap, FPS is aweful. Sound is all laggy as well.

Definately dont think its my Gfx card, the temp isnt rising on it. My CPU cores however are being thrashed. FPS stays the same whether Im using Native or 1024x1024.

Total loss. Any more suggestions?
Reply
#7
how about trying newer version of Gsdx and Pcsx2.
C2D E6550 @ 2333 Mhz oc 3010 Mhz vcore 1.2750v | HD2600XT | P5KC | 1 + 1 GB G.Skill 6400HK 860 4.4.3.5
Reply
#8
(10-01-2009, 08:15 PM)seinfeldx Wrote: how about trying newer version of Gsdx and Pcsx2.

I think I am running the latest...

0.9.6 + 0.1.14??
Reply
#9
Try pcsx2-r1884 and Gsdx-r1650.
C2D E6550 @ 2333 Mhz oc 3010 Mhz vcore 1.2750v | HD2600XT | P5KC | 1 + 1 GB G.Skill 6400HK 860 4.4.3.5
Reply
#10
Yeah, use the latest beta, enable a few speedhacks (not all of them!) and it should work better.
You'll probably be able to run this game fine most of the time then.
Reply




Users browsing this thread: 1 Guest(s)