Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FFX Audio Problem and Video Optimising
#1
Hi everyone =-) I had a few visual issues with PCSX2 but after updating plugins and tweaking, I finally got the video working. Now I'm having a problem with sound, and tweaking isn't helping =-)

Firstly, my rig:

Intel Core 2 Extreme CPU @ 2.8GHz (factory clocked)
2x Nvidia 8800M GTX 512MB DDR3 GPUs (Does PCSX2 take advantage of SLI?)
4GB DDR2 RAM @ 667MHz (couldn't buy faster RAM for this mobo =-( )

And my config:

GSdx 872m (SSE4) 0.1.12, running with Direct3D10, no interlacing, stretched aspect ratio, Texture filtering and VSync on.

ZeroSPU2 0.4.6 with Time Scaling and Real Time mode (I've tried it without this, same issue).

Basically if I change my plugin, there's no sound whatsoever, no matter what way I configure it. So for now I stick with ZeroSPU2




The problem is that the sound either stutters or sounds choppy, and the BGM either sounds too fast, or in a small loop at a really high speed, making it sound terrible.

I was hoping someone could suggest what I'm doing wrong, and what I could do to try and resolve this. Or even just let me know it's a common problem so I don't think it's a newbie screw up (which it probably is =-))




Finally, with the GSdx 872M plugin I can find no way (through the plugin) to add AA or anything similar. I done this through the Nvidia control panel, however I prefer having it set to allow the program to do it, not the control panel. If anyone can suggest any way to do this, or any other video settings I could change to make my gameplay more enjoyable (see the above setup) please fire away! Thanks!

Sponsored links

#2
For your sound problem,have you turned on limit frames at cpu configuration? If you are using any kind of frame skipping or if you aren't getting full speed it will cause stutter.
For 'AA' in GSdx,you can change the native resolution to a custom of your choice which will give similar results to the 'AA' you know in games.ZeroGS 'AA' is actually doing just this,increasing the internal rendering resolution
[Image: newsig.jpg]
#3
Hi Bositman, thanks a lot for the reply.


I'm getting full speed pretty much all the time, so I know it's not that. I have frame limiting on, not skipping however. And thanks for the AA advice =-)
My Rig:
Intel Core i7 950 @ 3.07GHz (Stock speeds)
2x ATI Radeon HD 5870 is Crossfire (Don't know if PCSX2 uses crossfire :-P)
12GB DDR3 @ 1333MHz
Windows 7 Ultimate x64

#4
Hey there!

Although I am using the latest rvn, FFX works exactly the same as with the official release. Thus providing my own configuration. This is how I got FFX running near flawlessly:

Use GSDX in dx10 mode. Set the int res to 1024x1024. Use your graphics card settings outside of pcsx to set AF 16x + AA6x.

For sound, choose PEOPS 1.90, and enable threading mode. This way you might get some cracks in the sound somewhere, but movies, speeches, and music is 100% in sync. Set the priority of the emulator to Low, to minimize the gaps in sound. This is the best option now, to get the most authentic ps2 experience. Also note that if you are using saved states, your sound might go off after using another plugin. So if you change your sound plugin, boot the game normally and load game from mem card.

For CPU: tick all the boxes on the left side + set the framerate option to "Limit FPS".

Go to advanced settings and tick all the boxes on the down right and down left: "Denormals are zero" + "flush to zero".

If the game is less than 60fps, click the "speed" button in speedhacks menu.

Apply the above in your configuration and you should get 60fps with your rig with minimal bugs here and there, but able to play the game with better graphical quality than with ps2.

Please ask me if you have any questions!

Cheers!

P.S. Same settings for P4, Kingdom Hearts and Kingdom Hearts II. FFXII works almost 100% as well, but you must turn off the "Denormals are zero" from the down right box in advanced menu.




Users browsing this thread: 1 Guest(s)